aboutsummaryrefslogtreecommitdiff
path: root/security/zeronet/Makefile
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2016-06-14 17:03:42 +0000
committerKurt Jaeger <pi@FreeBSD.org>2016-06-14 17:03:42 +0000
commit29f3aeb81cf597dbf769ec6f2b3416895fd99c93 (patch)
tree09bdc18046e34a452fac56531c19c80bf83170a4 /security/zeronet/Makefile
parent38e97072cc34dd54a52ce840ed6df272db551863 (diff)
New port: security/zeronet
Open, free and uncensorable websites, using Bitcoin cryptography and BitTorrent network. Features: * Real-time updated sites * Namecoin .bit domains support * Easy to setup: unpack & run * Clone websites in one click * Password-less BIP32 based authorization: Your account is protected by the same cryptography as your Bitcoin wallet * Built-in SQL server with P2P data synchronization: Allows easier site development and faster page load times * Anonymity: Full Tor network support with .onion hidden services instead of IPv4 addresses * TLS encrypted connections * Automatic uPnP port opening * Plugin for multiuser (openproxy) support * Works with any browser/OS WWW: https://zeronet.io/ PR: 209735 Submitted by: Yuri Victorovich <yuri@rawbw.com>
Notes
Notes: svn path=/head/; revision=416899
Diffstat (limited to 'security/zeronet/Makefile')
-rw-r--r--security/zeronet/Makefile67
1 files changed, 67 insertions, 0 deletions
diff --git a/security/zeronet/Makefile b/security/zeronet/Makefile
new file mode 100644
index 000000000000..ccfc2f927e50
--- /dev/null
+++ b/security/zeronet/Makefile
@@ -0,0 +1,67 @@
+# Created by: Yuri Victorovich <yuri@rawbw.com>
+# $FreeBSD$
+
+PORTNAME= zeronet
+PORTVERSION= 0.3.7
+#DISTVERSIONPREFIX= v
+CATEGORIES= security net-p2p
+
+MAINTAINER= yuri@rawbw.com
+COMMENT= Decentralized websites using Bitcoin crypto and BitTorrent network
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}msgpack-python>0:devel/py-msgpack-python \
+ ${PYTHON_PKGNAMEPREFIX}gevent>=1.0.2:devel/py-gevent \
+ ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3
+
+USE_GITHUB= yes
+GH_ACCOUNT= HelloZeroNet
+GH_PROJECT= ZeroNet
+GH_TAGNAME= 523a7d4
+
+SUB_FILES= zeronet-service zeronet-cmd pkg-message
+SUB_LIST= LOCALBASE=${LOCALBASE} USER=${USER} GROUP=${GROUP}
+PLIST_SUB= USER=${USER} GROUP=${GROUP}
+
+USES= python
+NO_ARCH= yes
+
+OPTIONS_DEFINE= TOR DEBUG
+TOR_DESC= Enable TOR anonymity network integration
+
+TOR_RUN_DEPENDS= tor:security/tor
+DEBUG_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}werkzeug>0:www/py-werkzeug
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MTOR}
+USER= _tor
+GROUP= _tor
+.else
+USER= nobody
+GROUP= nobody
+.endif
+
+do-build:
+ @(cd ${WRKSRC} && \
+ ${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py \
+ -d ${WRKSRC} -f ${WRKSRC} && \
+ ${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py \
+ -d ${WRKSRC} -f ${WRKSRC})
+do-install:
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ @${CP} -R ${WRKSRC}/* ${STAGEDIR}${DATADIR}/
+ @${RM} `${FIND} ${STAGEDIR}${DATADIR} -name LICENSE`
+ @${RM} ${STAGEDIR}${DATADIR}/README.md ${STAGEDIR}${DATADIR}/requirements.txt
+ @${RM} ${STAGEDIR}${DATADIR}/Vagrantfile ${STAGEDIR}${DATADIR}/Dockerfile
+ @${RM} -r `${FIND} ${STAGEDIR}${DATADIR} -name test`
+ @${MKDIR} ${STAGEDIR}/var/db/zeronet
+ @${MKDIR} ${STAGEDIR}/var/log/zeronet
+ @${LN} -s /var/db/zeronet ${STAGEDIR}${DATADIR}/data
+ @${LN} -s /var/log/zeronet ${STAGEDIR}${DATADIR}/log
+ ${INSTALL_SCRIPT} ${WRKDIR}/zeronet-cmd ${STAGEDIR}${PREFIX}/bin/zeronet
+ ${INSTALL_SCRIPT} ${WRKDIR}/zeronet-service ${STAGEDIR}${PREFIX}/etc/rc.d/zeronet
+
+.include <bsd.port.mk>