aboutsummaryrefslogtreecommitdiff
path: root/security/zxid
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2008-04-18 07:58:33 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2008-04-18 07:58:33 +0000
commit6faad2c53eb66f06a022df23f4b2601f848abc2c (patch)
tree1efc980059fd85fd3f1424ce542ae826a2133d58 /security/zxid
parent1a22edb95f11c6f0e768a5262a5508afcabb4432 (diff)
downloadports-6faad2c53eb66f06a022df23f4b2601f848abc2c.tar.gz
ports-6faad2c53eb66f06a022df23f4b2601f848abc2c.zip
Notes
Diffstat (limited to 'security/zxid')
-rw-r--r--security/zxid/Makefile2
-rw-r--r--security/zxid/distinfo6
-rw-r--r--security/zxid/files/patch-Makefile37
3 files changed, 27 insertions, 18 deletions
diff --git a/security/zxid/Makefile b/security/zxid/Makefile
index b269f658c9f6..f0fd8225ea6a 100644
--- a/security/zxid/Makefile
+++ b/security/zxid/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= zxid
-PORTVERSION= 0.22
+PORTVERSION= 0.25
CATEGORIES= security www
MASTER_SITES= http://zxid.org/
EXTRACT_SUFX= .tgz
diff --git a/security/zxid/distinfo b/security/zxid/distinfo
index c1e8e510e424..46b23df2ac55 100644
--- a/security/zxid/distinfo
+++ b/security/zxid/distinfo
@@ -1,3 +1,3 @@
-MD5 (zxid-0.22.tgz) = 9c7d52080ce3b0111da2bef9513d5c88
-SHA256 (zxid-0.22.tgz) = 052de7fc4cef86ccc1a5526ad89362d52d6ea2afff70594763e7607035fc789e
-SIZE (zxid-0.22.tgz) = 2799246
+MD5 (zxid-0.25.tgz) = 118a0873632dc1186a37702586c4119c
+SHA256 (zxid-0.25.tgz) = feb68f1d646f6b792834c7d99eb9d8b9a20cb90af81f15037d0f5343b6c1b906
+SIZE (zxid-0.25.tgz) = 2803264
diff --git a/security/zxid/files/patch-Makefile b/security/zxid/files/patch-Makefile
index b571142a6f89..c419cd714f71 100644
--- a/security/zxid/files/patch-Makefile
+++ b/security/zxid/files/patch-Makefile
@@ -1,14 +1,14 @@
---- Makefile.orig Tue Mar 6 15:11:03 2007
-+++ Makefile Fri Jul 6 06:58:52 2007
-@@ -24,13 +24,13 @@
+--- Makefile.orig 2008-04-17 09:47:50.000000000 +0800
++++ Makefile 2008-04-18 15:30:13.000000000 +0800
+@@ -26,13 +26,13 @@
- default: seehelp zxid zxidhlo zxidhlowsf zxidsimple zxidwsctool zxlogview
+ default: seehelp zxid zxidsp zxidhlo zxidhlowsf zxidsimple zxidwsctool zxlogview zxidhrxmlwsc zxidhrxmlwsp
--all: seehelp zxid zxidhlo zxidsimple zxlogview samlmod phpzxid javazxid
-+all: seehelp zxid zxidhlo zxidsimple zxlogview
+-all: seehelp zxid zxidsp zxidhlo zxidsimple zxlogview samlmod phpzxid javazxid apachezxid
++all: seehelp zxid zxidsp zxidhlo zxidsimple zxlogview
- ZXIDREL=0.22
- ZXIDVERSION=0x000022
+ ZXIDREL=0.25
+ ZXIDVERSION=0x000025
### Where package is installed (use `make PREFIX=/your/path' to change)
-PREFIX=/usr/local/zxid/$(ZXIDREL)
@@ -16,7 +16,7 @@
### Where runtime configuration and temporary data is kept.
### If you change the following, be sure to edit zxidconf.h as well. N.B. Trailing / is needed.
-@@ -58,8 +58,8 @@
+@@ -60,8 +60,8 @@
###
TOP=$(shell pwd)
@@ -25,9 +25,9 @@
+CURL_ROOT?=/usr/local
+OPENSSL_ROOT?=/usr/local/ssl
PHP_CONFIG=php-config
- PERL=perl
- XSD2SG_PL= ../pd/xsd2sg.pl
-@@ -69,11 +69,11 @@
+ APACHE_ROOT=/usr/local/httpd
+
+@@ -75,11 +75,11 @@
SWIG=swig
AR=ar -crs
ARX=ar -x
@@ -42,9 +42,9 @@
+SHARED_CLOSE+=-Wl,-no-whole-archive
+CFLAGS+=-g -fpic -fmessage-length=0 -Wno-unused-label -Wno-unknown-pragmas -fno-strict-aliasing
#CFLAGS += -Os # gcc-3.4.6 miscompiles with -Os on ix86
- #CFLAGS += -Wall
+ CFLAGS += -Wall -Wno-parentheses -DMAYBE_UNUSED='__attribute__ ((unused))'
-@@ -105,7 +105,7 @@
+@@ -112,7 +112,7 @@
CDEF+= -DUSE_CURL
# Without OpenSSL signing and signature verification are not possible
CDEF+= -DUSE_OPENSSL
@@ -53,3 +53,12 @@
# Following ld flags as well as C flag -ffunction-sections are a quest to
# eliminate unused functions from final link.
+@@ -848,7 +848,7 @@
+ @$(ECHO)
+ @$(ECHO) "to make sure the zxid CGI script can write to the $(ZXID_PATH)"
+ @$(ECHO) "directory (substitute nobody with the user your web server runs as)."
+- @$(ECHO)/
++ @$(ECHO)
+
+ install: zxid libzxid.a libzxid.so.0.0 dir
+ @$(ECHO) "===== Installing in $(PREFIX) (to change do make install PREFIX=/your/path)"