aboutsummaryrefslogtreecommitdiff
path: root/security/zzuf/Makefile
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2007-03-06 05:36:34 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2007-03-06 05:36:34 +0000
commit5a4a332130a06d30b90eaf1dfbba8ed673db10c4 (patch)
tree6c69deedbde7d62f28e4bfa3a3ed1c7aa923fd46 /security/zzuf/Makefile
parentcd75a344584d9374d4d5fa5e3405bd9e8d87962f (diff)
Move zzuf-0.8.1 from devel/, transparent application input fuzzer.
Noted by: kris PR: ports/109829 Submitted by: Peter Johnson <johnson.peter at gmail.com>
Notes
Notes: svn path=/head/; revision=186633
Diffstat (limited to 'security/zzuf/Makefile')
-rw-r--r--security/zzuf/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/security/zzuf/Makefile b/security/zzuf/Makefile
new file mode 100644
index 000000000000..40aa55648f3c
--- /dev/null
+++ b/security/zzuf/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: zzuf
+# Date created: 2007-03-03
+# Whom: Peter Johnson <johnson.peter@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= zzuf
+PORTVERSION= 0.8.1
+CATEGORIES= security
+MASTER_SITES= http://sam.zoy.org/zzuf/
+
+MAINTAINER= johnson.peter@gmail.com
+COMMENT= Transparent application input fuzzer
+
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ARGS= --mandir=${MANPREFIX}/man
+USE_LDCONFIG= yes
+
+MAN1= zzuf.1
+
+post-install:
+ @${RM} -f ${PREFIX}/lib/zzuf/libzzuf.la
+
+.include <bsd.port.mk>