aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2011-06-27 02:57:29 +0000
committerSteve Wills <swills@FreeBSD.org>2011-06-27 02:57:29 +0000
commit2fe7b848d0b3569819cb637770c3e5fe901a4980 (patch)
tree23858fe8067053306c26fdfa4fe64404692448d2 /security
parent1020fcac76d3683fdf92908d3cb5bff0089da9d4 (diff)
downloadports-2fe7b848d0b3569819cb637770c3e5fe901a4980.tar.gz
ports-2fe7b848d0b3569819cb637770c3e5fe901a4980.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/apache-xml-security-c/Makefile8
-rw-r--r--security/apache-xml-security-c/distinfo5
-rw-r--r--security/apache-xml-security-c/pkg-plist9
-rw-r--r--security/opensaml2/Makefile5
-rw-r--r--security/opensaml2/distinfo5
-rw-r--r--security/opensaml2/pkg-plist8
-rw-r--r--security/shibboleth2-sp/Makefile5
-rw-r--r--security/shibboleth2-sp/distinfo5
-rw-r--r--security/shibboleth2-sp/pkg-plist68
9 files changed, 70 insertions, 48 deletions
diff --git a/security/apache-xml-security-c/Makefile b/security/apache-xml-security-c/Makefile
index f537a29f798c..22f0af32ebb7 100644
--- a/security/apache-xml-security-c/Makefile
+++ b/security/apache-xml-security-c/Makefile
@@ -6,9 +6,10 @@
#
PORTNAME= xml-security-c
-PORTVERSION= 1.4.0
+PORTVERSION= 1.6.0
CATEGORIES= security
-MASTER_SITES= http://santuario.apache.org/dist/c-library/
+MASTER_SITES= ${MASTER_SITE_APACHE}
+MASTER_SITE_SUBDIR=santuario/c-library
PKGNAMEPREFIX= apache-
MAINTAINER= janos.mohacsi@bsd.hu
@@ -16,6 +17,7 @@ COMMENT= Apache XML security libraries C version
OPTIONS= XERCES_DEVEL "With Xerces vesion 2.8 (shibboleth2 requires)" on
+USE_OPENSSL= yes
.include <bsd.port.pre.mk>
.if defined(WITH_XERCES_DEVEL)
@@ -29,5 +31,5 @@ CONFIGURE_ARGS+=--with-xerces=${LOCALBASE}
USE_AUTOTOOLS= libtool
USE_GMAKE= yes
USE_LDCONFIG= yes
-
+CONFIGURE_ARGS+=--with-openssl=${OPENSSLBASE}
.include <bsd.port.post.mk>
diff --git a/security/apache-xml-security-c/distinfo b/security/apache-xml-security-c/distinfo
index 1c0e3a46add1..e25a9ca7e9e5 100644
--- a/security/apache-xml-security-c/distinfo
+++ b/security/apache-xml-security-c/distinfo
@@ -1,3 +1,2 @@
-MD5 (xml-security-c-1.4.0.tar.gz) = dd9accf6727eb008dbf1dd674d5d4dcc
-SHA256 (xml-security-c-1.4.0.tar.gz) = 955c570a965ab58d021a797ad85ad052ec37d9b8739d9a926d1081fb96c6245f
-SIZE (xml-security-c-1.4.0.tar.gz) = 934876
+SHA256 (xml-security-c-1.6.0.tar.gz) = ccc8abe614bfed814bc772e3904ba1708b5984ec1245500a0be409f8195e0831
+SIZE (xml-security-c-1.6.0.tar.gz) = 865131
diff --git a/security/apache-xml-security-c/pkg-plist b/security/apache-xml-security-c/pkg-plist
index 0395773384ad..dc6d2c91ed3a 100644
--- a/security/apache-xml-security-c/pkg-plist
+++ b/security/apache-xml-security-c/pkg-plist
@@ -12,6 +12,8 @@ include/xsec/canon/XSECXMLNSStack.hpp
include/xsec/dsig/DSIGAlgorithmHandlerDefault.hpp
include/xsec/dsig/DSIGConstants.hpp
include/xsec/dsig/DSIGKeyInfo.hpp
+include/xsec/dsig/DSIGKeyInfoDEREncoded.hpp
+include/xsec/dsig/DSIGKeyInfoExt.hpp
include/xsec/dsig/DSIGKeyInfoList.hpp
include/xsec/dsig/DSIGKeyInfoMgmtData.hpp
include/xsec/dsig/DSIGKeyInfoName.hpp
@@ -46,6 +48,7 @@ include/xsec/enc/OpenSSL/OpenSSLCryptoBase64.hpp
include/xsec/enc/OpenSSL/OpenSSLCryptoHash.hpp
include/xsec/enc/OpenSSL/OpenSSLCryptoHashHMAC.hpp
include/xsec/enc/OpenSSL/OpenSSLCryptoKeyDSA.hpp
+include/xsec/enc/OpenSSL/OpenSSLCryptoKeyEC.hpp
include/xsec/enc/OpenSSL/OpenSSLCryptoKeyHMAC.hpp
include/xsec/enc/OpenSSL/OpenSSLCryptoKeyRSA.hpp
include/xsec/enc/OpenSSL/OpenSSLCryptoProvider.hpp
@@ -57,6 +60,7 @@ include/xsec/enc/XSECCryptoException.hpp
include/xsec/enc/XSECCryptoHash.hpp
include/xsec/enc/XSECCryptoKey.hpp
include/xsec/enc/XSECCryptoKeyDSA.hpp
+include/xsec/enc/XSECCryptoKeyEC.hpp
include/xsec/enc/XSECCryptoKeyHMAC.hpp
include/xsec/enc/XSECCryptoKeyRSA.hpp
include/xsec/enc/XSECCryptoProvider.hpp
@@ -75,6 +79,7 @@ include/xsec/framework/XSECException.hpp
include/xsec/framework/XSECProvider.hpp
include/xsec/framework/XSECURIResolver.hpp
include/xsec/framework/XSECURIResolverXerces.hpp
+include/xsec/framework/XSECVersion.hpp
include/xsec/framework/XSECW32Config.hpp
include/xsec/transformers/TXFMBase.hpp
include/xsec/transformers/TXFMBase64.hpp
@@ -93,6 +98,7 @@ include/xsec/transformers/TXFMURL.hpp
include/xsec/transformers/TXFMXPath.hpp
include/xsec/transformers/TXFMXPathFilter.hpp
include/xsec/transformers/TXFMXSL.hpp
+include/xsec/utils/XSECAutoPtr.hpp
include/xsec/utils/XSECBinTXFMInputStream.hpp
include/xsec/utils/XSECDOMUtils.hpp
include/xsec/utils/XSECNameSpaceExpander.hpp
@@ -153,9 +159,8 @@ include/xsec/xkms/XKMSValidateRequest.hpp
include/xsec/xkms/XKMSValidateResult.hpp
include/xsec/xkms/XKMSValidityInterval.hpp
lib/libxml-security-c.a
-lib/libxml-security-c.la
lib/libxml-security-c.so
-lib/libxml-security-c.so.14
+lib/libxml-security-c.so.16
@dirrm include/xsec/xkms
@dirrm include/xsec/xenc
@dirrm include/xsec/utils/unixutils
diff --git a/security/opensaml2/Makefile b/security/opensaml2/Makefile
index 9a1c655eafa6..d7a63e26253c 100644
--- a/security/opensaml2/Makefile
+++ b/security/opensaml2/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= opensaml2
-PORTVERSION= 2.3
-PORTREVISION= 1
+PORTVERSION= 2.4.1
CATEGORIES= security
MASTER_SITES= http://shibboleth.internet2.edu/downloads/opensaml/cpp/${PORTVERSION}/
DISTNAME= opensaml-${PORTVERSION}
@@ -18,7 +17,7 @@ COMMENT= Open source implentation of SAML2
LIB_DEPENDS= curl.6:${PORTSDIR}/ftp/curl \
log4shib.1:${PORTSDIR}/devel/log4shib \
xerces-c.28:${PORTSDIR}/textproc/xerces-c2-devel \
- xmltooling.4:${PORTSDIR}/devel/xmltooling
+ xmltooling.5:${PORTSDIR}/devel/xmltooling
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--with-log4shib=${LOCALBASE} --with-openssl=${OPENSSLBASE} \
diff --git a/security/opensaml2/distinfo b/security/opensaml2/distinfo
index 1598d65118a9..61d887aa3eb8 100644
--- a/security/opensaml2/distinfo
+++ b/security/opensaml2/distinfo
@@ -1,3 +1,2 @@
-MD5 (opensaml-2.3.tar.gz) = 9695d40cb28519c2cde8211cd1c3dc69
-SHA256 (opensaml-2.3.tar.gz) = 027b3b9a6f5c147dd434d52e674ca238672412595dfa18675a70bafc5495e2fd
-SIZE (opensaml-2.3.tar.gz) = 926057
+SHA256 (opensaml-2.4.1.tar.gz) = 89289f882da19bab5d1476943d75c2f7fa97776980bfa86c7395b573603a2ecb
+SIZE (opensaml-2.4.1.tar.gz) = 870509
diff --git a/security/opensaml2/pkg-plist b/security/opensaml2/pkg-plist
index f0682f3e9556..00c8c06581ba 100644
--- a/security/opensaml2/pkg-plist
+++ b/security/opensaml2/pkg-plist
@@ -22,6 +22,7 @@ include/saml/saml2/binding/SAML2SOAPClient.h
include/saml/saml2/core/Assertions.h
include/saml/saml2/core/Protocols.h
include/saml/saml2/metadata/AbstractMetadataProvider.h
+include/saml/saml2/metadata/DiscoverableMetadataProvider.h
include/saml/saml2/metadata/DynamicMetadataProvider.h
include/saml/saml2/metadata/EndpointManager.h
include/saml/saml2/metadata/Metadata.h
@@ -45,8 +46,9 @@ include/saml/signature/SignableObject.h
include/saml/signature/SignatureProfileValidator.h
include/saml/util/CommonDomainCookie.h
include/saml/util/SAMLConstants.h
-lib/libsaml.so.6
+lib/libsaml.so.7
lib/libsaml.so
+libdata/pkgconfig/opensaml.pc
%%PORTDOCS%%%%DOCSDIR%%/README.txt
%%PORTDOCS%%%%DOCSDIR%%/LICENSE.txt
%%PORTDOCS%%%%DOCSDIR%%/NOTICE.txt
@@ -55,8 +57,12 @@ share/xml/opensaml/saml20-catalog.xml
share/xml/opensaml/saml10-catalog.xml
share/xml/opensaml/saml11-catalog.xml
share/xml/opensaml/sstc-metadata-attr.xsd
+share/xml/opensaml/sstc-request-initiation.xsd
share/xml/opensaml/sstc-saml-attribute-ext.xsd
share/xml/opensaml/sstc-saml-delegation.xsd
+share/xml/opensaml/sstc-saml-idp-discovery.xsd
+share/xml/opensaml/sstc-saml-metadata-algsupport-v1.0.xsd
+share/xml/opensaml/sstc-saml-metadata-ui-v1.0.xsd
share/xml/opensaml/cs-sstc-schema-assertion-01.xsd
share/xml/opensaml/cs-sstc-schema-protocol-01.xsd
share/xml/opensaml/cs-sstc-schema-assertion-1.1.xsd
diff --git a/security/shibboleth2-sp/Makefile b/security/shibboleth2-sp/Makefile
index 4847843c807c..241fa2e1a5c4 100644
--- a/security/shibboleth2-sp/Makefile
+++ b/security/shibboleth2-sp/Makefile
@@ -6,15 +6,14 @@
#
PORTNAME= shibboleth-sp
-PORTVERSION= 2.3.1
-PORTREVISION= 2
+PORTVERSION= 2.4.2
CATEGORIES= security www
MASTER_SITES= http://shibboleth.internet2.edu/downloads/shibboleth/cppsp/${PORTVERSION}/
MAINTAINER= janos.mohacsi@bsd.hu
COMMENT= C++ Shibboleth Service Provider (Internet2) for Apache
-LIB_DEPENDS= saml.6:${PORTSDIR}/security/opensaml2
+LIB_DEPENDS= saml.7:${PORTSDIR}/security/opensaml2
OPTIONS= APACHE22 "Use Apache version 2.2 instead of version 2.0" on
diff --git a/security/shibboleth2-sp/distinfo b/security/shibboleth2-sp/distinfo
index 50667b9b8b97..1981417286ff 100644
--- a/security/shibboleth2-sp/distinfo
+++ b/security/shibboleth2-sp/distinfo
@@ -1,3 +1,2 @@
-MD5 (shibboleth-sp-2.3.1.tar.gz) = a292f1cc0aab3cfe3ecec0e9b2b30a10
-SHA256 (shibboleth-sp-2.3.1.tar.gz) = d1d0a3de0a9c383d1210fde7a7e60e464096950337512cab667f924322a122e2
-SIZE (shibboleth-sp-2.3.1.tar.gz) = 806177
+SHA256 (shibboleth-sp-2.4.2.tar.gz) = 1e3c3281c8c0d9a1cec77eb62f89dd9d11ad83ec0dca2d12e195ace68aff8579
+SIZE (shibboleth-sp-2.4.2.tar.gz) = 854404
diff --git a/security/shibboleth2-sp/pkg-plist b/security/shibboleth2-sp/pkg-plist
index 72fb806408b9..75e2fa558f6e 100644
--- a/security/shibboleth2-sp/pkg-plist
+++ b/security/shibboleth2-sp/pkg-plist
@@ -49,6 +49,15 @@ etc/shibboleth/globalLogout.html.dist
@unexec if cmp -s %D/etc/shibboleth/sslError.html.dist %D/etc/shibboleth/sslError.html; then rm -f %D/etc/shibboleth/sslError.html; fi
etc/shibboleth/sslError.html.dist
@exec if [ ! -f %D/etc/shibboleth/sslError.html ] ; then cp -p %D/etc/shibboleth/sslError.html.dist %D/etc/shibboleth/sslError.html; fi
+@unexec if cmp -s %D/etc/shibboleth/example-shibboleth2.xml.dist %D/etc/shibboleth/example-shibboleth2.xml; then rm -f %D/etc/shibboleth/example-shibboleth2.xml; fi
+etc/shibboleth/example-shibboleth2.xml.dist
+@exec if [ ! -f %D/etc/shibboleth/example-shibboleth2.xml ] ; then cp -p %D/etc/shibboleth/example-shibboleth2.xml.dist %D/etc/shibboleth/example-shibboleth2.xml; fi
+@unexec if cmp -s %D/etc/shibboleth/protocols.xml.dist %D/etc/shibboleth/protocols.xml; then rm -f %D/etc/shibboleth/protocols.xml; fi
+etc/shibboleth/protocols.xml.dist
+@exec if [ ! -f %D/etc/shibboleth/protocols.xml ] ; then cp -p %D/etc/shibboleth/protocols.xml.dist %D/etc/shibboleth/protocols.xml; fi
+@unexec if cmp -s %D/etc/shibboleth/security-policy.xml.dist %D/etc/shibboleth/security-policy.xml; then rm -f %D/etc/shibboleth/security-policy.xml; fi
+etc/shibboleth/security-policy.xml.dist
+@exec if [ ! -f %D/etc/shibboleth/security-policy.xml ] ; then cp -p %D/etc/shibboleth/security-policy.xml.dist %D/etc/shibboleth/security-policy.xml; fi
etc/shibboleth/shibd-redhat
etc/shibboleth/shibd-debian
etc/shibboleth/shibd-suse
@@ -66,57 +75,61 @@ etc/shibboleth/postTemplate.html.dist
@unexec if cmp -s %D/etc/shibboleth/partialLogout.html.dist %D/etc/shibboleth/partialLogout.html; then rm -f %D/etc/shibboleth/partialLogout.html; fi
etc/shibboleth/partialLogout.html.dist
@exec if [ ! -f %D/etc/shibboleth/partialLogout.html ] ; then cp -p %D/etc/shibboleth/partialLogout.html.dist %D/etc/shibboleth/partialLogout.html; fi
-include/shibsp/attribute/filtering/AttributeFilter.h
-include/shibsp/attribute/filtering/BasicFilteringContext.h
-include/shibsp/attribute/filtering/FilteringContext.h
-include/shibsp/attribute/filtering/FilterPolicyContext.h
-include/shibsp/attribute/filtering/MatchFunctor.h
-include/shibsp/attribute/ExtensibleAttribute.h
+include/shibsp/AbstractSPRequest.h
+include/shibsp/AccessControl.h
+include/shibsp/Application.h
+include/shibsp/GSSRequest.h
+include/shibsp/RequestMapper.h
+include/shibsp/SPConfig.h
+include/shibsp/SPRequest.h
+include/shibsp/ServiceProvider.h
+include/shibsp/SessionCache.h
+include/shibsp/SessionCacheEx.h
+include/shibsp/TransactionLog.h
include/shibsp/attribute/Attribute.h
include/shibsp/attribute/AttributeDecoder.h
+include/shibsp/attribute/ExtensibleAttribute.h
include/shibsp/attribute/NameIDAttribute.h
include/shibsp/attribute/ScopedAttribute.h
include/shibsp/attribute/SimpleAttribute.h
include/shibsp/attribute/XMLAttribute.h
+include/shibsp/attribute/filtering/AttributeFilter.h
+include/shibsp/attribute/filtering/BasicFilteringContext.h
+include/shibsp/attribute/filtering/FilterPolicyContext.h
+include/shibsp/attribute/filtering/FilteringContext.h
+include/shibsp/attribute/filtering/MatchFunctor.h
include/shibsp/attribute/resolver/AttributeExtractor.h
include/shibsp/attribute/resolver/AttributeResolver.h
include/shibsp/attribute/resolver/ResolutionContext.h
+include/shibsp/base.h
include/shibsp/binding/ArtifactResolver.h
+include/shibsp/binding/ProtocolProvider.h
include/shibsp/binding/SOAPClient.h
+include/shibsp/exceptions.h
include/shibsp/handler/AbstractHandler.h
include/shibsp/handler/AssertionConsumerService.h
include/shibsp/handler/Handler.h
include/shibsp/handler/LogoutHandler.h
+include/shibsp/handler/LogoutInitiator.h
include/shibsp/handler/RemotedHandler.h
include/shibsp/handler/SessionInitiator.h
-include/shibsp/AbstractSPRequest.h
-include/shibsp/AccessControl.h
-include/shibsp/Application.h
-include/shibsp/base.h
-include/shibsp/exceptions.h
-include/shibsp/paths.h
-include/shibsp/RequestMapper.h
-include/shibsp/ServiceProvider.h
-include/shibsp/SessionCache.h
-include/shibsp/SessionCacheEx.h
-include/shibsp/SPConfig.h
-include/shibsp/SPRequest.h
-include/shibsp/TransactionLog.h
-include/shibsp/version.h
include/shibsp/lite/CommonDomainCookie.h
include/shibsp/lite/SAMLConstants.h
include/shibsp/metadata/MetadataExt.h
include/shibsp/metadata/MetadataProviderCriteria.h
-include/shibsp/remoting/ddf.h
+include/shibsp/paths.h
include/shibsp/remoting/ListenerService.h
+include/shibsp/remoting/ddf.h
include/shibsp/security/PKIXTrustEngine.h
include/shibsp/security/SecurityPolicy.h
+include/shibsp/security/SecurityPolicyProvider.h
include/shibsp/util/CGIParser.h
include/shibsp/util/DOMPropertySet.h
include/shibsp/util/PropertySet.h
include/shibsp/util/SPConstants.h
include/shibsp/util/TemplateParameters.h
-lib/libshibsp.so.4
+include/shibsp/version.h
+lib/libshibsp.so.5
lib/libshibsp.so
lib/shibboleth/adfs.so
lib/shibboleth/adfs.la
@@ -126,18 +139,19 @@ lib/shibboleth/adfs-lite.la
%%WITH_APACHE_22%%lib/shibboleth/mod_shib_22.la
%%WITH_APACHE_20%%lib/shibboleth/mod_shib_20.so
%%WITH_APACHE_20%%lib/shibboleth/mod_shib_20.la
-lib/libshibsp-lite.so.4
+lib/libshibsp-lite.so.5
lib/libshibsp-lite.so
sbin/shibd
share/xml/shibboleth/catalog.xml
-share/xml/shibboleth/shibboleth.xsd
-share/xml/shibboleth/shibboleth-metadata-1.0.xsd
-share/xml/shibboleth/shibboleth-2.0-native-sp-config.xsd
-share/xml/shibboleth/shibboleth-2.0-afp.xsd
share/xml/shibboleth/shibboleth-2.0-afp-mf-basic.xsd
share/xml/shibboleth/shibboleth-2.0-afp-mf-saml.xsd
+share/xml/shibboleth/shibboleth-2.0-afp.xsd
share/xml/shibboleth/shibboleth-2.0-attribute-map.xsd
+share/xml/shibboleth/shibboleth-2.0-native-sp-config.xsd
+share/xml/shibboleth/shibboleth-2.0-native-sp-protocols.xsd
share/xml/shibboleth/shibboleth-2.0-sp-notify.xsd
+share/xml/shibboleth/shibboleth-metadata-1.0.xsd
+share/xml/shibboleth/shibboleth.xsd
share/xml/shibboleth/WS-Trust.xsd
share/doc/shibboleth/CREDITS.txt
share/doc/shibboleth/LICENSE.txt