aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorRoman Bogorodskiy <novel@FreeBSD.org>2005-11-28 10:07:51 +0000
committerRoman Bogorodskiy <novel@FreeBSD.org>2005-11-28 10:07:51 +0000
commit4de7513dc037bd88007ed03adb392428bbe1603a (patch)
treeee6fd40fd68c7931554562b4e31d3ce57a5d8e6e /security
parent20346564c3ddb6fbad1f80864d724fc118e6f528 (diff)
downloadports-4de7513dc037bd88007ed03adb392428bbe1603a.tar.gz
ports-4de7513dc037bd88007ed03adb392428bbe1603a.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/gnutls-devel/Makefile71
-rw-r--r--security/gnutls-devel/Makefile.man380
-rw-r--r--security/gnutls-devel/distinfo3
-rw-r--r--security/gnutls-devel/pkg-descr17
-rw-r--r--security/gnutls-devel/pkg-plist54
6 files changed, 526 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index d5231c1c2980..74fa1e212240 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -132,6 +132,7 @@
SUBDIR += gnupg-devel
SUBDIR += gnupg-idea
SUBDIR += gnutls
+ SUBDIR += gnutls-devel
SUBDIR += gpa
SUBDIR += gpasman
SUBDIR += gpgme
diff --git a/security/gnutls-devel/Makefile b/security/gnutls-devel/Makefile
new file mode 100644
index 000000000000..527b9d7f026c
--- /dev/null
+++ b/security/gnutls-devel/Makefile
@@ -0,0 +1,71 @@
+# New ports collection makefile for: gnutls
+# Date created: 13 Nov 2002
+# Whom: Sergei Kolobov <sergei@kolobov.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gnutls-devel
+PORTVERSION= 1.3.0
+CATEGORIES= security net
+MASTER_SITES= ${MASTER_SITE_GNUPG} \
+ http://www.mirrors.wiretapped.net/security/network-security/gnutls/ \
+ ftp://ftp.mirrors.wiretapped.net/security/network-security/gnutls/ \
+ http://josefsson.org/gnutls/releases/ \
+ ftp://ftp.gnutls.org/pub/gnutls/
+MASTER_SITE_SUBDIR= alpha/gnutls
+
+MAINTAINER= novel@FreeBSD.org
+COMMENT= GNU Transport Layer Security library
+
+BUILD_DEPENDS= ${LOCALBASE}/bin/makeinfo:${PORTSDIR}/print/texinfo
+LIB_DEPENDS= gcrypt.13:${PORTSDIR}/security/libgcrypt \
+ gpg-error.1:${PORTSDIR}/security/libgpg-error
+
+.if defined(WITH_OPENCDK) || exists(${LOCALBASE}/lib/libopencdk.so.8)
+LIB_DEPENDS+= opencdk.8:${PORTSDIR}/security/opencdk
+.endif
+
+.if defined(WITH_LIBTASN1) || exists(${LOCALBASE}/lib/libtasn1.so.2)
+LIB_DEPENDS+= tasn1.2:${PORTSDIR}/security/libtasn1
+.endif
+
+CONFLICTS= gnutls-[0-9]*
+
+USE_BZIP2= yes
+USE_ICONV= yes
+USE_GETTEXT= yes
+USE_GNOME= pkgconfig
+USE_REINPLACE= yes
+USE_AUTOTOOLS= libtool:15:inc
+INSTALLS_SHLIB= yes
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+MAKE_ARGS= MAKEINFO="${PREFIX}/bin/makeinfo"
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}" \
+ MAKEINFO="${PREFIX}/bin/makeinfo"
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ARGS= --with-included-lzo --disable-static
+MANCOMPRESSED= no
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= AUTHORS NEWS README THANKS
+.endif
+EXAMPLES= doc/examples/*.c
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,(libdir)/pkgconfig,(prefix)/libdata/pkgconfig,' \
+ ${WRKSRC}/lib/Makefile.in ${WRKSRC}/libextra/Makefile.in
+
+post-install:
+ @${MKDIR} ${EXAMPLESDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${EXAMPLES} ${EXAMPLESDIR}
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for i in ${PORTDOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+.endfor
+.endif
+
+.include "Makefile.man"
+.include <bsd.port.mk>
diff --git a/security/gnutls-devel/Makefile.man b/security/gnutls-devel/Makefile.man
new file mode 100644
index 000000000000..21318eb4222a
--- /dev/null
+++ b/security/gnutls-devel/Makefile.man
@@ -0,0 +1,380 @@
+# vi:ft=make
+# $FreeBSD$
+
+INFO= gnutls
+
+MAN1= certtool.1 \
+ gnutls-cli.1 \
+ gnutls-cli-debug.1 \
+ gnutls-serv.1 \
+ psktool.1 \
+ srptool.1
+
+MAN3= gnutls_hex_decode.3 \
+ gnutls_hex_encode.3 \
+ gnutls_srp_base64_encode.3 \
+ gnutls_srp_base64_encode_alloc.3 \
+ gnutls_srp_base64_decode.3 \
+ gnutls_srp_base64_decode_alloc.3 \
+ gnutls_server_name_get.3 \
+ gnutls_server_name_set.3 \
+ gnutls_alert_get_name.3 \
+ gnutls_alert_send.3 \
+ gnutls_error_to_alert.3 \
+ gnutls_alert_send_appropriate.3 \
+ gnutls_alert_get.3 \
+ gnutls_mac_get_name.3 \
+ gnutls_compression_get_name.3 \
+ gnutls_cipher_get_key_size.3 \
+ gnutls_cipher_get_name.3 \
+ gnutls_kx_get_name.3 \
+ gnutls_protocol_get_name.3 \
+ gnutls_cipher_suite_get_name.3 \
+ gnutls_perror.3 \
+ gnutls_certificate_type_get_name.3 \
+ gnutls_sign_algorithm_get_name.3 \
+ gnutls_pk_algorithm_get_name.3 \
+ gnutls_anon_free_server_credentials.3 \
+ gnutls_anon_allocate_server_credentials.3 \
+ gnutls_anon_free_client_credentials.3 \
+ gnutls_anon_allocate_client_credentials.3 \
+ gnutls_credentials_clear.3 \
+ gnutls_credentials_set.3 \
+ gnutls_auth_get_type.3 \
+ gnutls_auth_server_get_type.3 \
+ gnutls_auth_client_get_type.3 \
+ gnutls_record_check_pending.3 \
+ gnutls_certificate_free_keys.3 \
+ gnutls_certificate_free_cas.3 \
+ gnutls_certificate_free_ca_names.3 \
+ gnutls_certificate_free_credentials.3 \
+ gnutls_certificate_allocate_credentials.3 \
+ gnutls_certificate_server_set_request.3 \
+ gnutls_certificate_client_set_retrieve_function.3 \
+ gnutls_certificate_server_set_retrieve_function.3 \
+ gnutls_certificate_verify_peers.3 \
+ gnutls_certificate_verify_peers2.3 \
+ gnutls_db_set_ptr.3 \
+ gnutls_certificate_expiration_time_peers.3 \
+ gnutls_certificate_activation_time_peers.3 \
+ gnutls_db_set_retrieve_function.3 \
+ gnutls_db_set_remove_function.3 \
+ gnutls_db_set_store_function.3 \
+ gnutls_db_get_ptr.3 \
+ gnutls_db_set_cache_expiration.3 \
+ gnutls_db_check_entry.3 \
+ gnutls_db_remove_session.3 \
+ gnutls_dh_params_import_raw.3 \
+ gnutls_dh_params_init.3 \
+ gnutls_dh_params_deinit.3 \
+ gnutls_dh_params_cpy.3 \
+ gnutls_dh_params_generate2.3 \
+ gnutls_dh_params_import_pkcs3.3 \
+ gnutls_dh_params_export_pkcs3.3 \
+ gnutls_dh_params_export_raw.3 \
+ gnutls_error_is_fatal.3 \
+ gnutls_strerror.3 \
+ gnutls_global_set_log_function.3 \
+ gnutls_global_set_log_level.3 \
+ gnutls_global_set_mem_functions.3 \
+ gnutls_global_init.3 \
+ gnutls_global_deinit.3 \
+ gnutls_transport_set_pull_function.3 \
+ gnutls_transport_set_push_function.3 \
+ gnutls_check_version.3 \
+ gnutls_rehandshake.3 \
+ gnutls_handshake.3 \
+ gnutls_handshake_set_max_packet_length.3 \
+ gnutls_handshake_get_last_in.3 \
+ gnutls_handshake_get_last_out.3 \
+ gnutls_malloc.3 \
+ gnutls_free.3 \
+ gnutls_cipher_set_priority.3 \
+ gnutls_kx_set_priority.3 \
+ gnutls_mac_set_priority.3 \
+ gnutls_compression_set_priority.3 \
+ gnutls_protocol_set_priority.3 \
+ gnutls_set_default_priority.3 \
+ gnutls_certificate_type_set_priority.3 \
+ gnutls_set_default_export_priority.3 \
+ gnutls_protocol_get_version.3 \
+ gnutls_transport_set_lowat.3 \
+ gnutls_transport_set_ptr.3 \
+ gnutls_transport_set_ptr2.3 \
+ gnutls_transport_get_ptr.3 \
+ gnutls_transport_get_ptr2.3 \
+ gnutls_bye.3 \
+ gnutls_record_send.3 \
+ gnutls_record_recv.3 \
+ gnutls_record_get_max_size.3 \
+ gnutls_record_set_max_size.3 \
+ gnutls_kx_get.3 \
+ gnutls_rsa_params_import_raw.3 \
+ gnutls_rsa_params_init.3 \
+ gnutls_rsa_params_deinit.3 \
+ gnutls_rsa_params_cpy.3 \
+ gnutls_rsa_params_generate2.3 \
+ gnutls_rsa_params_import_pkcs1.3 \
+ gnutls_rsa_params_export_pkcs1.3 \
+ gnutls_rsa_params_export_raw.3 \
+ gnutls_session_get_data.3 \
+ gnutls_session_get_data2.3 \
+ gnutls_session_get_id.3 \
+ gnutls_session_set_data.3 \
+ gnutls_srp_free_client_credentials.3 \
+ gnutls_srp_set_client_credentials.3 \
+ gnutls_srp_allocate_client_credentials.3 \
+ gnutls_srp_free_server_credentials.3 \
+ gnutls_srp_allocate_server_credentials.3 \
+ gnutls_srp_set_server_credentials_file.3 \
+ gnutls_srp_set_server_credentials_function.3 \
+ gnutls_srp_set_client_credentials_function.3 \
+ gnutls_srp_server_get_username.3 \
+ gnutls_srp_verifier.3 \
+ gnutls_cipher_get.3 \
+ gnutls_certificate_type_get.3 \
+ gnutls_mac_get.3 \
+ gnutls_init.3 \
+ gnutls_compression_get.3 \
+ gnutls_deinit.3 \
+ gnutls_openpgp_send_key.3 \
+ gnutls_certificate_send_x509_rdn_sequence.3 \
+ gnutls_handshake_set_private_extensions.3 \
+ gnutls_session_is_resumed.3 \
+ gnutls_session_get_ptr.3 \
+ gnutls_session_set_ptr.3 \
+ gnutls_record_get_direction.3 \
+ gnutls_dh_get_group.3 \
+ gnutls_dh_get_pubkey.3 \
+ gnutls_dh_get_prime_bits.3 \
+ gnutls_rsa_export_get_pubkey.3 \
+ gnutls_dh_get_secret_bits.3 \
+ gnutls_dh_set_prime_bits.3 \
+ gnutls_rsa_export_get_modulus_bits.3 \
+ gnutls_dh_get_peers_public_bits.3 \
+ gnutls_certificate_get_ours.3 \
+ gnutls_certificate_get_peers.3 \
+ gnutls_certificate_client_get_request_status.3 \
+ gnutls_fingerprint.3 \
+ gnutls_anon_set_server_dh_params.3 \
+ gnutls_certificate_set_dh_params.3 \
+ gnutls_certificate_free_crls.3 \
+ gnutls_anon_set_params_function.3 \
+ gnutls_certificate_set_verify_flags.3 \
+ gnutls_certificate_set_verify_limits.3 \
+ gnutls_certificate_set_params_function.3 \
+ gnutls_certificate_set_rsa_export_params.3 \
+ gnutls_certificate_set_x509_key_mem.3 \
+ gnutls_certificate_set_x509_key.3 \
+ gnutls_certificate_set_x509_key_file.3 \
+ gnutls_certificate_set_x509_trust_mem.3 \
+ gnutls_certificate_set_x509_trust.3 \
+ gnutls_certificate_set_x509_trust_file.3 \
+ gnutls_pem_base64_encode.3 \
+ gnutls_certificate_set_x509_crl_mem.3 \
+ gnutls_certificate_set_x509_crl.3 \
+ gnutls_certificate_set_x509_crl_file.3 \
+ gnutls_pem_base64_encode_alloc.3 \
+ gnutls_pem_base64_decode.3 \
+ gnutls_pem_base64_decode_alloc.3 \
+ gnutls_global_init_extra.3 \
+ gnutls_extra_check_version.3 \
+ gnutls_certificate_set_openpgp_key_mem.3 \
+ gnutls_certificate_set_openpgp_key_file.3 \
+ gnutls_certificate_set_openpgp_keyring_file.3 \
+ gnutls_certificate_set_openpgp_keyring_mem.3 \
+ gnutls_certificate_set_openpgp_keyserver.3 \
+ gnutls_certificate_set_openpgp_trustdb.3 \
+ gnutls_openpgp_set_recv_key_function.3 \
+ gnutls_certificate_set_openpgp_key.3 \
+ gnutls_x509_dn_oid_known.3 \
+ gnutls_x509_crl_init.3 \
+ gnutls_x509_crl_deinit.3 \
+ gnutls_x509_crl_import.3 \
+ gnutls_x509_crl_get_issuer_dn_by_oid.3 \
+ gnutls_pkcs7_init.3 \
+ gnutls_x509_crl_get_dn_oid.3 \
+ gnutls_x509_crl_get_signature_algorithm.3 \
+ gnutls_x509_crl_get_this_update.3 \
+ gnutls_x509_crl_get_next_update.3 \
+ gnutls_x509_crl_get_crt_count.3 \
+ gnutls_x509_crl_sign.3 \
+ gnutls_x509_crl_set_this_update.3 \
+ gnutls_x509_crl_set_next_update.3 \
+ gnutls_x509_crl_set_crt.3 \
+ gnutls_x509_crq_init.3 \
+ gnutls_x509_crq_deinit.3 \
+ gnutls_x509_crq_import.3 \
+ gnutls_x509_crq_get_dn.3 \
+ gnutls_x509_crq_get_dn_by_oid.3 \
+ gnutls_x509_crq_get_challenge_password.3 \
+ gnutls_x509_crq_set_attribute_by_oid.3 \
+ gnutls_x509_crq_get_attribute_by_oid.3 \
+ gnutls_x509_crq_set_dn_by_oid.3 \
+ gnutls_x509_crq_set_version.3 \
+ gnutls_x509_crq_get_version.3 \
+ gnutls_x509_crq_set_key.3 \
+ gnutls_x509_crq_set_challenge_password.3 \
+ gnutls_x509_crq_sign2.3 \
+ gnutls_x509_crq_sign.3 \
+ gnutls_x509_crq_export.3 \
+ gnutls_x509_crq_get_pk_algorithm.3 \
+ gnutls_x509_rdn_get_by_oid.3 \
+ gnutls_x509_rdn_get_oid.3 \
+ gnutls_pkcs12_bag_init.3 \
+ gnutls_pkcs12_bag_deinit.3 \
+ gnutls_pkcs12_bag_get_count.3 \
+ gnutls_pkcs12_bag_get_data.3 \
+ gnutls_pkcs12_bag_set_data.3 \
+ gnutls_pkcs12_bag_set_crl.3 \
+ gnutls_pkcs12_bag_set_key_id.3 \
+ gnutls_pkcs12_bag_get_key_id.3 \
+ gnutls_pkcs12_bag_get_friendly_name.3 \
+ gnutls_pkcs12_bag_set_friendly_name.3 \
+ gnutls_pkcs12_init.3 \
+ gnutls_pkcs12_bag_encrypt.3 \
+ gnutls_pkcs12_deinit.3 \
+ gnutls_pkcs12_import.3 \
+ gnutls_pkcs12_export.3 \
+ gnutls_pkcs12_get_bag.3 \
+ gnutls_pkcs12_set_bag.3 \
+ gnutls_pkcs12_generate_mac.3 \
+ gnutls_pkcs12_verify_mac.3 \
+ gnutls_pkcs7_deinit.3 \
+ gnutls_pkcs7_import.3 \
+ gnutls_pkcs7_get_crt_raw.3 \
+ gnutls_pkcs7_get_crt_count.3 \
+ gnutls_pkcs7_set_crt_raw.3 \
+ gnutls_pkcs7_set_crt.3 \
+ gnutls_pkcs7_delete_crt.3 \
+ gnutls_pkcs7_get_crl_raw.3 \
+ gnutls_pkcs7_get_crl_count.3 \
+ gnutls_pkcs7_set_crl_raw.3 \
+ gnutls_pkcs7_set_crl.3 \
+ gnutls_pkcs12_bag_get_type.3 \
+ gnutls_pkcs12_bag_set_crt.3 \
+ gnutls_pkcs12_bag_decrypt.3 \
+ gnutls_pkcs7_export.3 \
+ gnutls_pkcs7_delete_crl.3 \
+ gnutls_x509_crl_get_issuer_dn.3 \
+ gnutls_x509_crl_get_version.3 \
+ gnutls_x509_crl_get_crt_serial.3 \
+ gnutls_x509_crl_export.3 \
+ gnutls_x509_crl_set_version.3 \
+ gnutls_x509_crl_sign2.3 \
+ gnutls_x509_crl_set_crt_serial.3 \
+ gnutls_x509_crq_get_dn_oid.3 \
+ gnutls_x509_rdn_get.3 \
+ gnutls_x509_privkey_init.3 \
+ gnutls_x509_privkey_deinit.3 \
+ gnutls_x509_privkey_import_rsa_raw.3 \
+ gnutls_x509_privkey_cpy.3 \
+ gnutls_x509_privkey_import.3 \
+ gnutls_x509_privkey_import_dsa_raw.3 \
+ gnutls_x509_privkey_get_pk_algorithm.3 \
+ gnutls_x509_privkey_export.3 \
+ gnutls_x509_privkey_export_rsa_raw.3 \
+ gnutls_x509_privkey_export_dsa_raw.3 \
+ gnutls_x509_privkey_generate.3 \
+ gnutls_x509_privkey_get_key_id.3 \
+ gnutls_x509_privkey_sign_data.3 \
+ gnutls_x509_privkey_verify_data.3 \
+ gnutls_x509_privkey_fix.3 \
+ gnutls_x509_privkey_export_pkcs8.3 \
+ gnutls_x509_privkey_import_pkcs8.3 \
+ gnutls_x509_crl_check_issuer.3 \
+ gnutls_x509_crl_verify.3 \
+ gnutls_x509_crt_init.3 \
+ gnutls_x509_crt_deinit.3 \
+ gnutls_x509_crt_import.3 \
+ gnutls_x509_crt_get_issuer_dn.3 \
+ gnutls_x509_crt_get_issuer_dn_by_oid.3 \
+ gnutls_x509_crt_get_issuer_dn_oid.3 \
+ gnutls_x509_crt_get_dn.3 \
+ gnutls_x509_crt_get_dn_oid.3 \
+ gnutls_x509_crt_get_signature_algorithm.3 \
+ gnutls_x509_crt_get_version.3 \
+ gnutls_x509_crt_get_activation_time.3 \
+ gnutls_x509_crt_get_expiration_time.3 \
+ gnutls_x509_crt_get_serial.3 \
+ gnutls_x509_crt_get_subject_key_id.3 \
+ gnutls_x509_crt_get_authority_key_id.3 \
+ gnutls_x509_crt_get_pk_algorithm.3 \
+ gnutls_x509_crt_get_subject_alt_name.3 \
+ gnutls_x509_crt_get_ca_status.3 \
+ gnutls_x509_crt_get_key_usage.3 \
+ gnutls_x509_crt_get_extension_by_oid.3 \
+ gnutls_x509_crt_get_extension_oid.3 \
+ gnutls_x509_crt_export.3 \
+ gnutls_x509_crt_get_key_id.3 \
+ gnutls_x509_crt_check_revocation.3 \
+ gnutls_x509_crt_verify_data.3 \
+ gnutls_x509_crt_get_crl_dist_points.3 \
+ gnutls_x509_crt_get_key_purpose_oid.3 \
+ gnutls_x509_crt_check_hostname.3 \
+ gnutls_x509_crt_check_issuer.3 \
+ gnutls_x509_crt_list_verify.3 \
+ gnutls_x509_crt_verify.3 \
+ gnutls_x509_crt_get_dn_by_oid.3 \
+ gnutls_x509_crt_get_fingerprint.3 \
+ gnutls_x509_crt_get_pk_rsa_raw.3 \
+ gnutls_x509_crt_get_pk_dsa_raw.3 \
+ gnutls_x509_crt_sign2.3 \
+ gnutls_x509_crt_list_import.3 \
+ gnutls_x509_crt_set_dn_by_oid.3 \
+ gnutls_x509_crt_set_issuer_dn_by_oid.3 \
+ gnutls_x509_crt_set_version.3 \
+ gnutls_x509_crt_set_key.3 \
+ gnutls_x509_crt_set_crq.3 \
+ gnutls_x509_crt_set_extension_by_oid.3 \
+ gnutls_x509_crt_set_ca_status.3 \
+ gnutls_x509_crt_set_key_usage.3 \
+ gnutls_x509_crt_set_subject_alternative_name.3 \
+ gnutls_x509_crt_sign.3 \
+ gnutls_x509_crt_set_activation_time.3 \
+ gnutls_x509_crt_set_expiration_time.3 \
+ gnutls_x509_crt_set_serial.3 \
+ gnutls_x509_crt_set_crl_dist_points.3 \
+ gnutls_x509_crt_set_subject_key_id.3 \
+ gnutls_x509_crt_set_authority_key_id.3 \
+ gnutls_x509_crt_set_key_purpose_oid.3 \
+ gnutls_x509_crt_to_xml.3 \
+ gnutls_x509_crt_cpy_crl_dist_points.3 \
+ gnutls_openpgp_keyring_deinit.3 \
+ gnutls_openpgp_keyring_check_id.3 \
+ gnutls_openpgp_keyring_import.3 \
+ gnutls_openpgp_trustdb_init.3 \
+ gnutls_openpgp_trustdb_deinit.3 \
+ gnutls_openpgp_key_init.3 \
+ gnutls_openpgp_key_import.3 \
+ gnutls_openpgp_key_export.3 \
+ gnutls_openpgp_key_get_fingerprint.3 \
+ gnutls_openpgp_key_get_name.3 \
+ gnutls_openpgp_key_get_pk_algorithm.3 \
+ gnutls_openpgp_key_get_version.3 \
+ gnutls_openpgp_key_get_creation_time.3 \
+ gnutls_openpgp_key_get_expiration_time.3 \
+ gnutls_openpgp_key_get_id.3 \
+ gnutls_openpgp_key_check_hostname.3 \
+ gnutls_openpgp_key_verify_ring.3 \
+ gnutls_openpgp_key_verify_self.3 \
+ gnutls_openpgp_key_verify_trustdb.3 \
+ gnutls_openpgp_keyring_init.3 \
+ gnutls_openpgp_trustdb_import_file.3 \
+ gnutls_openpgp_key_deinit.3 \
+ gnutls_openpgp_key_get_key_usage.3 \
+ gnutls_openpgp_privkey_init.3 \
+ gnutls_openpgp_privkey_deinit.3 \
+ gnutls_openpgp_privkey_import.3 \
+ gnutls_openpgp_key_to_xml.3 \
+ gnutls_openpgp_privkey_get_pk_algorithm.3 \
+ gnutls_certificate_verify_peers.3 \
+ gnutls_psk_free_client_credentials.3 \
+ gnutls_psk_allocate_client_credentials.3 \
+ gnutls_psk_set_client_credentials.3 \
+ gnutls_psk_free_server_credentials.3 \
+ gnutls_psk_allocate_server_credentials.3 \
+ gnutls_psk_set_server_credentials_file.3 \
+ gnutls_psk_set_server_credentials_function.3 \
+ gnutls_psk_set_client_credentials_function.3 \
+ gnutls_psk_server_get_username.3
diff --git a/security/gnutls-devel/distinfo b/security/gnutls-devel/distinfo
new file mode 100644
index 000000000000..43b520b5dac4
--- /dev/null
+++ b/security/gnutls-devel/distinfo
@@ -0,0 +1,3 @@
+MD5 (gnutls-1.3.0.tar.bz2) = e5caf8f1240088a97e53c8e20b117afd
+SHA256 (gnutls-1.3.0.tar.bz2) = daa9f0be19d9b77afecdcba081788e856dc9639524110cdb35a13dd0ee0f37e6
+SIZE (gnutls-1.3.0.tar.bz2) = 3087449
diff --git a/security/gnutls-devel/pkg-descr b/security/gnutls-devel/pkg-descr
new file mode 100644
index 000000000000..eb3b18b04920
--- /dev/null
+++ b/security/gnutls-devel/pkg-descr
@@ -0,0 +1,17 @@
+GnuTLS is a portable ANSI C based library which implements the TLS 1.0 and
+SSL 3.0 protocols. The library does not include any patented algorithms and
+is available under the GNU Lesser GPL license.
+
+Important features of the GnuTLS library include:
+- Thread safety
+- Support for both TLS 1.0 and SSL 3.0 protocols
+- Support for both X.509 and OpenPGP certificates
+- Support for basic parsing and verification of certificates
+- Support for SRP for TLS authentication
+- Support for TLS Extension mechanism
+- Support for TLS Compression Methods
+
+Additionaly GnuTLS provides an emulation API for the widely used
+OpenSSL library, to ease integration with existing applications.
+
+WWW: http://www.gnutls.org/
diff --git a/security/gnutls-devel/pkg-plist b/security/gnutls-devel/pkg-plist
new file mode 100644
index 000000000000..1231b3d78000
--- /dev/null
+++ b/security/gnutls-devel/pkg-plist
@@ -0,0 +1,54 @@
+@comment $FreeBSD$
+bin/certtool
+bin/gnutls-cli
+bin/gnutls-cli-debug
+bin/gnutls-serv
+bin/libgnutls-config
+bin/libgnutls-extra-config
+bin/psktool
+bin/srptool
+include/gnutls/compat.h
+include/gnutls/extra.h
+include/gnutls/gnutls.h
+include/gnutls/openpgp.h
+include/gnutls/openssl.h
+include/gnutls/pkcs12.h
+include/gnutls/x509.h
+lib/libgnutls-extra.a
+lib/libgnutls-extra.la
+lib/libgnutls-extra.so
+lib/libgnutls-extra.so.16
+lib/libgnutls-openssl.a
+lib/libgnutls-openssl.la
+lib/libgnutls-openssl.so
+lib/libgnutls-openssl.so.16
+lib/libgnutls.a
+lib/libgnutls.la
+lib/libgnutls.so
+lib/libgnutls.so.16
+libdata/pkgconfig/gnutls-extra.pc
+libdata/pkgconfig/gnutls.pc
+@comment info/gnutls.info-1
+@comment info/gnutls.info-2
+share/aclocal/libgnutls-extra.m4
+share/aclocal/libgnutls.m4
+%%EXAMPLESDIR%%/ex-alert.c
+%%EXAMPLESDIR%%/ex-cert-select.c
+%%EXAMPLESDIR%%/ex-client-resume.c
+%%EXAMPLESDIR%%/ex-client-srp.c
+%%EXAMPLESDIR%%/ex-client1.c
+%%EXAMPLESDIR%%/ex-client2.c
+%%EXAMPLESDIR%%/ex-crq.c
+%%EXAMPLESDIR%%/ex-pkcs12.c
+%%EXAMPLESDIR%%/ex-rfc2818.c
+%%EXAMPLESDIR%%/ex-serv-anon.c
+%%EXAMPLESDIR%%/ex-serv-export.c
+%%EXAMPLESDIR%%/ex-serv-pgp.c
+%%EXAMPLESDIR%%/ex-serv-srp.c
+%%EXAMPLESDIR%%/ex-serv1.c
+%%EXAMPLESDIR%%/ex-session-info.c
+%%EXAMPLESDIR%%/ex-verify.c
+%%EXAMPLESDIR%%/ex-x509-info.c
+%%EXAMPLESDIR%%/tcp.c
+@dirrm %%EXAMPLESDIR%%
+@dirrm include/gnutls