aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-01-13 20:41:19 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-01-13 20:41:19 +0000
commit8075c5bed6442cc2fd4150a0589a102ed9380b8b (patch)
treece058b2d71ad6e9129766df8676764b16748dbc9 /security
parentc63c243d07b9d069b8b789bccfa817eb93faf450 (diff)
downloadports-8075c5bed6442cc2fd4150a0589a102ed9380b8b.tar.gz
ports-8075c5bed6442cc2fd4150a0589a102ed9380b8b.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/pf/Makefile8
-rw-r--r--security/pf/distinfo2
-rw-r--r--security/pf/files/patch-ac98
-rw-r--r--security/pf/files/patch-ad23
4 files changed, 5 insertions, 126 deletions
diff --git a/security/pf/Makefile b/security/pf/Makefile
index 7ebf07fa1177..45720983436b 100644
--- a/security/pf/Makefile
+++ b/security/pf/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= pf_freebsd
-PORTVERSION= 2.00
-PORTREVISION= 1
+PORTVERSION= 2.02
CATEGORIES= security ipv6
MASTER_SITES= http://pf4freebsd.love2party.net/
.if defined(WITH_ALTQ) && (${WITH_ALTQ} == "yes")
@@ -60,8 +59,9 @@ IGNORE= "Kernel source files required"
pre-fetch:
@${ECHO_MSG} "======================================================="
@${ECHO_MSG} "* If you have ALTQ support from: *"
- @${ECHO_MSG} "* http://www.nipsi.de/altq/index.html *"
- @${ECHO_MSG} "* You can may define WITH_ALTQ=yes to make use of it *"
+ @${ECHO_MSG} "* http://www.nipsi.de/altq/index.html or *"
+ @${ECHO_MSG} "* http://www.rofug.ro/projects/freebsd-altq/ *"
+ @${ECHO_MSG} "* You can define WITH_ALTQ=yes to make use of it *"
@${ECHO_MSG} "* Please define SYS_ALTQ to point to the patched src *"
@${ECHO_MSG} "* *"
@${ECHO_MSG} "* e.g.: make WITH_ALTQ=yes SYS_ALTQ=/usr/src/sys.altq *"
diff --git a/security/pf/distinfo b/security/pf/distinfo
index b32961316280..316738b7b658 100644
--- a/security/pf/distinfo
+++ b/security/pf/distinfo
@@ -1 +1 @@
-MD5 (pf_freebsd_2.00.tar.gz) = e55504a934a232a0030dc746f0bf96d0
+MD5 (pf_freebsd_2.02.tar.gz) = 378eb8b827604cb313e7e1d16318106e
diff --git a/security/pf/files/patch-ac b/security/pf/files/patch-ac
deleted file mode 100644
index ae562f0605d3..000000000000
--- a/security/pf/files/patch-ac
+++ /dev/null
@@ -1,98 +0,0 @@
---- pf/pf.c.orig Fri Nov 21 14:32:14 2003
-+++ pf/pf.c Fri Nov 21 14:32:33 2003
-@@ -1250,8 +1250,10 @@
- struct tcphdr *th;
- #if defined(__FreeBSD__)
- struct ip *ip;
-+#if (__FreeBSD_version < 501114)
- struct route ro;
- #endif
-+#endif
- char *opt;
-
- /* maximum segment size tcp option */
-@@ -1366,7 +1368,6 @@
- h->ip_ttl = ttl ? ttl : ip_defttl;
- h->ip_sum = 0;
- #if defined(__FreeBSD__)
-- bzero(&ro, sizeof(ro));
- ip = mtod(m, struct ip *);
- /*
- * XXX
-@@ -1376,6 +1377,8 @@
- */
- NTOHS(ip->ip_len);
- NTOHS(ip->ip_off);
-+#if (__FreeBSD_version < 501114)
-+ bzero(&ro, sizeof(ro));
- ip_rtaddr(ip->ip_dst, &ro);
- PF_UNLOCK();
- ip_output(m, (void *)NULL, &ro, 0, (void *)NULL,
-@@ -1384,7 +1387,13 @@
- if(ro.ro_rt) {
- RTFREE(ro.ro_rt);
- }
--#else
-+#else /* __FreeBSD_version >= 501114 */
-+ PF_UNLOCK();
-+ ip_output(m, (void *)NULL, (void *)NULL, 0, (void *)NULL,
-+ (void *)NULL);
-+ PF_LOCK();
-+#endif
-+#else /* ! __FreeBSD__ */
- ip_output(m, (void *)NULL, (void *)NULL, 0, (void *)NULL,
- (void *)NULL);
- #endif
-@@ -2354,8 +2363,12 @@
- dst->sin_len = sizeof(*dst);
- dst->sin_addr = addr->v4;
- #if defined(__FreeBSD__)
-+#ifdef RTF_PRCLONING
- rtalloc_ign(&ro, (RTF_CLONING | RTF_PRCLONING));
--#else
-+#else /* !RTF_PRCLONING */
-+ rtalloc_ign(&ro, RTF_CLONING);
-+#endif
-+#else /* ! __FreeBSD__ */
- rtalloc_noclone(&ro, NO_CLONING);
- #endif
- rt = ro.ro_rt;
-@@ -2370,9 +2383,13 @@
- dst6->sin6_len = sizeof(*dst6);
- dst6->sin6_addr = addr->v6;
- #if defined(__FreeBSD__)
-+#ifdef RTF_PRCLONING
- rtalloc_ign((struct route *)&ro6,
- (RTF_CLONING | RTF_PRCLONING));
--#else
-+#else /* !RTF_PRCLONING */
-+ rtalloc_ign((struct route *)&ro6, RTF_CLONING);
-+#endif
-+#else /* ! __FreeBSD__ */
- rtalloc_noclone((struct route *)&ro6, NO_CLONING);
- #endif
- rt = ro6.ro_rt;
-@@ -4731,8 +4748,12 @@
- dst->sin_len = sizeof(*dst);
- dst->sin_addr = addr->v4;
- #if defined(__FreeBSD__)
-+#ifdef RTF_PRCLONING
- rtalloc_ign(&ro, (RTF_CLONING|RTF_PRCLONING));
--#else
-+#else /* !RTF_PRCLONING */
-+ rtalloc_ign(&ro, RTF_CLONING);
-+#endif
-+#else /* ! __FreeBSD__ */
- rtalloc_noclone(&ro, NO_CLONING);
- #endif
-
-@@ -5044,7 +5065,8 @@
- m0->m_pkthdr.csum_flags &= ifp->if_hwassist;
-
- if (ntohs(ip->ip_len) <= ifp->if_mtu ||
-- ifp->if_hwassist & CSUM_FRAGMENT) {
-+ (ifp->if_hwassist & CSUM_FRAGMENT &&
-+ ((ip->ip_off & htons(IP_DF)) == 0))) {
- /*
- * ip->ip_len = htons(ip->ip_len);
- * ip->ip_off = htons(ip->ip_off);
diff --git a/security/pf/files/patch-ad b/security/pf/files/patch-ad
deleted file mode 100644
index 8473380dac8e..000000000000
--- a/security/pf/files/patch-ad
+++ /dev/null
@@ -1,23 +0,0 @@
---- freebsd_libpcap/savefile.c.orig Fri Nov 21 14:35:34 2003
-+++ freebsd_libpcap/savefile.c Fri Nov 21 14:35:46 2003
-@@ -178,6 +178,9 @@
- #define LINKTYPE_HDLC 112 /* NetBSD HDLC framing */
- #define LINKTYPE_IPFILTER 116 /* IP Filter capture files */
- #define LINKTYPE_PFLOG 117 /* OpenBSD DLT_PFLOG */
-+#if defined(DLT_PFSYNC)
-+#define LINKTYPE_PFSYNC DLT_PFSYNC
-+#endif
-
- static struct linktype_map {
- int dlt;
-@@ -271,6 +274,10 @@
- * defining DLT_* values that collide with those
- * LINKTYPE_* values, either).
- */
-+ { DLT_PFLOG, LINKTYPE_PFLOG },
-+#if defined(DLT_PFSYNC)
-+ { DLT_PFSYNC, LINKTYPE_PFSYNC },
-+#endif
- { -1, -1 }
- };
-