aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorSofian Brabez <sbz@FreeBSD.org>2011-06-29 09:42:02 +0000
committerSofian Brabez <sbz@FreeBSD.org>2011-06-29 09:42:02 +0000
commita8e7678ba03147e62a4a16dbf20d368de240e64d (patch)
treebae1c94cea633e945e11aaa6e2ca180d9119871b /security
parenta1a1818dcf9064170c171348fd088fc12213f255 (diff)
downloadports-a8e7678ba03147e62a4a16dbf20d368de240e64d.tar.gz
ports-a8e7678ba03147e62a4a16dbf20d368de240e64d.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/libssh2/Makefile3
-rw-r--r--security/libssh2/files/patch-version60
2 files changed, 63 insertions, 0 deletions
diff --git a/security/libssh2/Makefile b/security/libssh2/Makefile
index 8ed5eb2fd8c6..a539f14f0a27 100644
--- a/security/libssh2/Makefile
+++ b/security/libssh2/Makefile
@@ -7,6 +7,7 @@
PORTNAME= libssh2
PORTVERSION= 1.2.8
+PORTREVISION= 1
PORTEPOCH= 2
CATEGORIES= security devel
MASTER_SITES= http://www.libssh2.org/download/
@@ -18,8 +19,10 @@ LICENSE= BSD
LICENSE_FILE= ${WRKSRC}/COPYING
USE_OPENSSL= yes
+USE_AUTOTOOLS= autoconf
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
+PATCH_STRIP= -p1
OPTIONS= GCRYPT "Use libgcrypt instead of OpenSSL" off \
TRACE "Enable debug packet traces" off \
diff --git a/security/libssh2/files/patch-version b/security/libssh2/files/patch-version
new file mode 100644
index 000000000000..c1fd18828da0
--- /dev/null
+++ b/security/libssh2/files/patch-version
@@ -0,0 +1,60 @@
+From: Daniel Stenberg <daniel@haxx.se>
+Date: Wed, 6 Apr 2011 10:03:11 +0000 (+0200)
+Subject: configure: fix $VERSION
+X-Git-Url: http://git.libssh2.org/?p=libssh2.git;a=commitdiff_plain;h=f0a37bdadc311b83fcb2ccafad4827016abe5d18;js=1
+
+configure: fix $VERSION
+
+Stop using the $VERSION variable as it seems to be magically used by
+autoconfig itself and thus gets set to the value set in AC_INIT()
+without us wanting that. $LIBSSH2VER is now the libssh2 version as
+detected.
+
+Reported by: Paul Howarth
+Bug: http://www.libssh2.org/mail/libssh2-devel-archive-2011-04/0008.shtml
+---
+
+diff --git a/configure.ac b/configure.ac
+index 9bdf3b9..46c6cfa 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -15,12 +15,14 @@ if test "x$SED" = "xsed-was-not-found-by-configure"; then
+ fi
+
+ dnl figure out the libssh2 version
+-VERSION=`$SED -ne 's/^#define LIBSSH2_VERSION *"\(.*\)"/\1/p' ${srcdir}/include/libssh2.h`
++LIBSSH2VER=`$SED -ne 's/^#define LIBSSH2_VERSION *"\(.*\)"/\1/p' ${srcdir}/include/libssh2.h`
+ AM_INIT_AUTOMAKE
+ AC_MSG_CHECKING([libssh2 version])
+-AC_MSG_RESULT($VERSION)
++AC_MSG_RESULT($LIBSSH2VER)
+
+-AB_VERSION=$VERSION
++AC_SUBST(LIBSSH2VER)
++
++AB_VERSION=$LIBSSH2VER
+
+ AB_INIT
+
+@@ -289,7 +291,7 @@ AC_OUTPUT
+
+ AC_MSG_NOTICE([summary of build options:
+
+- version: ${VERSION}
++ version: ${LIBSSH2VER}
+ Host type: ${host}
+ Install prefix: ${prefix}
+ Compiler: ${CC}
+diff --git a/libssh2.pc.in b/libssh2.pc.in
+index 013e6bf..eaef88b 100644
+--- a/libssh2.pc.in
++++ b/libssh2.pc.in
+@@ -10,7 +10,7 @@ includedir=@includedir@
+ Name: libssh2
+ URL: http://www.libssh2.org/
+ Description: Library for SSH based connunication
+-Version: @VERSION@
++Version: @LIBSSH2VER@
+ Libs: -L${libdir} -lssh2 @LDFLAGS@ @LIBS@
+ Libs.private: @LIBS@
+ Cflags: -I${includedir}