aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2002-03-09 12:51:44 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2002-03-09 12:51:44 +0000
commitb0f1b90bd7f158207ccc04c5498bd3a274307d3f (patch)
tree66a2cf66a5fe5fe970d3ead21943fdcf6c5040e3 /security
parentddec5bcc6faedad9813f344f91d389256191608f (diff)
downloadports-b0f1b90bd7f158207ccc04c5498bd3a274307d3f.tar.gz
ports-b0f1b90bd7f158207ccc04c5498bd3a274307d3f.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/hpn-ssh/Makefile1
-rw-r--r--security/hpn-ssh/files/patch-sshconnect.c2
-rw-r--r--security/openssh-portable/Makefile1
-rw-r--r--security/openssh-portable/files/patch-sshconnect.c2
4 files changed, 4 insertions, 2 deletions
diff --git a/security/hpn-ssh/Makefile b/security/hpn-ssh/Makefile
index 173638fea7cb..940730c77a44 100644
--- a/security/hpn-ssh/Makefile
+++ b/security/hpn-ssh/Makefile
@@ -7,6 +7,7 @@
PORTNAME= openssh
PORTVERSION= 3.1p1
+PORTREVISION= 1
CATEGORIES= security ipv6
MASTER_SITES= ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/ \
ftp://ftp.op.net/pub/OpenBSD/OpenSSH/portable/ \
diff --git a/security/hpn-ssh/files/patch-sshconnect.c b/security/hpn-ssh/files/patch-sshconnect.c
index ba0aa01906a8..72f75354bd24 100644
--- a/security/hpn-ssh/files/patch-sshconnect.c
+++ b/security/hpn-ssh/files/patch-sshconnect.c
@@ -4,7 +4,7 @@
sin_addr.s_addr) >> 24) == IN_LOOPBACKNET;
salen = sizeof(struct sockaddr_in);
break;
-+#ifdef INET6
++#ifdef HAVE_STRUCT_SOCKADDR_IN6
case AF_INET6:
local = IN6_IS_ADDR_LOOPBACK(
&(((struct sockaddr_in6 *)hostaddr)->sin6_addr));
diff --git a/security/openssh-portable/Makefile b/security/openssh-portable/Makefile
index 173638fea7cb..940730c77a44 100644
--- a/security/openssh-portable/Makefile
+++ b/security/openssh-portable/Makefile
@@ -7,6 +7,7 @@
PORTNAME= openssh
PORTVERSION= 3.1p1
+PORTREVISION= 1
CATEGORIES= security ipv6
MASTER_SITES= ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/ \
ftp://ftp.op.net/pub/OpenBSD/OpenSSH/portable/ \
diff --git a/security/openssh-portable/files/patch-sshconnect.c b/security/openssh-portable/files/patch-sshconnect.c
index ba0aa01906a8..72f75354bd24 100644
--- a/security/openssh-portable/files/patch-sshconnect.c
+++ b/security/openssh-portable/files/patch-sshconnect.c
@@ -4,7 +4,7 @@
sin_addr.s_addr) >> 24) == IN_LOOPBACKNET;
salen = sizeof(struct sockaddr_in);
break;
-+#ifdef INET6
++#ifdef HAVE_STRUCT_SOCKADDR_IN6
case AF_INET6:
local = IN6_IS_ADDR_LOOPBACK(
&(((struct sockaddr_in6 *)hostaddr)->sin6_addr));