aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorRyan Steinmetz <zi@FreeBSD.org>2012-05-23 19:58:16 +0000
committerRyan Steinmetz <zi@FreeBSD.org>2012-05-23 19:58:16 +0000
commitd5bd9df70b968d35e575b68543efa86c75774825 (patch)
treebf3278079cfc77aa6f3b267f84f8be3add1456d3 /security
parentcc18b2487de09cbdd3226e1691155fda8b79fed8 (diff)
downloadports-d5bd9df70b968d35e575b68543efa86c75774825.tar.gz
ports-d5bd9df70b968d35e575b68543efa86c75774825.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/truecrack/Makefile42
-rw-r--r--security/truecrack/distinfo2
-rw-r--r--security/truecrack/pkg-descr17
4 files changed, 62 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index f552984a38a8..22ac7ad3c57c 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -918,6 +918,7 @@
SUBDIR += tripwire-131
SUBDIR += tripwire12
SUBDIR += trousers
+ SUBDIR += truecrack
SUBDIR += truecrypt
SUBDIR += tsshbatch
SUBDIR += tthsum
diff --git a/security/truecrack/Makefile b/security/truecrack/Makefile
new file mode 100644
index 000000000000..d51f55f0ea2a
--- /dev/null
+++ b/security/truecrack/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: truecrack
+# Date created: 23 May 2012
+# Whom: Ryan Steinmetz <zi@FreeBSD.org>
+#
+# $FreeBSD$
+
+PORTNAME= truecrack
+PORTVERSION= 0.1
+CATEGORIES= security
+MASTER_SITES= https://truecrack.googlecode.com/files/ \
+ http://mirrors.rit.edu/zi/
+DISTNAME= ${PORTNAME}
+
+MAINTAINER= zi@FreeBSD.org
+COMMENT= A password cracker for TrueCrypt volumes
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/license.txt
+
+USE_GMAKE= yes
+CFLAGS+= -DTC_BSD
+PLIST_FILES= bin/truecrack
+
+.if !defined(NOPORTDATA)
+DICTIONARIES= dictionary_100k.txt dictionary_10k.txt dictionary.txt
+PORTDATA= ${DICTIONARIES}
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's/CFLAGS =/CFLAGS +=/g' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's/return ;/return 0;/g' ${WRKSRC}/Main/Utils.c
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/truecrack ${PREFIX}/bin
+.if !defined(NOPORTDATA)
+.for dict in ${DICTIONARIES}
+ @${MKDIR} ${DATADIR}
+ @${INSTALL_DATA} ${WRKSRC}/${dict} ${DATADIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/security/truecrack/distinfo b/security/truecrack/distinfo
new file mode 100644
index 000000000000..f38e7e7eb43b
--- /dev/null
+++ b/security/truecrack/distinfo
@@ -0,0 +1,2 @@
+SHA256 (truecrack.tar.gz) = 44318f9e44d315a77dda4bb4d474a88b3207f4c63d3a445d865b50b4c8f323ac
+SIZE (truecrack.tar.gz) = 8601600
diff --git a/security/truecrack/pkg-descr b/security/truecrack/pkg-descr
new file mode 100644
index 000000000000..67a048d88acc
--- /dev/null
+++ b/security/truecrack/pkg-descr
@@ -0,0 +1,17 @@
+TrueCrack is a brute-force password cracker for TrueCrypt (Copyright) volume
+files. It works on Linux and it is optimized with Nvidia Cuda technology.
+It works with cripted volumes with the following algorithms:
+
+- PBKDF2 (defined in PKCS5 v2.0) based on RIPEMD160 Key derivation function.
+- XTS block cipher mode of operation used for hard disk encryption based on
+ AES.
+
+TrueCrack can work in two different modes of use:
+
+- Dictionary attack: read the passwords from a file of words (one password
+ for line).
+- Charset attack: generate the passwords from a charset of symbols defined
+ by the user (for example: all possible strings of n characters from the
+ charset "abc" ).
+
+WWW: https://code.google.com/p/truecrack/