aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2006-02-17 21:00:23 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2006-02-17 21:00:23 +0000
commit2e142b64d01cb542d74d1010403e57a1858a9e9f (patch)
tree66e0f321400df87c80984acc19a4e2a8ae772efb /security
parentc46191ce53ec0aca705275be0ec909db15d976d7 (diff)
downloadports-2e142b64d01cb542d74d1010403e57a1858a9e9f.tar.gz
ports-2e142b64d01cb542d74d1010403e57a1858a9e9f.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/hostapd/Makefile23
-rw-r--r--security/hostapd/distinfo6
-rw-r--r--security/hostapd/files/config.bsd3
-rw-r--r--security/hostapd/pkg-plist2
4 files changed, 18 insertions, 16 deletions
diff --git a/security/hostapd/Makefile b/security/hostapd/Makefile
index 75991130640f..c35e8b2df618 100644
--- a/security/hostapd/Makefile
+++ b/security/hostapd/Makefile
@@ -6,22 +6,23 @@
#
PORTNAME= hostapd
-PORTVERSION= 0.3.0
-PORTREVISION= 1
+PORTVERSION= 0.4.8
CATEGORIES= security
-MASTER_SITES= http://hostap.epitest.fi/releases/
-DISTNAME= hostapd-${PORTVERSION}
+MASTER_SITES= http://hostap.epitest.fi/releases/ \
+ http://www.freebsdbrasil.com.br/~jmelo/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= jmelo@freebsdbrasil.com.br
COMMENT= Authenticator (server) for WPA/802.1x protocols
LIB_DEPENDS= dnet.1:${PORTSDIR}/net/libdnet
-WRKSRC= ${WRKDIR}/${DISTNAME}
USE_GMAKE= yes
-post-extract:
- @${CP} ${FILESDIR}/config.bsd ${WRKSRC}/.config
+WRKSRC= ${WRKDIR}/${DISTNAME}
+MAKE_ENV+= CC="${CC}"
+CFLAGS+= -DCONFIG_DRIVER_BSD
+
+PLIST_FILES= bin/hostapd bin/hostapd_cli
.include <bsd.port.pre.mk>
@@ -29,4 +30,10 @@ post-extract:
IGNORE=is not supported on FreeBSD < 6.0
.endif
+post-extract:
+ @${TOUCH} ${WRKSRC}/.config
+
+post-patch:
+ @${REINPLACE_CMD} -e '/^CC/d' ${WRKSRC}/${MAKEFILE}
+
.include <bsd.port.post.mk>
diff --git a/security/hostapd/distinfo b/security/hostapd/distinfo
index d2b96caafa85..56ada21f1898 100644
--- a/security/hostapd/distinfo
+++ b/security/hostapd/distinfo
@@ -1,3 +1,3 @@
-MD5 (hostapd-0.3.0.tar.gz) = 2fa275b17c0c395898dd4b1fb10545ce
-SHA256 (hostapd-0.3.0.tar.gz) = 3963a2141161fbd880c4fdbc558950d90442d72dddcb71486f6a98c0cb20dbc2
-SIZE (hostapd-0.3.0.tar.gz) = 198308
+MD5 (hostapd-0.4.8.tar.gz) = b8f30f23c04b74f18b2e4e6d8e0ee014
+SHA256 (hostapd-0.4.8.tar.gz) = 4675ae608a9f16e0ac519af2003ef694e7e13a4ecda2fcbe29f12a306e460551
+SIZE (hostapd-0.4.8.tar.gz) = 290829
diff --git a/security/hostapd/files/config.bsd b/security/hostapd/files/config.bsd
deleted file mode 100644
index 814a97d5e283..000000000000
--- a/security/hostapd/files/config.bsd
+++ /dev/null
@@ -1,3 +0,0 @@
-CONFIG_DRIVER_BSD=y
-CFLAGS += -I/usr/local/include
-LIBS += -L/usr/local/lib
diff --git a/security/hostapd/pkg-plist b/security/hostapd/pkg-plist
deleted file mode 100644
index 71ec0e7e1ac7..000000000000
--- a/security/hostapd/pkg-plist
+++ /dev/null
@@ -1,2 +0,0 @@
-bin/hostapd
-bin/hostapd_cli