aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2010-12-27 20:32:24 +0000
committerPav Lucistnik <pav@FreeBSD.org>2010-12-27 20:32:24 +0000
commit725ff435f0fe29e2011acc5214a71a173a5d2f39 (patch)
tree8f5aa0a08f84aa8e8c4d97f67b3641abb3712492 /security
parent974ea15108f4fe300a7cd67f746dc19b2a0efc25 (diff)
Notes
Diffstat (limited to 'security')
-rw-r--r--security/hydra/Makefile20
-rw-r--r--security/hydra/distinfo4
-rw-r--r--security/hydra/files/patch-configure53
3 files changed, 32 insertions, 45 deletions
diff --git a/security/hydra/Makefile b/security/hydra/Makefile
index 7c1d06f2614b..6672154ee214 100644
--- a/security/hydra/Makefile
+++ b/security/hydra/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= hydra
-PORTVERSION= 5.8
+PORTVERSION= 5.9
CATEGORIES= security
MASTER_SITES= http://freeworld.thc.org/releases/
MASTER_SITE_SUBDIR= groups/thc
@@ -26,6 +26,22 @@ USE_GNOME= gtk20
USE_OPENSSL= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}-src
+OPTIONS= FIREBIRD "Enable firebird support" off \
+ SSH "Enable ssh support" off \
+ SVN "Enable subversion support" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_FIREBIRD)
+LIB_DEPENDS+= fbclient.2:${PORTSDIR}/databases/firebird20-client
+.endif
+.if defined(WITH_SSH)
+LIB_DEPENDS+= ssh.4:${PORTSDIR}/security/libssh
+.endif
+.if defined(WITH_SVN)
+LIB_DEPENDS+= svn_client-1:${PORTSDIR}/devel/subversion
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|CC = gcc||; \
s|-O2|${CFLAGS}|; s|md4\..||g' \
@@ -34,4 +50,4 @@ post-patch:
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/hydra ${WRKSRC}/hydra-gtk/src/xhydra ${PREFIX}/bin
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/security/hydra/distinfo b/security/hydra/distinfo
index d9c7c788de15..5aebdb24ccdf 100644
--- a/security/hydra/distinfo
+++ b/security/hydra/distinfo
@@ -1,2 +1,2 @@
-SHA256 (hydra-5.8-src.tar.gz) = 8c97472509a1afe9c60bddbb3f3541eb706d3719fb1c4634749d1531397377aa
-SIZE (hydra-5.8-src.tar.gz) = 203164
+SHA256 (hydra-5.9-src.tar.gz) = 66023f94460abe76e76c1c6b187d44e82bafafb4c517314261bbd34429f913a7
+SIZE (hydra-5.9-src.tar.gz) = 423995
diff --git a/security/hydra/files/patch-configure b/security/hydra/files/patch-configure
index ada45c40d12a..9192ad1021d3 100644
--- a/security/hydra/files/patch-configure
+++ b/security/hydra/files/patch-configure
@@ -1,51 +1,22 @@
---- configure.orig 2010-09-29 15:19:43.000000000 +0400
-+++ configure 2010-10-24 22:49:10.000000000 +0400
-@@ -125,11 +125,11 @@
- echo " ... NOT found, module postgres disabled"
- fi
-
--echo "Checking for SVN (libsvn_client-1 libapr-0.so libaprutil-0.so) ..."
-+echo "Checking for SVN (libsvn_client-1 libapr-1.so libaprutil-1.so) ..."
- for i in $LIBDIRS /lib /usr/lib /usr/local/lib /opt/local/lib .
- do
- if [ "X" = "X$SVN_PATH" ]; then
-- if [ -f "$i/libsvn_client-1.so" ]&&[ -f "$i/libapr-0.so" ]&&[ -f "$i/libaprutil-0.so" ]; then
-+ if [ -f "$i/libsvn_client-1.so" ]&&[ -f "$i/libapr-1.so" ]&&[ -f "$i/libaprutil-1.so" ]; then
- SVN_PATH="$i"
- fi
- fi
-@@ -303,8 +303,8 @@
+--- configure.orig 2010-11-19 12:52:07.000000000 +0300
++++ configure 2010-11-30 00:06:09.000000000 +0300
+@@ -152,8 +152,8 @@
fi
fi
if [ "X" = "X$APR_IPATH" ]; then
-- if [ -d "$i/apr-0" ]; then
-- APR_IPATH="$i/apr-0"
+- if [ -d "$i/apr-1.0" ]; then
+- APR_IPATH="$i/apr-1.0"
+ if [ -d "$i/apr-1" ]; then
+ APR_IPATH="$i/apr-1"
fi
fi
done
-@@ -321,8 +321,8 @@
- fi
- fi
- if [ "X" = "X$APR_IPATH" ]; then
-- if [ -d "$i/apr-0" ]; then
-- APR_IPATH="$i/apr-0"
-+ if [ -d "$i/apr-1" ]; then
-+ APR_IPATH="$i/apr-1"
- fi
- fi
- done
-@@ -528,10 +528,10 @@
- XLIBS="$XLIBS -lpq"
- fi
- if [ -n "$SVN_PATH" ]; then
-- XLIBS="$XLIBS -lsvn_client-1 -lapr-0 -laprutil-0"
-+ XLIBS="$XLIBS -lsvn_client-1 -lapr-1 -laprutil-1"
+@@ -473,7 +473,7 @@
fi
- if [ -n "$SVN_PATH" ]; then
-- XLIBS="$XLIBS -lsvn_client-1 -lapr-0 -laprutil-0"
-+ XLIBS="$XLIBS -lsvn_client-1 -lapr-1 -laprutil-1"
+
+ if [ -n "$FIREBIRD_PATH" -o -n "$SSL_PATH" -o -n "$CRYPTO_PATH" -o -n "$NSL_PATH" -o -n "$SOCKET_PATH" -o -n "$RESOLV_PATH" -o -n "$SAPR3_PATH" -o -n "$SSH_PATH" -o -n "$POSTGRES_PATH" -o -n "$SVN_PATH" -o -n "$NCP_PATH" -o -n "$AFP_PATH" -o -n "$MYSQL_PATH" ]; then
+- XLIBPATHS="-L/usr/lib -L/usr/local/lib -L/lib"
++ XLIBPATHS="-L/usr/local/lib -L/usr/lib -L/lib"
fi
- if [ -n "$SSH_PATH" ]; then
- XLIBS="$XLIBS -lssh"
+ if [ -n "$SSL_PATH" ]; then
+ XDEFINES="$XDEFINES -DLIBOPENSSL"