aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-07-14 15:08:36 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-07-14 15:08:36 +0000
commitd3a3d3c66db404cf90030c7e2d1ee3cb886251ba (patch)
treed5aca524d61db2fc784c09ae8a707ccefcec864b /security
parente75ada711049d76ee4e10a27f49c27f7044ed795 (diff)
Notes
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/gnome-password-generator/Makefile27
-rw-r--r--security/gnome-password-generator/distinfo2
-rw-r--r--security/gnome-password-generator/pkg-descr5
-rw-r--r--security/gnome-password-generator/pkg-plist3
5 files changed, 38 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 02c1615cce79..e6a369f2dcbd 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -99,6 +99,7 @@
SUBDIR += gag
SUBDIR += gaim-encryption
SUBDIR += gcipher
+ SUBDIR += gnome-password-generator
SUBDIR += gnome-ssh-askpass
SUBDIR += gnomekeyring
SUBDIR += gnupg
diff --git a/security/gnome-password-generator/Makefile b/security/gnome-password-generator/Makefile
new file mode 100644
index 000000000000..c474180fdc1c
--- /dev/null
+++ b/security/gnome-password-generator/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: gnome-password-generator
+# Date created: 2004-07-13
+# Whom: Sergey Akifyev <asa@gascom.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gnome-password-generator
+PORTVERSION= 1.4
+CATEGORIES= sysutils gnome python
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= gnome-password
+
+MAINTAINER= asa@gascom.ru
+COMMENT= GNOME 2 password generator
+
+USE_GNOME= pygnome2
+USE_PYTHON= yes
+USE_X_PREFIX= yes
+USE_REINPLACE= yes
+USE_GMAKE= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|prefix=/usr|prefix=${PREFIX}|g' -e 's|(prefix)/share|(prefix)/share/gnome|g' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|/usr/bin/python|${PYTHON_CMD}|g' ${WRKSRC}/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/security/gnome-password-generator/distinfo b/security/gnome-password-generator/distinfo
new file mode 100644
index 000000000000..6db23f793297
--- /dev/null
+++ b/security/gnome-password-generator/distinfo
@@ -0,0 +1,2 @@
+MD5 (gnome-password-generator-1.4.tar.gz) = a2a043a93ce04f3bb798afded8bfd329
+SIZE (gnome-password-generator-1.4.tar.gz) = 20767
diff --git a/security/gnome-password-generator/pkg-descr b/security/gnome-password-generator/pkg-descr
new file mode 100644
index 000000000000..f48c98023bab
--- /dev/null
+++ b/security/gnome-password-generator/pkg-descr
@@ -0,0 +1,5 @@
+Gnome Password Generator is a GUI based secure password generator. It allows
+the user to generate a specified number of random passwords of a specified
+length.
+
+WWW: http://gnome-password.sourceforge.net/
diff --git a/security/gnome-password-generator/pkg-plist b/security/gnome-password-generator/pkg-plist
new file mode 100644
index 000000000000..623d99f94537
--- /dev/null
+++ b/security/gnome-password-generator/pkg-plist
@@ -0,0 +1,3 @@
+bin/gnome-password-generator
+share/gnome/pixmaps/gnome-password-generator.png
+share/gnome/applications/gnome-password-generator.desktop