aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2013-03-05 17:07:43 +0000
committerMartin Wilke <miwi@FreeBSD.org>2013-03-05 17:07:43 +0000
commitfb3520254ab73be0aad04c3a63b781750cf26b5b (patch)
tree268d74f9d8738f78b0c895672044611aa6343387 /security
parent4706739618b79681811e5b336a54032908638160 (diff)
Notes
Diffstat (limited to 'security')
-rw-r--r--security/botan/Makefile21
-rw-r--r--security/clamassassin/Makefile20
-rw-r--r--security/cvm/Makefile17
-rw-r--r--security/libssh/Makefile15
-rw-r--r--security/webfwlog/Makefile18
5 files changed, 37 insertions, 54 deletions
diff --git a/security/botan/Makefile b/security/botan/Makefile
index f767b2520c94..8c2ebe1d5f1c 100644
--- a/security/botan/Makefile
+++ b/security/botan/Makefile
@@ -1,10 +1,5 @@
-# ex:ts=8
-# New ports collection makefile for: botan
-# Date created: Mar 3, 2001
-# Whom: Ying-Chieh Liao <ijliao@FreeBSD.org>
-#
+# Created by: Ying-Chieh Liao <ijliao@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= botan
PORTVERSION= 1.8.13
@@ -19,9 +14,9 @@ COMMENT= A portable, easy to use, and efficient C++ crypto library
LICENSE= BSD
LICENSE_FILE= ${WRKSRC}/doc/license.txt
-OPTIONS= SSL "Enable OpenSSL engine" on \
- GMP "Enable GMP engine" on \
- ECC "Enable ECC support" on
+OPTIONS_DEFINE= SSL GMP ECC
+OPTIONS_DEFAULT= SSL GMP ECC
+ECC_DESC= ECC support
USE_BZIP2= yes
USE_PYTHON_BUILD= yes
@@ -38,18 +33,18 @@ PORTDOCS= *
.include <bsd.port.options.mk>
-.if !defined(WITHOUT_SSL)
+.if ${PORT_OPTIONS:MSSL}
USE_OPENSSL= yes
CONFIGURE_ARGS+=--with-openssl
.endif
-.if !defined(WITHOUT_GMP)
+.if ${PORT_OPTIONS:MGMP}
LIB_DEPENDS+= gmp.10:${PORTSDIR}/math/gmp
CONFIGURE_ARGS+=--with-gnump
MAKE_ARGS+= LDFLAGS="-L${LOCALBASE}/lib"
.endif
-.if !defined(WITHOUT_ECC)
+.if ${PORT_OPTIONS:MECC}
BUILD_DEPENDS+= ${LOCALBASE}/include/boost/tr1/memory.hpp:${PORTSDIR}/devel/boost-libs
CONFIGURE_ARGS+=--with-tr1-implementation=boost
CXXFLAGS+= -I${LOCALBASE}/include
@@ -60,7 +55,7 @@ CONFIGURE_ARGS+=--with-tr1-implementation=none
post-patch:
${REINPLACE_CMD} -e "s|#!/usr/bin/env python|#!${PYTHON_CMD}|" \
${WRKSRC}/configure.py
-.if defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${REINPLACE_CMD} -e '/$$(MKDIR_INSTALL) $$(DOCDIR)/d' \
-e '/$$(INSTALL_CMD_DATA) $$$$i $$(DOCDIR); /d' \
${WRKSRC}/src/build-data/makefile/unix_shr.in
diff --git a/security/clamassassin/Makefile b/security/clamassassin/Makefile
index c29123a6f15b..1fdf3fe0c4ed 100644
--- a/security/clamassassin/Makefile
+++ b/security/clamassassin/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: clamassassin
-# Date created: 16 October 2004
-# Whom: Matt <matt@xtaz.net>
-#
+# Created by: Matt <matt@xtaz.net>
# $FreeBSD$
-#
PORTNAME= clamassassin
PORTVERSION= 1.2.4
@@ -22,17 +18,19 @@ PLIST_FILES= bin/clamassassin
GNU_CONFIGURE= yes
-OPTIONS= CLAMDSCAN "Scanning using clamd" on \
- SUBREWRITE "Mail subject rewriting" off
+OPTIONS_DEFINE= CLAMDSCAN SUBREWRITE
+OPTIONS_DEFAULT= CLAMDSCAN
+CLAMDSCAN_DESC= Scanning using clamd
+SUBREWRITE_DESC= Mail subject rewriting
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined (WITHOUT_CLAMDSCAN)
+.if ${PORT_OPTIONS:MCLAMDSCAN}
CONFIGURE_ARGS+= --enable-clamdscan
.endif
-.if defined (WITH_SUBREWRITE)
+.if ${PORT_OPTIONS:MSUBREWRITE}
CONFIGURE_ARGS+= --enable-subject-rewrite
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/cvm/Makefile b/security/cvm/Makefile
index fef206b00d5d..4137022d27a8 100644
--- a/security/cvm/Makefile
+++ b/security/cvm/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: cvm
-# Date created: 2003-12-24
-# Whom: Sergei Kolobov <sergei@FreeBSD.org>
-#
+# Created by: Sergei Kolobov <sergei@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= cvm
PORTVERSION= 0.96
@@ -26,13 +22,14 @@ BGLIBS_LIB= ${LOCALBASE}/lib/bglibs
DOCS= NEWS README TODO *.html
-OPTIONS= VCHKPW "Compile cvm-vchkpw" off
+OPTIONS_DEFINE= VCHKPW
+VCHKPW_DESC= Compile cvm-vchkpw
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
ALL_TARGET=all
-.if defined(WITH_VCHKPW)
+.if ${PORT_OPTIONS:MVCHKPW}
BUILD_DEPENDS+= ${LOCALBASE}/vpopmail/lib/libvpopmail.a:${PORTSDIR}/mail/vpopmail
ALL_TARGET+= cvm-vchkpw
PLIST_SUB= VCHKPW=""
@@ -53,10 +50,10 @@ do-configure:
${ECHO_CMD} "${BGLIBS_INC}" > ${WRKSRC}/conf-bgincs
${ECHO_CMD} "${BGLIBS_LIB}" > ${WRKSRC}/conf-bglibs
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
post-install:
@${MKDIR} ${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/libssh/Makefile b/security/libssh/Makefile
index 1f28565cdeee..e492f5dd923b 100644
--- a/security/libssh/Makefile
+++ b/security/libssh/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: libssh
-# Date created: 12 April 2009
-# Whom: Alexander Logvinov <ports@logvinov.com>
-#
+# Created by: Alexander Logvinov <ports@logvinov.com>
# $FreeBSD$
-#
PORTNAME= libssh
PORTVERSION= 0.5.2
@@ -14,8 +10,9 @@ MASTER_SITES= http://www.libssh.org/files/0.5/ \
MAINTAINER= fluffy@FreeBSD.org
COMMENT= A library implementing the SSH1 and SSH2 protocol
-OPTIONS= GCRYPT "Build with libgcrypt" off \
- SSH1 "Build with SSH1 support" off
+OPTIONS_DEFINE= GCRYPT SSH1
+GCRYPT_DESC= Build with libgcrypt
+SSH1_DESC= Build with SSH1 support
MAKE_JOBS_SAFE= yes
USE_CMAKE= yes
@@ -31,14 +28,14 @@ LICENSE_FILE= ${WRKSRC}/COPYING
.include <bsd.port.options.mk>
-.if defined(WITH_GCRYPT)
+.if ${PORT_OPTIONS:MGCRYPT}
LIB_DEPENDS+= gcrypt.18:${PORTSDIR}/security/libgcrypt
CMAKE_ARGS+= -DWITH_GCRYPT:BOOL=ON
.else
USE_OPENSSL= yes
.endif
-.if defined(WITH_SSH1)
+.if ${PORT_OPTIONS:MSSH1}
CMAKE_ARGS+= -DWITH_SSH1:BOOL=ON
PLIST_SUB+= SSH1=""
.else
diff --git a/security/webfwlog/Makefile b/security/webfwlog/Makefile
index 0f4275c70679..31e6cbb6b225 100644
--- a/security/webfwlog/Makefile
+++ b/security/webfwlog/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: webfwlog
-# Date created: 21 November 2004
-# Whom: Bob Hockney <zeus@ix.netcom.com>
-#
+# Created by: Bob Hockney <zeus@ix.netcom.com>
# $FreeBSD$
-#
PORTNAME= webfwlog
PORTVERSION= 0.94
@@ -17,8 +13,8 @@ PATCH_SITES= http://devel.webfwlog.net/download/patches/
MAINTAINER= zeus@ix.netcom.com
COMMENT= A web-based firewall log analyzer
-OPTIONS= MYSQL "Include MySQL Support" on \
- PGSQL "Include PostgreSQL Support" off
+OPTIONS_DEFINE= MYSQL PGSQL EXAMPLES
+OPTIONS_DEFAULTS= MYSQL
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --with-html-doc-root=${PREFIX}
@@ -36,13 +32,13 @@ PORTEXAMPLES= *
.include <bsd.port.options.mk>
-.if defined(WITH_MYSQL)
+.if ${PORT_OPTIONS:MMYSQL}
USE_PHP+= mysql
USE_MYSQL= yes
CONFIGURE_ARGS+= --with-mysql
.endif
-.if defined(WITH_PGSQL)
+.if ${PORT_OPTIONS:MPGSQL}
USE_PHP+= pgsql
USE_PGSQL= yes
CONFIGURE_ARGS+= --with-pgsql
@@ -61,7 +57,7 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/webfwlog/index.php ${WWWDIR}
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}/mysql
@${MKDIR} ${DOCSDIR}/pgsql
@(cd ${WRKSRC}/mysql/ && ${COPYTREE_SHARE} \* ${DOCSDIR}/mysql/)
@@ -71,7 +67,7 @@ post-install:
.endfor
.endif
-.if !defined(NOPORTEXAMPLES)
+.if ${PORT_OPTIONS:MEXAMPLES}
${MKDIR} ${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/examples/* ${EXAMPLESDIR}
.endif