aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorJohan van Selst <johans@FreeBSD.org>2014-01-12 16:59:50 +0000
committerJohan van Selst <johans@FreeBSD.org>2014-01-12 16:59:50 +0000
commit25438e64ffc7b2a0d57f18ef82c23c2602131643 (patch)
treeb54883f06b41305a4f66d2eea2f4a16e1ea483e9 /security
parent393b3728acfd34e520c7ac3d0bfd3655ab84599e (diff)
downloadports-25438e64ffc7b2a0d57f18ef82c23c2602131643.tar.gz
ports-25438e64ffc7b2a0d57f18ef82c23c2602131643.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/xmlsec1/Makefile54
-rw-r--r--security/xmlsec1/pkg-plist256
2 files changed, 223 insertions, 87 deletions
diff --git a/security/xmlsec1/Makefile b/security/xmlsec1/Makefile
index 64ac763e4f5d..980df7f07ce7 100644
--- a/security/xmlsec1/Makefile
+++ b/security/xmlsec1/Makefile
@@ -12,54 +12,35 @@ MASTER_SITES= http://www.aleksey.com/xmlsec/download/ \
MAINTAINER= johans@FreeBSD.org
COMMENT= XML Security Library
-BUILD_DEPENDS:= ${RUN_DEPENDS}
-
-OPTIONS_DEFINE= GNUTLS NSS
-GNUTLS_DESC= Enable GNUTLS support
-NSS_DESC= Enable Mozilla's NSS support
+OPTIONS_DEFINE= DOCS GNUTLS NSS
+OPTIONS_SUB= yes
+GNUTLS_DESC= Enable GNUTLS support
+GNUTLS_CONFIGURE_WITH= gnutls="${LOCALBASE}"
+GNUTLS_LIB_DEPENDS= libgnutls.so:${PORTSDIR}/security/gnutls
+NSS_DESC= Enable Mozilla's NSS support
+NSS_CONFIGURE_WITH= nss="${LOCALBASE}" nspr="${LOCALBASE}"
+NSS_LIB_DEPENDS= libnss3.so:${PORTSDIR}/security/nss
USE_OPENSSL= yes
-USE_GNOME= gnomehack lthack libxslt
+USE_GNOME= lthack libxml2 libxslt
+USE_AUTOTOOLS= libltdl
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-USES= pkgconfig
+USES= pkgconfig pathfix
-MAN1= xmlsec1.1 xmlsec1-config.1
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-MAKE_ENV+= ABS_BUILDDIR=${WRKSRC} TMPFOLDER=${WRKSRC}
+MAKE_ENV+= ABS_BUILDDIR=${WRKSRC} TMPFOLDER=${WRKSRC} DOCS=docs
+CONFIGURE_ARGS+=--with-openssl="${OPENSSLBASE}"
+
.if !defined(.PARSEDIR)
MAKE_ARGS+= -EABS_BUILDDIR
.endif
-USE_AUTOTOOLS= libltdl
-NO_STAGE= yes
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MDOCS}
-PORTDOCS= *
-MAKE_ENV+= DOCS=docs
-.endif
-
-.if ${PORT_OPTIONS:MGNUTLS}
-CONFIGURE_ARGS+= --with-gnutls="${LOCALBASE}"
-LIB_DEPENDS+= gnutls:${PORTSDIR}/security/gnutls
-PLIST_SUB+= GNUTLS=""
-.else
-CONFIGURE_ARGS+= --without-gnutls
-PLIST_SUB+= GNUTLS="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MNSS}
-CONFIGURE_ARGS+= --with-nss="${LOCALBASE}" --with-nspr="${LOCALBASE}"
-LIB_DEPENDS+= nss3:${PORTSDIR}/security/nss
-PLIST_SUB+= NSS=""
-.else
-CONFIGURE_ARGS+= --without-nss
-PLIST_SUB+= NSS="@comment "
-.endif
-
-CONFIGURE_ARGS+= --with-openssl="${OPENSSLBASE}"
+# avoid --without-opt=PATH constructs
+CONFIGURE_ARGS:=${CONFIGURE_ARGS:C/without-([a-z]*)=.*/without-\1/}
post-patch:
@${REINPLACE_CMD} -e 's|src apps man docs|src apps man \$${DOCS}|g' \
@@ -95,4 +76,7 @@ post-patch:
${WRKSRC}/apps/Makefile.in
.endif
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libxmlsec1*.so
+
.include <bsd.port.mk>
diff --git a/security/xmlsec1/pkg-plist b/security/xmlsec1/pkg-plist
index 2eb3b712276b..deeb54397df8 100644
--- a/security/xmlsec1/pkg-plist
+++ b/security/xmlsec1/pkg-plist
@@ -1,49 +1,6 @@
bin/xmlsec1
bin/xmlsec1-config
etc/xmlsec1Conf.sh
-share/aclocal/xmlsec1.m4
-lib/libxmlsec1-gcrypt.a
-lib/libxmlsec1-gcrypt.la
-lib/libxmlsec1-gcrypt.so
-lib/libxmlsec1-gcrypt.so.3
-lib/libxmlsec1-openssl.a
-lib/libxmlsec1-openssl.la
-lib/libxmlsec1-openssl.so
-lib/libxmlsec1-openssl.so.3
-lib/libxmlsec1.a
-lib/libxmlsec1.la
-lib/libxmlsec1.so
-lib/libxmlsec1.so.3
-%%GNUTLS%%lib/libxmlsec1-gnutls.a
-%%GNUTLS%%lib/libxmlsec1-gnutls.la
-%%GNUTLS%%lib/libxmlsec1-gnutls.so
-%%GNUTLS%%lib/libxmlsec1-gnutls.so.3
-%%NSS%%lib/libxmlsec1-nss.a
-%%NSS%%lib/libxmlsec1-nss.la
-%%NSS%%lib/libxmlsec1-nss.so
-%%NSS%%lib/libxmlsec1-nss.so.3
-include/xmlsec1/xmlsec/private/xkms.h
-include/xmlsec1/xmlsec/private/xslt.h
-include/xmlsec1/xmlsec/openssl/app.h
-include/xmlsec1/xmlsec/openssl/bn.h
-include/xmlsec1/xmlsec/openssl/crypto.h
-include/xmlsec1/xmlsec/openssl/evp.h
-include/xmlsec1/xmlsec/openssl/symbols.h
-include/xmlsec1/xmlsec/openssl/x509.h
-include/xmlsec1/xmlsec/gcrypt/app.h
-include/xmlsec1/xmlsec/gcrypt/crypto.h
-include/xmlsec1/xmlsec/gcrypt/symbols.h
-%%GNUTLS%%include/xmlsec1/xmlsec/gnutls/app.h
-%%GNUTLS%%include/xmlsec1/xmlsec/gnutls/crypto.h
-%%GNUTLS%%include/xmlsec1/xmlsec/gnutls/symbols.h
-%%GNUTLS%%include/xmlsec1/xmlsec/gnutls/x509.h
-%%NSS%%include/xmlsec1/xmlsec/nss/app.h
-%%NSS%%include/xmlsec1/xmlsec/nss/bignum.h
-%%NSS%%include/xmlsec1/xmlsec/nss/crypto.h
-%%NSS%%include/xmlsec1/xmlsec/nss/keysstore.h
-%%NSS%%include/xmlsec1/xmlsec/nss/pkikeys.h
-%%NSS%%include/xmlsec1/xmlsec/nss/symbols.h
-%%NSS%%include/xmlsec1/xmlsec/nss/x509.h
include/xmlsec1/xmlsec/app.h
include/xmlsec1/xmlsec/base64.h
include/xmlsec1/xmlsec/bn.h
@@ -52,16 +9,38 @@ include/xmlsec1/xmlsec/crypto.h
include/xmlsec1/xmlsec/dl.h
include/xmlsec1/xmlsec/errors.h
include/xmlsec1/xmlsec/exports.h
+include/xmlsec1/xmlsec/gcrypt/app.h
+include/xmlsec1/xmlsec/gcrypt/crypto.h
+include/xmlsec1/xmlsec/gcrypt/symbols.h
+%%GNUTLS%%include/xmlsec1/xmlsec/gnutls/app.h
+%%GNUTLS%%include/xmlsec1/xmlsec/gnutls/crypto.h
+%%GNUTLS%%include/xmlsec1/xmlsec/gnutls/symbols.h
+%%GNUTLS%%include/xmlsec1/xmlsec/gnutls/x509.h
include/xmlsec1/xmlsec/io.h
include/xmlsec1/xmlsec/keyinfo.h
-include/xmlsec1/xmlsec/keysdata.h
include/xmlsec1/xmlsec/keys.h
+include/xmlsec1/xmlsec/keysdata.h
include/xmlsec1/xmlsec/keysmngr.h
include/xmlsec1/xmlsec/list.h
include/xmlsec1/xmlsec/membuf.h
include/xmlsec1/xmlsec/nodeset.h
+%%NSS%%include/xmlsec1/xmlsec/nss/app.h
+%%NSS%%include/xmlsec1/xmlsec/nss/bignum.h
+%%NSS%%include/xmlsec1/xmlsec/nss/crypto.h
+%%NSS%%include/xmlsec1/xmlsec/nss/keysstore.h
+%%NSS%%include/xmlsec1/xmlsec/nss/pkikeys.h
+%%NSS%%include/xmlsec1/xmlsec/nss/symbols.h
+%%NSS%%include/xmlsec1/xmlsec/nss/x509.h
+include/xmlsec1/xmlsec/openssl/app.h
+include/xmlsec1/xmlsec/openssl/bn.h
+include/xmlsec1/xmlsec/openssl/crypto.h
+include/xmlsec1/xmlsec/openssl/evp.h
+include/xmlsec1/xmlsec/openssl/symbols.h
+include/xmlsec1/xmlsec/openssl/x509.h
include/xmlsec1/xmlsec/parser.h
include/xmlsec1/xmlsec/private.h
+include/xmlsec1/xmlsec/private/xkms.h
+include/xmlsec1/xmlsec/private/xslt.h
include/xmlsec1/xmlsec/soap.h
include/xmlsec1/xmlsec/strings.h
include/xmlsec1/xmlsec/templates.h
@@ -73,15 +52,188 @@ include/xmlsec1/xmlsec/xmldsig.h
include/xmlsec1/xmlsec/xmlenc.h
include/xmlsec1/xmlsec/xmlsec.h
include/xmlsec1/xmlsec/xmltree.h
-%%GNUTLS%%@dirrm include/xmlsec1/xmlsec/gnutls
-%%NSS%%@dirrm include/xmlsec1/xmlsec/nss
-@dirrm include/xmlsec1/xmlsec/gcrypt
-@dirrm include/xmlsec1/xmlsec/openssl
-@dirrm include/xmlsec1/xmlsec/private
-@dirrm include/xmlsec1/xmlsec
-@dirrm include/xmlsec1
+lib/libxmlsec1-gcrypt.a
+lib/libxmlsec1-gcrypt.la
+lib/libxmlsec1-gcrypt.so
+lib/libxmlsec1-gcrypt.so.3
+%%GNUTLS%%lib/libxmlsec1-gnutls.a
+%%GNUTLS%%lib/libxmlsec1-gnutls.la
+%%GNUTLS%%lib/libxmlsec1-gnutls.so
+%%GNUTLS%%lib/libxmlsec1-gnutls.so.3
+%%NSS%%lib/libxmlsec1-nss.a
+%%NSS%%lib/libxmlsec1-nss.la
+%%NSS%%lib/libxmlsec1-nss.so
+%%NSS%%lib/libxmlsec1-nss.so.3
+lib/libxmlsec1-openssl.a
+lib/libxmlsec1-openssl.la
+lib/libxmlsec1-openssl.so
+lib/libxmlsec1-openssl.so.3
+lib/libxmlsec1.a
+lib/libxmlsec1.la
+lib/libxmlsec1.so
+lib/libxmlsec1.so.3
+libdata/pkgconfig/xmlsec1-gcrypt.pc
%%GNUTLS%%libdata/pkgconfig/xmlsec1-gnutls.pc
%%NSS%%libdata/pkgconfig/xmlsec1-nss.pc
-libdata/pkgconfig/xmlsec1-gcrypt.pc
libdata/pkgconfig/xmlsec1-openssl.pc
libdata/pkgconfig/xmlsec1.pc
+man/man1/xmlsec1-config.1.gz
+man/man1/xmlsec1.1.gz
+share/aclocal/xmlsec1.m4
+%%PORTDOCS%%%%DOCSDIR%%/api/home.png
+%%PORTDOCS%%%%DOCSDIR%%/api/images/encryption-structure.png
+%%PORTDOCS%%%%DOCSDIR%%/api/images/key.png
+%%PORTDOCS%%%%DOCSDIR%%/api/images/keysmngr.png
+%%PORTDOCS%%%%DOCSDIR%%/api/images/sign-enc-model.png
+%%PORTDOCS%%%%DOCSDIR%%/api/images/signature-structure.png
+%%PORTDOCS%%%%DOCSDIR%%/api/images/structure.png
+%%PORTDOCS%%%%DOCSDIR%%/api/images/transform.png
+%%PORTDOCS%%%%DOCSDIR%%/api/images/transforms-chain.png
+%%PORTDOCS%%%%DOCSDIR%%/api/images/verif-dec-model.png
+%%PORTDOCS%%%%DOCSDIR%%/api/index.html
+%%PORTDOCS%%%%DOCSDIR%%/api/index.sgml
+%%PORTDOCS%%%%DOCSDIR%%/api/left.png
+%%PORTDOCS%%%%DOCSDIR%%/api/right.png
+%%PORTDOCS%%%%DOCSDIR%%/api/up.png
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-app.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-base64.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-bn.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-buffer.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-custom-keys-manager.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-decrypt-with-keys-mngr.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-decrypt-with-signle-key.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-dl.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-encrypt-dynamic-template.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-encrypt-template-file.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-encrypt-with-session-key.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-encryption-klasses.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-errors.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-examples-sign-dynamimc-template.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-examples-sign-template-file.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-examples-sign-x509.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-examples.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-gcrypt-app.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-gcrypt-crypto.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-gcrypt-ref.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-gcrypt.sgml
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-gnutls-app.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-gnutls-crypto.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-gnutls-ref.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-gnutls.sgml
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-index.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-index.sgml
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-io.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-keyinfo.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-keys.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-keysdata.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-keysmngr.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-list.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-membuf.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-mscrypto-app.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-mscrypto-certkeys.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-mscrypto-crypto.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-mscrypto-keysstore.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-mscrypto-ref.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-mscrypto-x509.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-mscrypto.sgml
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-nodeset.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-notes-compiling-others.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-notes-compiling-unix.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-notes-compiling-windows.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-notes-compiling.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-notes-contexts.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-notes-custom-keys-store.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-notes-decrypt.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-notes-dynamic-encryption-templates.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-notes-dynamic-signature-templates.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-notes-encrypt.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-notes-include-files.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-notes-init-shutdown.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-notes-keys-manager-sign-enc.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-notes-keys-mngr-verify-decrypt.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-notes-keys.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-notes-keysmngr.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-notes-new-crypto-functions.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-notes-new-crypto-key-stores.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-notes-new-crypto-keys.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-notes-new-crypto-klasses.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-notes-new-crypto-sharing-results.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-notes-new-crypto-simple-keys-mngr.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-notes-new-crypto-skeleton.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-notes-new-crypto-transforms.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-notes-new-crypto.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-notes-overview.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-notes-sign-encrypt.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-notes-sign-x509.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-notes-sign.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-notes-simple-keys-store.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-notes-structure.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-notes-templates.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-notes-transforms.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-notes-verify-decrypt.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-notes-verify-x509.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-notes-verify.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-notes-x509.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-notes.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-nss-app.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-nss-bignum.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-nss-crypto.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-nss-keysstore.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-nss-pkikeys.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-nss-ref.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-nss-x509.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-nss.sgml
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-openssl-app.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-openssl-bn.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-openssl-crypto.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-openssl-evp.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-openssl-ref.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-openssl-x509.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-openssl.sgml
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-parser.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-ref.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-reference.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-signature-klasses.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-templates.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-transforms.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-verify-with-key.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-verify-with-keys-mngr.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-verify-with-restrictions.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-verify-with-x509.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-version.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-x509.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-xmldsig.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-xmlenc.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-xmlsec.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-xmltree.html
+%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec.sgml
+%%PORTDOCS%%%%DOCSDIR%%/authors.html
+%%PORTDOCS%%%%DOCSDIR%%/bugs.html
+%%PORTDOCS%%%%DOCSDIR%%/c14n.html
+%%PORTDOCS%%%%DOCSDIR%%/documentation.html
+%%PORTDOCS%%%%DOCSDIR%%/download.html
+%%PORTDOCS%%%%DOCSDIR%%/faq.html
+%%PORTDOCS%%%%DOCSDIR%%/images/bart.gif
+%%PORTDOCS%%%%DOCSDIR%%/images/libxml2-logo.png
+%%PORTDOCS%%%%DOCSDIR%%/images/libxslt-logo.png
+%%PORTDOCS%%%%DOCSDIR%%/images/logo.gif
+%%PORTDOCS%%%%DOCSDIR%%/images/openssl-logo.png
+%%PORTDOCS%%%%DOCSDIR%%/images/xmlsec-logo.gif
+%%PORTDOCS%%%%DOCSDIR%%/index.html
+%%PORTDOCS%%%%DOCSDIR%%/news.html
+%%PORTDOCS%%%%DOCSDIR%%/related.html
+%%PORTDOCS%%%%DOCSDIR%%/xmldsig-verifier.html
+%%PORTDOCS%%%%DOCSDIR%%/xmldsig.html
+%%PORTDOCS%%%%DOCSDIR%%/xmlenc.html
+%%PORTDOCS%%%%DOCSDIR%%/xmlsec-man.html
+%%PORTDOCS%%@dirrmtry %%DOCSDIR%%/images
+%%PORTDOCS%%@dirrmtry %%DOCSDIR%%/api/images
+%%PORTDOCS%%@dirrmtry %%DOCSDIR%%/api
+%%PORTDOCS%%@dirrmtry %%DOCSDIR%%
+@dirrmtry include/xmlsec1/xmlsec/private
+@dirrmtry include/xmlsec1/xmlsec/openssl
+%%NSS%%@dirrmtry include/xmlsec1/xmlsec/nss
+%%GNUTLS%%@dirrmtry include/xmlsec1/xmlsec/gnutls
+@dirrmtry include/xmlsec1/xmlsec/gcrypt
+@dirrmtry include/xmlsec1/xmlsec
+@dirrmtry include/xmlsec1