aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorMark Pulford <markp@FreeBSD.org>2002-04-02 12:58:21 +0000
committerMark Pulford <markp@FreeBSD.org>2002-04-02 12:58:21 +0000
commit30cda655e2d04e41d8223e257ea358f1180da643 (patch)
tree191d1f9cd65a9a626d2b261903a6ae99843b3739 /security
parentecdb1681020a2351657491d69c6008ae76a1c91b (diff)
downloadports-30cda655e2d04e41d8223e257ea358f1180da643.tar.gz
ports-30cda655e2d04e41d8223e257ea358f1180da643.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/vlog/Makefile28
-rw-r--r--security/vlog/distinfo1
-rw-r--r--security/vlog/pkg-comment1
-rw-r--r--security/vlog/pkg-descr21
-rw-r--r--security/vlog/pkg-plist1
6 files changed, 53 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 744905f61f00..527c18a94983 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -252,6 +252,7 @@
# SUBDIR += tripwire12
SUBDIR += uvscan-dat
SUBDIR += vlock
+ SUBDIR += vlog
SUBDIR += vpnd
SUBDIR += vscan
SUBDIR += whisker
diff --git a/security/vlog/Makefile b/security/vlog/Makefile
new file mode 100644
index 000000000000..13086ee7bc51
--- /dev/null
+++ b/security/vlog/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: vlog
+# Date created: 31 March 2002
+# Whom: hannes sowa <satbran@web.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= vlog
+PORTVERSION= 1.1f
+CATEGORIES= security
+MASTER_SITES= http://inc2.com/download/
+DISTNAME= vlog-${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= satbran@web.de
+
+ALL_TARGET= it
+MAKE_ARGS= CFLAGS="${CFLAGS} ${PTHREAD_CFLAGS}" \
+ LIBS="${PTHREAD_LIBS} -lcurses"
+WRKSRC= ${WRKDIR}/vlog
+
+MAN1= vlog.1
+MANCOMPRESSED= no
+
+post-patch:
+ ${PERL} -pi -e "s@/usr/local@${PREFIX}@g" ${WRKSRC}/Makefile
+
+.include <bsd.port.mk>
diff --git a/security/vlog/distinfo b/security/vlog/distinfo
new file mode 100644
index 000000000000..1c309af974ba
--- /dev/null
+++ b/security/vlog/distinfo
@@ -0,0 +1 @@
+MD5 (vlog-1.1f.tgz) = d60b2d615b9e94cc380859bf72845fb4
diff --git a/security/vlog/pkg-comment b/security/vlog/pkg-comment
new file mode 100644
index 000000000000..0343fda10aa1
--- /dev/null
+++ b/security/vlog/pkg-comment
@@ -0,0 +1 @@
+A curses based real-time logfile viewer
diff --git a/security/vlog/pkg-descr b/security/vlog/pkg-descr
new file mode 100644
index 000000000000..5e6a4b7799da
--- /dev/null
+++ b/security/vlog/pkg-descr
@@ -0,0 +1,21 @@
+vlog is a curses based real-time logfile viewer. It was designed
+to meet the following needs:
+
+ipmon viewer display IP-Filter log lines in a scrollable window
+ in a readable way
+
+real time viewing window receives log lines as soon as they're
+ appended to the log file
+
+old logfiles vlog can show the old rotated log files
+
+selecting log log lines to be viewed can be selected with a regexp
+lines given on the command line
+
+customizing one can control which fields are displayed
+display
+
+WWW: http://inc2.com/isba/index-vlog.html
+
+- Hannes Sowa
+satbran@web.de
diff --git a/security/vlog/pkg-plist b/security/vlog/pkg-plist
new file mode 100644
index 000000000000..a83ed21389d4
--- /dev/null
+++ b/security/vlog/pkg-plist
@@ -0,0 +1 @@
+bin/vlog