aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2005-12-20 15:50:08 +0000
committerErwin Lansing <erwin@FreeBSD.org>2005-12-20 15:50:08 +0000
commit7a9dfa805e663a3b205b310043c5ebb6af2f08e5 (patch)
tree7c357e03a747622e3884c0b749c77c35791b8328 /security
parent56e4435428061a8cab24423a5a95b2231fcb4337 (diff)
downloadports-7a9dfa805e663a3b205b310043c5ebb6af2f08e5.tar.gz
ports-7a9dfa805e663a3b205b310043c5ebb6af2f08e5.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/p5-Crypt-GOST/Makefile24
-rw-r--r--security/p5-Crypt-GOST/distinfo3
-rw-r--r--security/p5-Crypt-GOST/pkg-descr9
-rw-r--r--security/p5-Crypt-GOST/pkg-plist7
5 files changed, 44 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 1b5e8bda42e0..2516358d6200 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -301,6 +301,7 @@
SUBDIR += p5-Crypt-DH
SUBDIR += p5-Crypt-DSA
SUBDIR += p5-Crypt-ECB
+ SUBDIR += p5-Crypt-GOST
SUBDIR += p5-Crypt-GPG
SUBDIR += p5-Crypt-GeneratePassword
SUBDIR += p5-Crypt-HCE_MD5
diff --git a/security/p5-Crypt-GOST/Makefile b/security/p5-Crypt-GOST/Makefile
new file mode 100644
index 000000000000..c1eb0f9141e2
--- /dev/null
+++ b/security/p5-Crypt-GOST/Makefile
@@ -0,0 +1,24 @@
+# New ports collection Makefile for: p5-Crypt-GOST
+# Date created: 20 Dec 2006
+# Whom: Gabor Kovesdan
+# $FreeBSD$
+
+PORTNAME= Crypt-GOST
+PORTVERSION= 1.00
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Crypt
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gkovesdan@t-hosting.hu
+COMMENT= Perl extension for GOST Encryption Algorithm
+
+PERL_CONFIGURE= yes
+
+MAN3= Crypt::GOST.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} <= 500503
+IGNORE= requires Perl 5.6. Intall lang/perl5 or lang/perl5.8, and try again
+.endif
+.include <bsd.port.post.mk>
diff --git a/security/p5-Crypt-GOST/distinfo b/security/p5-Crypt-GOST/distinfo
new file mode 100644
index 000000000000..25af528aaff2
--- /dev/null
+++ b/security/p5-Crypt-GOST/distinfo
@@ -0,0 +1,3 @@
+MD5 (Crypt-GOST-1.00.tar.gz) = 0250fb0539db739baf6608318894d67d
+SHA256 (Crypt-GOST-1.00.tar.gz) = 7f7d7ef5d6dde5e7bbd09b198176f6e73e09bfdfbd7f4c707cb24ffcd124eba9
+SIZE (Crypt-GOST-1.00.tar.gz) = 8935
diff --git a/security/p5-Crypt-GOST/pkg-descr b/security/p5-Crypt-GOST/pkg-descr
new file mode 100644
index 000000000000..a95f466d810f
--- /dev/null
+++ b/security/p5-Crypt-GOST/pkg-descr
@@ -0,0 +1,9 @@
+GOST 28147-89 is a 64-bit symmetric block cipher with a 256-bit
+key developed in the former Soviet Union. Some information on it
+is available at http://vipul.net/gost/ .
+This module implements GOST encryption. It supports the Crypt::CBC
+interface, with the functions described below. It also provides
+an interface that is backwards- compatible with Crypt::GOST 0.41,
+but its use in new code is discouraged.
+
+WWW: http://search.cpan.org/dist/Crypt-GOST
diff --git a/security/p5-Crypt-GOST/pkg-plist b/security/p5-Crypt-GOST/pkg-plist
new file mode 100644
index 000000000000..122d6e83bf4d
--- /dev/null
+++ b/security/p5-Crypt-GOST/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/Crypt/GOST.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/GOST/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/GOST/GOST.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/GOST/GOST.so
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/GOST/
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/Crypt 2>/dev/null || true