aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>1998-12-15 11:18:32 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>1998-12-15 11:18:32 +0000
commit7091c3a40e8a6953c5f34f2b358848ac2a7f6e04 (patch)
tree77c50c2f0c844f14dde7e586c10c0e2f3d1dfbc6 /security
parent70f829e8fc33c6dbc7cfd7a7d30e1424ca67b53f (diff)
downloadports-7091c3a40e8a6953c5f34f2b358848ac2a7f6e04.tar.gz
ports-7091c3a40e8a6953c5f34f2b358848ac2a7f6e04.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/nmap/Makefile15
-rw-r--r--security/nmap/distinfo2
-rw-r--r--security/nmap/files/patch-aa20
-rw-r--r--security/nmap/pkg-descr2
-rw-r--r--security/nmap/pkg-plist2
-rw-r--r--security/nmapfe/Makefile15
-rw-r--r--security/nmapfe/distinfo2
-rw-r--r--security/nmapfe/pkg-descr2
-rw-r--r--security/nmapfe/pkg-plist2
-rw-r--r--security/zenmap/Makefile15
-rw-r--r--security/zenmap/distinfo2
-rw-r--r--security/zenmap/pkg-descr2
-rw-r--r--security/zenmap/pkg-plist2
13 files changed, 58 insertions, 25 deletions
diff --git a/security/nmap/Makefile b/security/nmap/Makefile
index 43ccfbf3492a..4c3ab54524bc 100644
--- a/security/nmap/Makefile
+++ b/security/nmap/Makefile
@@ -4,17 +4,23 @@
# Date created: Tue Aug 04, 1998
# Whom: David O'Brien (obrien@NUXI.com)
#
-# $Id: Makefile,v 1.3 1998/08/18 14:31:31 ache Exp $
+# $Id: Makefile,v 1.4 1998/08/20 22:06:00 obrien Exp $
#
-DISTNAME= nmap-1.51
+DISTNAME= nmap-2.00
CATEGORIES= security net
-MASTER_SITES= http://www.insecure.org/nmap/
+MASTER_SITES= http://www.insecure.org/nmap/ \
+ ftp://relay.nuxi.com/pub/misc/
+EXTRACT_SUFX= .tgz
MAINTAINER= obrien@FreeBSD.org
GNU_CONFIGURE= yes
-CFLAGS+= -DDLT_RAW=12 # for obsoleted <net/bpf.h>
+CONFIGURE_ARGS= --libdir=${PREFIX}/share/misc
+OSVERSION!= sysctl -n kern.osreldate
+.if ${OSVERSION} < 300004
+CFLAGS+= -DDLT_RAW=12 # for obsoleted <net/bpf.h>
+.endif
MAN1= nmap.1
post-extract:
@@ -22,6 +28,5 @@ post-extract:
post-install:
@strip ${PREFIX}/bin/nmap
- @${INSTALL_MAN} ${FILESDIR}/nmap.1 ${PREFIX}/man/man1
.include <bsd.port.mk>
diff --git a/security/nmap/distinfo b/security/nmap/distinfo
index ed2e8d80b962..e85bfc9bf196 100644
--- a/security/nmap/distinfo
+++ b/security/nmap/distinfo
@@ -1 +1 @@
-MD5 (nmap-1.51.tar.gz) = 1a5e2d4fbc455120a581c1bd68dbd9d7
+MD5 (nmap-2.00.tgz) = 063f1b0d901e0787416c92d67b1cd283
diff --git a/security/nmap/files/patch-aa b/security/nmap/files/patch-aa
index b156d2da2b59..ec1b31285915 100644
--- a/security/nmap/files/patch-aa
+++ b/security/nmap/files/patch-aa
@@ -1,11 +1,17 @@
---- Makefile.in.orig Mon May 25 06:11:27 1998
-+++ Makefile.in Thu Aug 20 15:04:19 1998
-@@ -9,7 +9,7 @@
+--- Makefile.in.orig Wed Oct 7 19:59:00 1998
++++ Makefile.in Thu Oct 8 03:57:23 1998
+@@ -10,4 +10,4 @@
CC = @CC@
CCOPT =
LIBPCAPDIR = @libpcapdir@
-INCLS = -I. -I$(LIBPCAPDIR)
-+INCLS = -I.
- DEFS = @DEFS@
- CFLAGS = @CFLAGS@ $(CCOPT) $(DEFS) $(INCLS)
- LDFLAGS = @LDFLAGS@
++INCLS = -I. # -I$(LIBPCAPDIR)
+@@ -30,7 +30,7 @@
+
+ all: $(TARGET)
+
+-$(TARGET): $(DEPS) @PCAP_DEPENDS@ $(OBJS)
++$(TARGET): $(DEPS) $(OBJS) # @PCAP_DEPENDS@
+ @echo Compiling nmap
+ rm -f $@
+ $(CC) $(LDFLAGS) -o $@ $(OBJS) $(LIBS)
diff --git a/security/nmap/pkg-descr b/security/nmap/pkg-descr
index c77e677a1b2e..606e9ad916ef 100644
--- a/security/nmap/pkg-descr
+++ b/security/nmap/pkg-descr
@@ -7,6 +7,8 @@ ICMP, etc.). You just can't do all this with one scanning mode. Thus nmap
incorporats virtually every scanning technique known of.
See the nmap homepage at http://www.insecure.org/nmap/index.html
+And the Phrack Magazine article (Volume 7, Issue 51 September 01, 1997,
+article 11 of 17) http://www.insecure.org/nmap/p51-11.txt
-- David
obrien@cs.ucdavis.edu
diff --git a/security/nmap/pkg-plist b/security/nmap/pkg-plist
index f9b01259219a..a178256d58f8 100644
--- a/security/nmap/pkg-plist
+++ b/security/nmap/pkg-plist
@@ -1 +1,3 @@
+@comment $Id$
bin/nmap
+share/misc/nmap-os-fingerprints
diff --git a/security/nmapfe/Makefile b/security/nmapfe/Makefile
index 43ccfbf3492a..4c3ab54524bc 100644
--- a/security/nmapfe/Makefile
+++ b/security/nmapfe/Makefile
@@ -4,17 +4,23 @@
# Date created: Tue Aug 04, 1998
# Whom: David O'Brien (obrien@NUXI.com)
#
-# $Id: Makefile,v 1.3 1998/08/18 14:31:31 ache Exp $
+# $Id: Makefile,v 1.4 1998/08/20 22:06:00 obrien Exp $
#
-DISTNAME= nmap-1.51
+DISTNAME= nmap-2.00
CATEGORIES= security net
-MASTER_SITES= http://www.insecure.org/nmap/
+MASTER_SITES= http://www.insecure.org/nmap/ \
+ ftp://relay.nuxi.com/pub/misc/
+EXTRACT_SUFX= .tgz
MAINTAINER= obrien@FreeBSD.org
GNU_CONFIGURE= yes
-CFLAGS+= -DDLT_RAW=12 # for obsoleted <net/bpf.h>
+CONFIGURE_ARGS= --libdir=${PREFIX}/share/misc
+OSVERSION!= sysctl -n kern.osreldate
+.if ${OSVERSION} < 300004
+CFLAGS+= -DDLT_RAW=12 # for obsoleted <net/bpf.h>
+.endif
MAN1= nmap.1
post-extract:
@@ -22,6 +28,5 @@ post-extract:
post-install:
@strip ${PREFIX}/bin/nmap
- @${INSTALL_MAN} ${FILESDIR}/nmap.1 ${PREFIX}/man/man1
.include <bsd.port.mk>
diff --git a/security/nmapfe/distinfo b/security/nmapfe/distinfo
index ed2e8d80b962..e85bfc9bf196 100644
--- a/security/nmapfe/distinfo
+++ b/security/nmapfe/distinfo
@@ -1 +1 @@
-MD5 (nmap-1.51.tar.gz) = 1a5e2d4fbc455120a581c1bd68dbd9d7
+MD5 (nmap-2.00.tgz) = 063f1b0d901e0787416c92d67b1cd283
diff --git a/security/nmapfe/pkg-descr b/security/nmapfe/pkg-descr
index c77e677a1b2e..606e9ad916ef 100644
--- a/security/nmapfe/pkg-descr
+++ b/security/nmapfe/pkg-descr
@@ -7,6 +7,8 @@ ICMP, etc.). You just can't do all this with one scanning mode. Thus nmap
incorporats virtually every scanning technique known of.
See the nmap homepage at http://www.insecure.org/nmap/index.html
+And the Phrack Magazine article (Volume 7, Issue 51 September 01, 1997,
+article 11 of 17) http://www.insecure.org/nmap/p51-11.txt
-- David
obrien@cs.ucdavis.edu
diff --git a/security/nmapfe/pkg-plist b/security/nmapfe/pkg-plist
index f9b01259219a..a178256d58f8 100644
--- a/security/nmapfe/pkg-plist
+++ b/security/nmapfe/pkg-plist
@@ -1 +1,3 @@
+@comment $Id$
bin/nmap
+share/misc/nmap-os-fingerprints
diff --git a/security/zenmap/Makefile b/security/zenmap/Makefile
index 43ccfbf3492a..4c3ab54524bc 100644
--- a/security/zenmap/Makefile
+++ b/security/zenmap/Makefile
@@ -4,17 +4,23 @@
# Date created: Tue Aug 04, 1998
# Whom: David O'Brien (obrien@NUXI.com)
#
-# $Id: Makefile,v 1.3 1998/08/18 14:31:31 ache Exp $
+# $Id: Makefile,v 1.4 1998/08/20 22:06:00 obrien Exp $
#
-DISTNAME= nmap-1.51
+DISTNAME= nmap-2.00
CATEGORIES= security net
-MASTER_SITES= http://www.insecure.org/nmap/
+MASTER_SITES= http://www.insecure.org/nmap/ \
+ ftp://relay.nuxi.com/pub/misc/
+EXTRACT_SUFX= .tgz
MAINTAINER= obrien@FreeBSD.org
GNU_CONFIGURE= yes
-CFLAGS+= -DDLT_RAW=12 # for obsoleted <net/bpf.h>
+CONFIGURE_ARGS= --libdir=${PREFIX}/share/misc
+OSVERSION!= sysctl -n kern.osreldate
+.if ${OSVERSION} < 300004
+CFLAGS+= -DDLT_RAW=12 # for obsoleted <net/bpf.h>
+.endif
MAN1= nmap.1
post-extract:
@@ -22,6 +28,5 @@ post-extract:
post-install:
@strip ${PREFIX}/bin/nmap
- @${INSTALL_MAN} ${FILESDIR}/nmap.1 ${PREFIX}/man/man1
.include <bsd.port.mk>
diff --git a/security/zenmap/distinfo b/security/zenmap/distinfo
index ed2e8d80b962..e85bfc9bf196 100644
--- a/security/zenmap/distinfo
+++ b/security/zenmap/distinfo
@@ -1 +1 @@
-MD5 (nmap-1.51.tar.gz) = 1a5e2d4fbc455120a581c1bd68dbd9d7
+MD5 (nmap-2.00.tgz) = 063f1b0d901e0787416c92d67b1cd283
diff --git a/security/zenmap/pkg-descr b/security/zenmap/pkg-descr
index c77e677a1b2e..606e9ad916ef 100644
--- a/security/zenmap/pkg-descr
+++ b/security/zenmap/pkg-descr
@@ -7,6 +7,8 @@ ICMP, etc.). You just can't do all this with one scanning mode. Thus nmap
incorporats virtually every scanning technique known of.
See the nmap homepage at http://www.insecure.org/nmap/index.html
+And the Phrack Magazine article (Volume 7, Issue 51 September 01, 1997,
+article 11 of 17) http://www.insecure.org/nmap/p51-11.txt
-- David
obrien@cs.ucdavis.edu
diff --git a/security/zenmap/pkg-plist b/security/zenmap/pkg-plist
index f9b01259219a..a178256d58f8 100644
--- a/security/zenmap/pkg-plist
+++ b/security/zenmap/pkg-plist
@@ -1 +1,3 @@
+@comment $Id$
bin/nmap
+share/misc/nmap-os-fingerprints