aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2006-06-08 09:44:48 +0000
committerErwin Lansing <erwin@FreeBSD.org>2006-06-08 09:44:48 +0000
commit9bf2eb4547725394e754cd561055f569cb97796a (patch)
treee6fa1c6ffc3cfd4ac7a69f059f37d95d220fba1e /security
parent7756498995f05c15bd7e02274246ccab89240aa6 (diff)
The NTLM (Windows NT LAN Manager) authentication scheme is the
authentication algorithm used by Microsoft. NTLM authentication scheme is used in DCOM and HTTP environment. It is used to authenticate DCE RPC packets in DCOM. It is also used to authenticate HTTP packets to MS Web Proxy or MS Web Server. Currently, it is the authentication scheme Internet Explorer chooses to authenticate itself to proxies/web servers that supports NTLM. WWW: http://search.cpan.org/dist/Authen-NTLM/ PR: ports/98684 Submitted by: James Thomason <james@divide.org>
Notes
Notes: svn path=/head/; revision=164802
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/p5-Authen-NTLM/Makefile25
-rw-r--r--security/p5-Authen-NTLM/distinfo3
-rw-r--r--security/p5-Authen-NTLM/pkg-descr11
-rw-r--r--security/p5-Authen-NTLM/pkg-plist8
5 files changed, 48 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 4ebeda3b9a71..982d629605a1 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -286,6 +286,7 @@
SUBDIR += p5-Authen-Htpasswd
SUBDIR += p5-Authen-Krb5
SUBDIR += p5-Authen-Libwrap
+ SUBDIR += p5-Authen-NTLM
SUBDIR += p5-Authen-PAM
SUBDIR += p5-Authen-Radius
SUBDIR += p5-Authen-SASL
diff --git a/security/p5-Authen-NTLM/Makefile b/security/p5-Authen-NTLM/Makefile
new file mode 100644
index 000000000000..d005568486bc
--- /dev/null
+++ b/security/p5-Authen-NTLM/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-Authen-NTLM
+# Date created: June 07 2006
+# Whom: James Thomason <james@divide.org>
+#
+#
+# $FreeBSD$
+
+PORTNAME= NTLM
+PORTVERSION= 1.02
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Authen
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= james@divide.org
+COMMENT= Perl extension to authenticate against an NTLM server
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Authen::NTLM.3
+
+.include <bsd.port.mk>
diff --git a/security/p5-Authen-NTLM/distinfo b/security/p5-Authen-NTLM/distinfo
new file mode 100644
index 000000000000..2e7fe2766c3a
--- /dev/null
+++ b/security/p5-Authen-NTLM/distinfo
@@ -0,0 +1,3 @@
+MD5 (NTLM-1.02.tar.gz) = 35a2304a107f65086e1c5670a41d97c4
+SHA256 (NTLM-1.02.tar.gz) = dbcc7eb1cb9dc42a9836de6acc57eee1ba22f5d3a0d3639c6b0bf70be134a34c
+SIZE (NTLM-1.02.tar.gz) = 8589
diff --git a/security/p5-Authen-NTLM/pkg-descr b/security/p5-Authen-NTLM/pkg-descr
new file mode 100644
index 000000000000..28efa0312533
--- /dev/null
+++ b/security/p5-Authen-NTLM/pkg-descr
@@ -0,0 +1,11 @@
+The NTLM (Windows NT LAN Manager) authentication scheme is the
+authentication algorithm used by Microsoft.
+
+NTLM authentication scheme is used in DCOM and HTTP environment. It is
+used to authenticate DCE RPC packets in DCOM. It is also used to
+authenticate HTTP packets to MS Web Proxy or MS Web Server.
+
+Currently, it is the authentication scheme Internet Explorer chooses to
+authenticate itself to proxies/web servers that supports NTLM.
+
+WWW: http://search.cpan.org/dist/Authen-NTLM/
diff --git a/security/p5-Authen-NTLM/pkg-plist b/security/p5-Authen-NTLM/pkg-plist
new file mode 100644
index 000000000000..77ffe185904e
--- /dev/null
+++ b/security/p5-Authen-NTLM/pkg-plist
@@ -0,0 +1,8 @@
+%%SITE_PERL%%/Authen/NTLM.pm
+%%SITE_PERL%%/Authen/NTLM/DES.pm
+%%SITE_PERL%%/Authen/NTLM/MD4.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Authen/NTLM/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Authen/NTLM
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Authen
+@dirrm %%SITE_PERL%%/Authen/NTLM
+@dirrmtry %%SITE_PERL%%/Authen