aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2010-04-12 12:56:56 +0000
committerRenato Botelho <garga@FreeBSD.org>2010-04-12 12:56:56 +0000
commitcd427c3ffbe58de744b0abbfedfe00fb145022e9 (patch)
treece5429b2e121e19dbb4de9f959c37ab2157034d9 /security
parentfd75cdf4d1d360f716e20b98ea6b720675bab9ff (diff)
downloadports-cd427c3ffbe58de744b0abbfedfe00fb145022e9.tar.gz
ports-cd427c3ffbe58de744b0abbfedfe00fb145022e9.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/clamav-devel/Makefile18
-rw-r--r--security/clamav/Makefile18
2 files changed, 34 insertions, 2 deletions
diff --git a/security/clamav-devel/Makefile b/security/clamav-devel/Makefile
index ff6fb6c606ef..50afece9ff05 100644
--- a/security/clamav-devel/Makefile
+++ b/security/clamav-devel/Makefile
@@ -40,6 +40,7 @@ DBDIR= /var/db/clamav
LOGDIR= /var/log/clamav
RUNDIR= /var/run/clamav
PLIST_SUB+= DBDIR=${DBDIR} LOGDIR=${LOGDIR} RUNDIR=${RUNDIR}
+PY_NO_THREAD= ${WRKDIR}/.python-has-no-threads
CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" \
LDFLAGS="${LDFLAGS}"
@@ -197,9 +198,24 @@ post-patch:
@${REINPLACE_CMD} -e 's|0x100000000|0x100000000ULL|g' \
${WRKSRC}/libclamunrar/unrar.c
+.if defined(WITH_LLVM)
+pre-configure:
+ @if ! ${PYTHON_CMD} -c "import thread" >/dev/null 2>&1; then \
+ ${ECHO_MSG} ""; \
+ ${ECHO_MSG} "==========================================================================="; \
+ ${ECHO_MSG} "= Unit tests REQUIRES python built with thread support, and yours is not. ="; \
+ ${ECHO_MSG} "= It will not be called during this build ="; \
+ ${ECHO_MSG} "==========================================================================="; \
+ ${ECHO_MSG} ""; \
+ touch ${PY_NO_THREAD}; \
+ fi
+.endif
+
.if ${OSVERSION} >= 700000
post-build:
- @${MAKE} -C ${WRKSRC} check
+ @if [ -f "${PY_NO_THREAD}" ]; then \
+ ${MAKE} -C ${WRKSRC} check; \
+ fi
.endif
pre-su-install:
diff --git a/security/clamav/Makefile b/security/clamav/Makefile
index c850c2e42b29..0b51da968932 100644
--- a/security/clamav/Makefile
+++ b/security/clamav/Makefile
@@ -38,6 +38,7 @@ DBDIR= /var/db/clamav
LOGDIR= /var/log/clamav
RUNDIR= /var/run/clamav
PLIST_SUB+= DBDIR=${DBDIR} LOGDIR=${LOGDIR} RUNDIR=${RUNDIR}
+PY_NO_THREAD= ${WRKDIR}/.python-has-no-threads
CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" \
LDFLAGS="${LDFLAGS}"
@@ -196,9 +197,24 @@ post-patch:
@${REINPLACE_CMD} -e 's|0x100000000|0x100000000ULL|g' \
${WRKSRC}/libclamunrar/unrar.c
+.if defined(WITH_LLVM)
+pre-configure:
+ @if ! ${PYTHON_CMD} -c "import thread" >/dev/null 2>&1; then \
+ ${ECHO_MSG} ""; \
+ ${ECHO_MSG} "==========================================================================="; \
+ ${ECHO_MSG} "= Unit tests REQUIRES python built with thread support, and yours is not. ="; \
+ ${ECHO_MSG} "= It will not be called during this build ="; \
+ ${ECHO_MSG} "==========================================================================="; \
+ ${ECHO_MSG} ""; \
+ touch ${PY_NO_THREAD}; \
+ fi
+.endif
+
.if ${OSVERSION} >= 700000
post-build:
- @${MAKE} -C ${WRKSRC} check
+ @if [ -f "${PY_NO_THREAD}" ]; then \
+ ${MAKE} -C ${WRKSRC} check; \
+ fi
.endif
pre-su-install: