aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2007-08-09 09:22:28 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2007-08-09 09:22:28 +0000
commit19e642669cc39634d43cca91461eaf8281f4aac5 (patch)
tree14615662fddab1abe096aa965b15e3c7fdd1eeb8 /security
parent345b8cc79fd1a9dc6fe992f5ca20007747243437 (diff)
Notes
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/clamtk/Makefile50
-rw-r--r--security/clamtk/distinfo3
-rw-r--r--security/clamtk/pkg-descr5
-rw-r--r--security/clamtk/pkg-plist17
5 files changed, 76 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 726fe02c5fac..83eb39b0e257 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -72,6 +72,7 @@
SUBDIR += clamav-devel
SUBDIR += clamcour
SUBDIR += clamsmtp
+ SUBDIR += clamtk
SUBDIR += clusterssh
SUBDIR += cmd5checkpw
SUBDIR += courier-authlib
diff --git a/security/clamtk/Makefile b/security/clamtk/Makefile
new file mode 100644
index 000000000000..5e3f32ceca5a
--- /dev/null
+++ b/security/clamtk/Makefile
@@ -0,0 +1,50 @@
+# New ports collection makefile for: clamtk
+# Date created: 24 February 2007
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= clamtk
+PORTVERSION= 3.00
+CATEGORIES= security
+MASTER_SITES= SF
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= GTK front-end for Clam Antivirus
+
+RUN_DEPENDS= p5-Gtk2>=1.144:${PORTSDIR}/x11-toolkits/p5-Gtk2 \
+ p5-File-Find-Rule>=0.30:${PORTSDIR}/devel/p5-File-Find-Rule \
+ p5-Date-Calc>=5.5.1:${PORTSDIR}/devel/p5-Date-Calc \
+ p5-gettext>=1.05:${PORTSDIR}/devel/p5-Locale-gettext \
+ clamscan:${PORTSDIR}/security/clamav
+
+NO_BUILD= yes
+USE_GETTEXT= yes
+MAN1= ${PORTNAME}.1
+PORTDOCS= CHANGES DISCLAIMER LICENSE README
+
+post-extract:
+ @${GUNZIP_CMD} ${WRKSRC}/${PORTNAME}.1.gz
+
+post-patch:
+ @${REINPLACE_CMD} -e '/command.*--un/d;/bin\/file/!s|/usr/bin|${LOCALBASE}/bin|g;\
+ s|/var/lib/clamav|/var/db/clamav|;s|/usr/share|${PREFIX}/share|g'\
+ ${WRKSRC}/${PORTNAME}
+
+do-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
+ @${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${MAN1PREFIX}/man/man1/
+ @${INSTALL} -d ${PREFIX}/share/applications/
+ @${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.desktop ${PREFIX}/share/applications/
+ @${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.png ${PREFIX}/share/pixmaps/
+ @cd ${WRKSRC}/po/&&for i in *.mo;do\
+ ${MKDIR} ${PREFIX}/share/locale/$${i%.mo};\
+ ${INSTALL_DATA} $$i ${PREFIX}/share/locale/$${i%.mo}/LC_MESSAGES/${PORTNAME}.mo;\
+ done
+.ifndef NOPORTDOCS
+ @${INSTALL} -d ${DOCSDIR}/
+ @cd ${WRKSRC}/&&${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}/
+.endif
+
+.include <bsd.port.mk>
diff --git a/security/clamtk/distinfo b/security/clamtk/distinfo
new file mode 100644
index 000000000000..3612276ad925
--- /dev/null
+++ b/security/clamtk/distinfo
@@ -0,0 +1,3 @@
+MD5 (clamtk-3.00.tar.gz) = d5dba14122a616d2eaca90925bf13f1a
+SHA256 (clamtk-3.00.tar.gz) = 0de1e5273d6f0fa867ba146aa588174e746cf280c6b2df15435e9a2ccb86c8cd
+SIZE (clamtk-3.00.tar.gz) = 91424
diff --git a/security/clamtk/pkg-descr b/security/clamtk/pkg-descr
new file mode 100644
index 000000000000..3fd4c401de1e
--- /dev/null
+++ b/security/clamtk/pkg-descr
@@ -0,0 +1,5 @@
+ClamTk is a GUI front-end for ClamAV using gtk2-perl. It is designed to
+be an easy-to-use frontend for Unix systems.
+
+WWW: http://clamtk.sourceforge.net/
+Author: Dave M <dave.nerd@gmail.com>
diff --git a/security/clamtk/pkg-plist b/security/clamtk/pkg-plist
new file mode 100644
index 000000000000..09afe1a61af6
--- /dev/null
+++ b/security/clamtk/pkg-plist
@@ -0,0 +1,17 @@
+bin/clamtk
+share/applications/clamtk.desktop
+share/locale/cs_CZ/LC_MESSAGES/clamtk.mo
+share/locale/da/LC_MESSAGES/clamtk.mo
+share/locale/de/LC_MESSAGES/clamtk.mo
+share/locale/es/LC_MESSAGES/clamtk.mo
+share/locale/fr/LC_MESSAGES/clamtk.mo
+share/locale/it/LC_MESSAGES/clamtk.mo
+share/locale/pl/LC_MESSAGES/clamtk.mo
+share/locale/pt_BR/LC_MESSAGES/clamtk.mo
+share/locale/ru/LC_MESSAGES/clamtk.mo
+share/locale/sv/LC_MESSAGES/clamtk.mo
+share/locale/zh_CN/LC_MESSAGES/clamtk.mo
+share/pixmaps/clamtk.png
+@dirrmtry share/applications
+@dirrmtry share/locale/cs_CZ/LC_MESSAGES
+@dirrmtry share/locale/cs_CZ