aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorWesley Shields <wxs@FreeBSD.org>2011-03-07 18:04:50 +0000
committerWesley Shields <wxs@FreeBSD.org>2011-03-07 18:04:50 +0000
commit47b8b364d9c57662931ade7f3643711ccb3aa9ef (patch)
tree54fd0090840fab815b427348e22911474d905c9f /security
parente0972dd3d0dabbc28aba83a42276dddb4c6af4fd (diff)
Notes
Diffstat (limited to 'security')
-rw-r--r--security/Makefile2
-rw-r--r--security/py-yara/Makefile28
-rw-r--r--security/py-yara/distinfo2
-rw-r--r--security/py-yara/files/patch-setup.py15
-rw-r--r--security/py-yara/pkg-descr9
-rw-r--r--security/yara/Makefile28
-rw-r--r--security/yara/distinfo2
-rw-r--r--security/yara/pkg-descr7
-rw-r--r--security/yara/pkg-plist6
9 files changed, 99 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 922d9e551021..bf14331b6f94 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -719,6 +719,7 @@
SUBDIR += py-twistedConch
SUBDIR += py-twofish
SUBDIR += py-xmlsec
+ SUBDIR += py-yara
SUBDIR += qca-cyrus-sasl
SUBDIR += qca-gnupg
SUBDIR += qca-ossl
@@ -903,6 +904,7 @@
SUBDIR += xyssl
SUBDIR += yafic
SUBDIR += yapet
+ SUBDIR += yara
SUBDIR += yassl
SUBDIR += yersinia
SUBDIR += zebedee
diff --git a/security/py-yara/Makefile b/security/py-yara/Makefile
new file mode 100644
index 000000000000..a4006227533d
--- /dev/null
+++ b/security/py-yara/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: py-yara
+# Date created: Mar 7 2011
+# Whom: wxs@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= yara
+PORTVERSION= 1.4a
+CATEGORIES= security
+MASTER_SITES= GOOGLE_CODE
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= yara-python-${PORTVERSION}
+
+MAINTAINER= wxs@FreeBSD.org
+COMMENT= Python bindings for yara
+
+LIB_DEPENDS= yara.0:${PORTSDIR}/security/yara
+
+PROJECTHOST= yara-project
+MAKE_JOBS_SAFE= yes
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+PYDISTUTILS_EGGINFO= yara_python-1.4a-py2.7.egg-info
+
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/yara.so
+
+.include <bsd.port.mk>
diff --git a/security/py-yara/distinfo b/security/py-yara/distinfo
new file mode 100644
index 000000000000..78da7a1b03ae
--- /dev/null
+++ b/security/py-yara/distinfo
@@ -0,0 +1,2 @@
+SHA256 (yara-python-1.4a.tar.gz) = 0221b6b5178edc99584fb0e082ebbc454e3e33701112f7041349e547a8aabc66
+SIZE (yara-python-1.4a.tar.gz) = 7504
diff --git a/security/py-yara/files/patch-setup.py b/security/py-yara/files/patch-setup.py
new file mode 100644
index 000000000000..2a9ed18afcc8
--- /dev/null
+++ b/security/py-yara/files/patch-setup.py
@@ -0,0 +1,15 @@
+--- ./setup.py.orig 2011-03-07 12:21:10.504810488 -0500
++++ ./setup.py 2011-03-07 12:21:30.973804718 -0500
+@@ -11,8 +11,9 @@
+ name='yara',
+ sources=['yara-python.c'],
+ libraries=['yara','pcre'],
+- include_dirs=['/usr/local/include']
++ include_dirs=['/usr/local/include'],
++ library_dirs=['/usr/local/lib']
+ )])
+
+
+-
+\ No newline at end of file
++
diff --git a/security/py-yara/pkg-descr b/security/py-yara/pkg-descr
new file mode 100644
index 000000000000..28eb3db86f9c
--- /dev/null
+++ b/security/py-yara/pkg-descr
@@ -0,0 +1,9 @@
+The python bindings for yara.
+
+"YARA is a tool aimed at helping malware researchers to identify and classify
+malware samples. With YARA you can create descriptions of malware families
+based on textual or binary patterns contained on samples of those families.
+Each description consists of a set of strings and a Boolean expression which
+determines its logic."
+
+WWW: http://code.google.com/p/yara-project/
diff --git a/security/yara/Makefile b/security/yara/Makefile
new file mode 100644
index 000000000000..9b842905a010
--- /dev/null
+++ b/security/yara/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: yara
+# Date created: Mar 7 2011
+# Whom: wxs@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= yara
+PORTVERSION= 1.4
+CATEGORIES= security
+MASTER_SITES= GOOGLE_CODE
+
+MAINTAINER= wxs@FreeBSD.org
+COMMENT= A malware identification and classification tool
+
+LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre
+
+PROJECTHOST= yara-project
+MAKE_JOBS_SAFE= yes
+GNU_CONFIGURE= yes
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ENV= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+USE_LDCONFIG= yes
+
+MAN1= yara.1
+
+.include <bsd.port.mk>
diff --git a/security/yara/distinfo b/security/yara/distinfo
new file mode 100644
index 000000000000..ab4f8c229fe6
--- /dev/null
+++ b/security/yara/distinfo
@@ -0,0 +1,2 @@
+SHA256 (yara-1.4.tar.gz) = c040cc139030e49f736200d3a951922d417fc660cf4c81484ff1ca1a06f83952
+SIZE (yara-1.4.tar.gz) = 462125
diff --git a/security/yara/pkg-descr b/security/yara/pkg-descr
new file mode 100644
index 000000000000..b6d24233b20a
--- /dev/null
+++ b/security/yara/pkg-descr
@@ -0,0 +1,7 @@
+"YARA is a tool aimed at helping malware researchers to identify and classify
+malware samples. With YARA you can create descriptions of malware families
+based on textual or binary patterns contained on samples of those families.
+Each description consists of a set of strings and a Boolean expression which
+determines its logic."
+
+WWW: http://code.google.com/p/yara-project/
diff --git a/security/yara/pkg-plist b/security/yara/pkg-plist
new file mode 100644
index 000000000000..26f068b6f237
--- /dev/null
+++ b/security/yara/pkg-plist
@@ -0,0 +1,6 @@
+bin/yara
+include/yara.h
+lib/libyara.a
+lib/libyara.la
+lib/libyara.so
+lib/libyara.so.0