aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2012-06-04 06:17:03 +0000
committerAndrej Zverev <az@FreeBSD.org>2012-06-04 06:17:03 +0000
commit5542fae1efc7914a62cbad9660568e6ff7f667e0 (patch)
tree197cf4926e3d2988f210f5bd5c683e60d0866e2f /security
parent905c5a61589ceb45f6b1cab39e9627bb52b556d9 (diff)
Notes
Diffstat (limited to 'security')
-rw-r--r--security/p5-Authen-Simple-DBM/Makefile4
-rw-r--r--security/p5-Authen-Simple-Net/Makefile4
-rw-r--r--security/p5-Authen-Simple-PAM/Makefile6
-rw-r--r--security/p5-Authen-Simple-RADIUS/Makefile6
-rw-r--r--security/p5-Authen-Simple-SMB/Makefile6
-rw-r--r--security/p5-Crypt-CipherSaber/Makefile4
-rw-r--r--security/p5-Crypt-Dining/Makefile6
-rw-r--r--security/p5-Filter-CBC/Makefile8
8 files changed, 22 insertions, 22 deletions
diff --git a/security/p5-Authen-Simple-DBM/Makefile b/security/p5-Authen-Simple-DBM/Makefile
index 76dee6872007..94d9af277d76 100644
--- a/security/p5-Authen-Simple-DBM/Makefile
+++ b/security/p5-Authen-Simple-DBM/Makefile
@@ -11,10 +11,10 @@ CATEGORIES= security perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= perl@FreeBSD.org
COMMENT= Simple DBM authentication
-BUILD_DEPENDS= ${SITE_PERL}/Authen/Simple.pm:${PORTSDIR}/security/p5-Authen-Simple
+BUILD_DEPENDS= p5-Authen-Simple>=0:${PORTSDIR}/security/p5-Authen-Simple
RUN_DEPENDS:= ${BUILD_DEPENDS}
MAN3= Authen::Simple::DBM.3
diff --git a/security/p5-Authen-Simple-Net/Makefile b/security/p5-Authen-Simple-Net/Makefile
index 2e01317c73cb..d63853dd8b7c 100644
--- a/security/p5-Authen-Simple-Net/Makefile
+++ b/security/p5-Authen-Simple-Net/Makefile
@@ -12,10 +12,10 @@ CATEGORIES= security perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= perl@FreeBSD.org
COMMENT= Simple authentication via FTP, POP3, or SMTP
-BUILD_DEPENDS= ${SITE_PERL}/Authen/Simple.pm:${PORTSDIR}/security/p5-Authen-Simple
+BUILD_DEPENDS= p5-Authen-Simple>=0:${PORTSDIR}/security/p5-Authen-Simple
RUN_DEPENDS:= ${BUILD_DEPENDS}
MAN3= Authen::Simple::FTP.3 Authen::Simple::POP3.3 Authen::Simple::SMTP.3
diff --git a/security/p5-Authen-Simple-PAM/Makefile b/security/p5-Authen-Simple-PAM/Makefile
index 59ce141b2917..42c6731442c6 100644
--- a/security/p5-Authen-Simple-PAM/Makefile
+++ b/security/p5-Authen-Simple-PAM/Makefile
@@ -11,11 +11,11 @@ CATEGORIES= security perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= perl@FreeBSD.org
COMMENT= Simple PAM authentication
-BUILD_DEPENDS= ${SITE_PERL}/Authen/Simple.pm:${PORTSDIR}/security/p5-Authen-Simple \
- ${SITE_PERL}/${PERL_ARCH}/Authen/PAM.pm:${PORTSDIR}/security/p5-Authen-PAM
+BUILD_DEPENDS= p5-Authen-Simple>=0:${PORTSDIR}/security/p5-Authen-Simple \
+ p5-Authen-PAM>=0:${PORTSDIR}/security/p5-Authen-PAM
RUN_DEPENDS:= ${BUILD_DEPENDS}
MAN3= Authen::Simple::PAM.3
diff --git a/security/p5-Authen-Simple-RADIUS/Makefile b/security/p5-Authen-Simple-RADIUS/Makefile
index 29074e56d831..28ff3e34d67c 100644
--- a/security/p5-Authen-Simple-RADIUS/Makefile
+++ b/security/p5-Authen-Simple-RADIUS/Makefile
@@ -11,11 +11,11 @@ CATEGORIES= security perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= perl@FreeBSD.org
COMMENT= Simple RADIUS authentication
-BUILD_DEPENDS= ${SITE_PERL}/Authen/Simple.pm:${PORTSDIR}/security/p5-Authen-Simple \
- ${SITE_PERL}/Authen/Radius.pm:${PORTSDIR}/security/p5-Authen-Radius
+BUILD_DEPENDS= p5-Authen-Simple>=0:${PORTSDIR}/security/p5-Authen-Simple \
+ p5-Authen-Radius>=0:${PORTSDIR}/security/p5-Authen-Radius
RUN_DEPENDS:= ${BUILD_DEPENDS}
MAN3= Authen::Simple::RADIUS.3
diff --git a/security/p5-Authen-Simple-SMB/Makefile b/security/p5-Authen-Simple-SMB/Makefile
index 3ca7381105d7..62f03e91f5c9 100644
--- a/security/p5-Authen-Simple-SMB/Makefile
+++ b/security/p5-Authen-Simple-SMB/Makefile
@@ -11,11 +11,11 @@ CATEGORIES= security perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= perl@FreeBSD.org
COMMENT= Simple SMB authentication
-BUILD_DEPENDS= ${SITE_PERL}/Authen/Simple.pm:${PORTSDIR}/security/p5-Authen-Simple \
- ${SITE_PERL}/${PERL_ARCH}/Authen/Smb.pm:${PORTSDIR}/security/p5-Authen-Smb
+BUILD_DEPENDS= p5-Authen-Simple>=0:${PORTSDIR}/security/p5-Authen-Simple \
+ p5-Authen-Smb>=0:${PORTSDIR}/security/p5-Authen-Smb
RUN_DEPENDS:= ${BUILD_DEPENDS}
MAN3= Authen::Simple::SMB.3
diff --git a/security/p5-Crypt-CipherSaber/Makefile b/security/p5-Crypt-CipherSaber/Makefile
index 879a7eb7d312..44e608debd55 100644
--- a/security/p5-Crypt-CipherSaber/Makefile
+++ b/security/p5-Crypt-CipherSaber/Makefile
@@ -11,10 +11,10 @@ CATEGORIES= security perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= perl@FreeBSD.org
COMMENT= Perl module providing an OO interface to CipherSaber encryption
-BUILD_DEPENDS= ${SITE_PERL}/Test/Warn.pm:${PORTSDIR}/devel/p5-Test-Warn
+BUILD_DEPENDS= p5-Test-Warn>=0:${PORTSDIR}/devel/p5-Test-Warn
PERL_CONFIGURE= yes
diff --git a/security/p5-Crypt-Dining/Makefile b/security/p5-Crypt-Dining/Makefile
index d3263e77b9f3..801fd367b9ea 100644
--- a/security/p5-Crypt-Dining/Makefile
+++ b/security/p5-Crypt-Dining/Makefile
@@ -11,11 +11,11 @@ CATEGORIES= security perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= perl@FreeBSD.org
COMMENT= The Dining Cryptographers' Protocol
-BUILD_DEPENDS= ${SITE_PERL}/Crypt/Random.pm:${PORTSDIR}/security/p5-Crypt-Random \
- ${SITE_PERL}/Net/Address/IPv4/Local.pm:${PORTSDIR}/net/p5-Net-Address-IPv4-Local
+BUILD_DEPENDS= p5-Crypt-Random>=0:${PORTSDIR}/security/p5-Crypt-Random \
+ p5-Net-Address-IPv4-Local>=0:${PORTSDIR}/net/p5-Net-Address-IPv4-Local
RUN_DEPENDS:= ${BUILD_DEPENDS}
MAN3= Crypt::Dining.3
diff --git a/security/p5-Filter-CBC/Makefile b/security/p5-Filter-CBC/Makefile
index aff0438711e2..032dc0de9a32 100644
--- a/security/p5-Filter-CBC/Makefile
+++ b/security/p5-Filter-CBC/Makefile
@@ -11,12 +11,12 @@ CATEGORIES= security perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= perl@FreeBSD.org
COMMENT= Source filter for Cipher Block Chaining
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Filter/Util/Call.pm:${PORTSDIR}/devel/p5-Filter \
- ${SITE_PERL}/${PERL_ARCH}/Crypt/Rijndael.pm:${PORTSDIR}/security/p5-Crypt-Rijndael \
- ${SITE_PERL}/Crypt/CBC.pm:${PORTSDIR}/security/p5-Crypt-CBC
+BUILD_DEPENDS= p5-Filter>=0:${PORTSDIR}/devel/p5-Filter \
+ p5-Crypt-Rijndael>=0:${PORTSDIR}/security/p5-Crypt-Rijndael \
+ p5-Crypt-CBC>=0:${PORTSDIR}/security/p5-Crypt-CBC
RUN_DEPENDS:= ${BUILD_DEPENDS}
PLIST_SUB= EXAMPLESDIR="share/examples/${PORTNAME}"