aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-12-28 08:44:09 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-12-28 08:44:09 +0000
commitcc503d8ccc5b3718cd3d75c91ad3a449111c9a08 (patch)
treec8ec92620262282ddb68b335bf9b655ffa4d486e /security
parent0d39c0b4db87ef5c1fe07a878a4dff72f549a75e (diff)
downloadports-cc503d8ccc5b3718cd3d75c91ad3a449111c9a08.tar.gz
ports-cc503d8ccc5b3718cd3d75c91ad3a449111c9a08.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/pear-Auth/Makefile44
-rw-r--r--security/pear-Auth/distinfo2
-rw-r--r--security/pear-Auth/pkg-descr2
-rw-r--r--security/pear-Auth/pkg-plist28
4 files changed, 26 insertions, 50 deletions
diff --git a/security/pear-Auth/Makefile b/security/pear-Auth/Makefile
index 89b5bd8a6134..157a9c3771a0 100644
--- a/security/pear-Auth/Makefile
+++ b/security/pear-Auth/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= Auth
-PORTVERSION= 1.2.2
+PORTVERSION= 1.2.3
CATEGORIES= security www pear
MAINTAINER= ports@FreeBSD.org
@@ -15,26 +15,30 @@ COMMENT= PEAR authentication methods
BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear-PEAR
RUN_DEPENDS= ${BUILD_DEPENDS}
-.include <bsd.port.pre.mk>
-.include "${.CURDIR}/../../devel/pear-PEAR/Makefile.common"
-
-MANIFEST= Auth.php Container Container.php
-TESTDIR= ${PEARDIR}/tests/${PORTNAME}
-
-do-install:
- @${MKDIR} ${PEARDIR}/Auth
-.for FILE in ${MANIFEST}
- @${CP} -Rp ${WRKSRC}/${FILE} ${PEARDIR}/Auth
-.endfor
- @${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${PEARDIR}/Auth
- @${CHMOD} -R a-x ${PEARDIR}/Auth/Container/*.php
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${TESTDIR}
- @${CP} -Rp ${WRKSRC}/tests/* ${TESTDIR}
- @${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${TESTDIR}
- @${ECHO_MSG} "===> Examples installed in ${TESTDIR}."
+CATEGORY= Auth
+FILES= Auth.php Container.php Container/DB.php Container/File.php \
+ Container/IMAP.php Container/LDAP.php Container/MDB.php \
+ Container/POP3.php Container/RADIUS.php Container/SMBPasswd.php \
+ Container/SOAP.php Container/vpopmail.php
+TESTS= DBContainer.php FileContainer.php POP3Container.php \
+ POP3aContainer.php TestAuthContainer.php \
+ auth_container_db_options.php auth_container_file_options.php \
+ auth_container_pop3_options.php auth_container_pop3a_options.php \
+ tests.php users
+
+do-install-tests-msg: .USE
@${ECHO_MSG} " (These tests require PHPUnit - see"
- @${ECHO_MSG} " <http://pear.php.net/package-info.php?package=PHPUnit>;)."
+ @${ECHO_MSG} " <http://pear.php.net/package/PHPUnit/>;)."
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
+
+.if exists(${PEARDIR}/DB.php)
+WITH_DB= yes
+.endif
+
+.if defined(WITH_DB)
+RUN_DEPENDS+= ${PEARDIR}/DB.php:${PORTSDIR}/databases/pear-DB
.endif
.include <bsd.port.post.mk>
diff --git a/security/pear-Auth/distinfo b/security/pear-Auth/distinfo
index 8a7b3593f988..0e8f3bdb130a 100644
--- a/security/pear-Auth/distinfo
+++ b/security/pear-Auth/distinfo
@@ -1 +1 @@
-MD5 (PEAR/Auth-1.2.2.tgz) = 6f8b343bf0ee9aef1bb063c9600898f8
+MD5 (PEAR/Auth-1.2.3.tgz) = 1506c2a27afe85e8d56eaa8466b6f13a
diff --git a/security/pear-Auth/pkg-descr b/security/pear-Auth/pkg-descr
index b8b178416090..9e68af144e00 100644
--- a/security/pear-Auth/pkg-descr
+++ b/security/pear-Auth/pkg-descr
@@ -15,4 +15,4 @@ the login data:
* SAMBA password files
* SOAP.
-WWW: http://pear.php.net/package-info.php?package=Auth
+WWW: http://pear.php.net/package/Auth/
diff --git a/security/pear-Auth/pkg-plist b/security/pear-Auth/pkg-plist
deleted file mode 100644
index ab42e6427ccd..000000000000
--- a/security/pear-Auth/pkg-plist
+++ /dev/null
@@ -1,28 +0,0 @@
-%%PEARDIR%%/Auth/Auth.php
-%%PEARDIR%%/Auth/Container.php
-%%PEARDIR%%/Auth/Container/DB.php
-%%PEARDIR%%/Auth/Container/File.php
-%%PEARDIR%%/Auth/Container/IMAP.php
-%%PEARDIR%%/Auth/Container/LDAP.php
-%%PEARDIR%%/Auth/Container/MDB.php
-%%PEARDIR%%/Auth/Container/POP3.php
-%%PEARDIR%%/Auth/Container/RADIUS.php
-%%PEARDIR%%/Auth/Container/SMBPasswd.php
-%%PEARDIR%%/Auth/Container/SOAP.php
-%%PEARDIR%%/Auth/Container/vpopmail.php
-%%PKGREGDIR%%/package.xml
-%%PORTDOCS%%%%PEARDIR%%/tests/Auth/DBContainer.php
-%%PORTDOCS%%%%PEARDIR%%/tests/Auth/FileContainer.php
-%%PORTDOCS%%%%PEARDIR%%/tests/Auth/POP3Container.php
-%%PORTDOCS%%%%PEARDIR%%/tests/Auth/POP3aContainer.php
-%%PORTDOCS%%%%PEARDIR%%/tests/Auth/TestAuthContainer.php
-%%PORTDOCS%%%%PEARDIR%%/tests/Auth/auth_container_db_options.php
-%%PORTDOCS%%%%PEARDIR%%/tests/Auth/auth_container_file_options.php
-%%PORTDOCS%%%%PEARDIR%%/tests/Auth/auth_container_pop3_options.php
-%%PORTDOCS%%%%PEARDIR%%/tests/Auth/auth_container_pop3a_options.php
-%%PORTDOCS%%%%PEARDIR%%/tests/Auth/tests.php
-%%PORTDOCS%%%%PEARDIR%%/tests/Auth/users
-@dirrm %%PEARDIR%%/Auth/Container
-@unexec rmdir %D/%%PEARDIR%%/Auth 2>/dev/null || true
-@dirrm %%PKGREGDIR%%
-%%PORTDOCS%%@dirrm %%PEARDIR%%/tests/Auth