aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-11-02 22:45:14 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-11-02 22:45:14 +0000
commitd26ef18700dca59c35dc940097bf7b3db1369965 (patch)
treeadf234bd1f2e56ae130e9960e1467b64c9fa0ed6 /security
parent23211342637a054575d9dc1935d00c038cb6545f (diff)
Cleanup no longer needed CHMOD usage after r424898.
PR: 213743 Submitted by: mat Exp-run by: antoine Sponsored by: Absolight
Notes
Notes: svn path=/head/; revision=425174
Diffstat (limited to 'security')
-rw-r--r--security/apg/Makefile4
-rw-r--r--security/bugs/Makefile2
-rw-r--r--security/py-oauthlib/Makefile3
-rw-r--r--security/py-pyaff4/Makefile3
-rw-r--r--security/py-rekall-core/Makefile3
-rw-r--r--security/py-rekall/Makefile3
-rw-r--r--security/py-rekall_gui/Makefile3
-rw-r--r--security/secure_delete/Makefile3
8 files changed, 0 insertions, 24 deletions
diff --git a/security/apg/Makefile b/security/apg/Makefile
index 775c66b494eb..010ff6cae58f 100644
--- a/security/apg/Makefile
+++ b/security/apg/Makefile
@@ -20,10 +20,6 @@ CRACKLIB_DESC= CrackLib support for password quality
CRACKLIB_LIB_DEPENDS= libcrack.so:security/cracklib
CRACKLIB_MAKE_ARGS= -DWITH_CRACKLIB
-post-extract:
- @${FIND} ${WRKSRC} -type d | ${XARGS} ${CHMOD} u+wx
- @${FIND} ${WRKSRC} -type f | ${XARGS} ${CHMOD} u+w
-
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/apg ${STAGEDIR}${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/apgbfm ${STAGEDIR}${PREFIX}/bin
diff --git a/security/bugs/Makefile b/security/bugs/Makefile
index c30035307636..fee76b59e6f9 100644
--- a/security/bugs/Makefile
+++ b/security/bugs/Makefile
@@ -25,8 +25,6 @@ DOCSDIR= ${PREFIX}/${DISTNAME}/doc
OPTIONS_DEFINE= DOCS
post-patch:
-# Sanitize permissions so "make clean" can work
- @${CHMOD} +x ${WRKSRC}/lib/unix ${WRKSRC}/lib/windows
# Allow parallel builds (-jX): fix make(1) syntax, register dependencies
@${REINPLACE_CMD} -E 's+cd (.*); make+$$(MAKE) -C \1+' \
${WRKSRC}/Makefile.bsd
diff --git a/security/py-oauthlib/Makefile b/security/py-oauthlib/Makefile
index 36d6413784b1..523dc6e5ab5b 100644
--- a/security/py-oauthlib/Makefile
+++ b/security/py-oauthlib/Makefile
@@ -42,9 +42,6 @@ TEST_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}unittest2>0:devel/py-unittest2 \
${PYTHON_PKGNAMEPREFIX}mock>0:devel/py-mock
.endif
-post-extract:
- @${CHMOD} -R a+rX ${WRKSRC}
-
do-test:
@cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
diff --git a/security/py-pyaff4/Makefile b/security/py-pyaff4/Makefile
index a5421dea424b..adaa6e50b1fb 100644
--- a/security/py-pyaff4/Makefile
+++ b/security/py-pyaff4/Makefile
@@ -20,9 +20,6 @@ NO_ARCH= yes
USES= python zip
USE_PYTHON= distutils autoplist
-post-extract:
- @${CHMOD} -R a+rX ${WRKSRC}
-
post-patch:
${REINPLACE_CMD} 's/aff4-snappy == 0.5/python-snappy >= 0.5/' ${WRKSRC}/setup.py
diff --git a/security/py-rekall-core/Makefile b/security/py-rekall-core/Makefile
index 405e556c327e..7d8dd0e968d8 100644
--- a/security/py-rekall-core/Makefile
+++ b/security/py-rekall-core/Makefile
@@ -32,7 +32,4 @@ NO_ARCH= yes
USES= python:2.7 zip
USE_PYTHON= distutils autoplist
-post-extract:
- @${CHMOD} -R a+rX ${WRKSRC}
-
.include <bsd.port.mk>
diff --git a/security/py-rekall/Makefile b/security/py-rekall/Makefile
index 84ca2db52927..d3ddaf4fa3a7 100644
--- a/security/py-rekall/Makefile
+++ b/security/py-rekall/Makefile
@@ -20,9 +20,6 @@ NO_ARCH= yes
USES= python:2.7 zip
USE_PYTHON= distutils autoplist
-post-extract:
- @${CHMOD} -R a+rX ${WRKSRC}
-
post-patch:
@${REINPLACE_CMD} 's|ipython >= 4.1.2, < 5.0|ipython|' ${WRKSRC}/setup.py
diff --git a/security/py-rekall_gui/Makefile b/security/py-rekall_gui/Makefile
index 09de6e2f705a..0d023d2c17b0 100644
--- a/security/py-rekall_gui/Makefile
+++ b/security/py-rekall_gui/Makefile
@@ -27,7 +27,4 @@ USE_PYTHON= distutils autoplist
PYDISTUTILS_INSTALLARGS+=--install-data ${PYTHONPREFIX_SITELIBDIR}
-post-extract:
- @${CHMOD} -R a+rX ${WRKSRC}
-
.include <bsd.port.post.mk>
diff --git a/security/secure_delete/Makefile b/security/secure_delete/Makefile
index c23da4e99f02..ea98d3749896 100644
--- a/security/secure_delete/Makefile
+++ b/security/secure_delete/Makefile
@@ -26,9 +26,6 @@ PLIST_FILES= bin/sdel bin/sfill bin/smem bin/srm bin/sswap \
OPTIONS_DEFINE= DOCS
-post-extract:
- @${CHMOD} u+w ${WRKSRC}
-
post-patch:
@${REINPLACE_CMD} -e \
's|^CC=|CC?=| ; \