aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-07-14 13:24:04 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-07-14 13:24:04 +0000
commit64b73b6642ec5ccdfffcb138be54faf8a581be11 (patch)
tree2fd33964599cf05f651a49b1a038f9c2961adff6 /security
parentcc323eeba5401e651956ed06435b77bbf392790a (diff)
downloadports-64b73b6642ec5ccdfffcb138be54faf8a581be11.tar.gz
ports-64b73b6642ec5ccdfffcb138be54faf8a581be11.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/newpki-client/Makefile56
-rw-r--r--security/newpki-client/distinfo2
-rw-r--r--security/newpki-client/files/patch-configure62
-rw-r--r--security/newpki-client/pkg-descr5
5 files changed, 126 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 132ea1a46479..dbd118166420 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -227,6 +227,7 @@
SUBDIR += nessus-plugins
SUBDIR += nessus-plugins-devel
SUBDIR += nettle
+ SUBDIR += newpki-client
SUBDIR += newpki-lib
SUBDIR += nikto
SUBDIR += nmap
diff --git a/security/newpki-client/Makefile b/security/newpki-client/Makefile
new file mode 100644
index 000000000000..8c37e3dd9ca7
--- /dev/null
+++ b/security/newpki-client/Makefile
@@ -0,0 +1,56 @@
+# New ports collection makefile for: newpki-client
+# Date created: 2005-07-05
+# Whom: Vsevolod Stakhov <vsevolod@highsecure.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= newpki-client
+DISTVERSION= 2.0.0-beta4
+CATEGORIES= security
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= newpki
+
+MAINTAINER= vsevolod@highsecure.ru
+COMMENT= C++ PKI client from newpki project
+
+LIB_DEPENDS= newpki.2:${PORTSDIR}/security/newpki-lib \
+ xml2:${PORTSDIR}/textproc/libxml2 \
+ wx_gtk2-2.4.0:${PORTSDIR}/x11-toolkits/wxgtk24
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-2.0.0
+
+USE_LIBTOOL_VER= 15
+USE_OPENSSL= yes
+WX_CONFIG= ${X11BASE}/bin/wxgtk2-2.4-config
+USE_GNOME= gnometarget
+USE_GMAKE= yes
+USE_REINPLACE= yes
+
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${PREFIX}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -L${PREFIX}/lib" \
+ WXCONFIG=${WX_CONFIG}
+CONFIGURE_ARGS+= --with-newpki-include=${PREFIX}/include/newpki \
+ --with-newpki-lib=${PREFIX}/lib \
+ --with-libxml2-include=${PREFIX}/include/libxml2
+
+PLIST_FILES= bin/newpki-client
+
+.if defined(WITHOUT_NLS)
+CONFIGURE_ARGS+= --disable-nls
+.else
+USE_GETTEXT= yes
+PLIST_FILES+= share/locale/fr/LC_MESSAGES/newpki-client.mo
+CONFIGURE_ARGS+= --with-libintl-prefix=${LOCALBASE}
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= "does not compile (C++ libraries compiled with conflicting gcc versions)"
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
+
+.include <bsd.port.post.mk>
diff --git a/security/newpki-client/distinfo b/security/newpki-client/distinfo
new file mode 100644
index 000000000000..6684e187c3f8
--- /dev/null
+++ b/security/newpki-client/distinfo
@@ -0,0 +1,2 @@
+MD5 (newpki-client-2.0.0-beta4.tar.gz) = 6455dda0e568a8ee56bb4069f7b8c011
+SIZE (newpki-client-2.0.0-beta4.tar.gz) = 632666
diff --git a/security/newpki-client/files/patch-configure b/security/newpki-client/files/patch-configure
new file mode 100644
index 000000000000..ecf255bfc8ee
--- /dev/null
+++ b/security/newpki-client/files/patch-configure
@@ -0,0 +1,62 @@
+--- configure.in Wed Jul 6 18:52:02 2005
++++ configure Wed Jul 6 18:53:03 2005
+@@ -10798,48 +10798,6 @@
+ fi
+
+
+-# Extract the first word of "wx-config", so it can be a program name with args.
+-set dummy wx-config; ac_word=$2
+-echo "$as_me:$LINENO: checking for $ac_word" >&5
+-echo $ECHO_N "checking for $ac_word... $ECHO_C" >&6
+-if test "${ac_cv_prog_WXCONFIG+set}" = set; then
+- echo $ECHO_N "(cached) $ECHO_C" >&6
+-else
+- if test -n "$WXCONFIG"; then
+- ac_cv_prog_WXCONFIG="$WXCONFIG" # Let the user override the test.
+-else
+-as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
+-for as_dir in $PATH
+-do
+- IFS=$as_save_IFS
+- test -z "$as_dir" && as_dir=.
+- for ac_exec_ext in '' $ac_executable_extensions; do
+- if $as_executable_p "$as_dir/$ac_word$ac_exec_ext"; then
+- ac_cv_prog_WXCONFIG=""yes""
+- echo "$as_me:$LINENO: found $as_dir/$ac_word$ac_exec_ext" >&5
+- break 2
+- fi
+-done
+-done
+-
+- test -z "$ac_cv_prog_WXCONFIG" && ac_cv_prog_WXCONFIG=""no""
+-fi
+-fi
+-WXCONFIG=$ac_cv_prog_WXCONFIG
+-if test -n "$WXCONFIG"; then
+- echo "$as_me:$LINENO: result: $WXCONFIG" >&5
+-echo "${ECHO_T}$WXCONFIG" >&6
+-else
+- echo "$as_me:$LINENO: result: no" >&5
+-echo "${ECHO_T}no" >&6
+-fi
+-
+-if test x"$WXCONFIG" != x"yes"; then
+- { { echo "$as_me:$LINENO: error: wx-config not found" >&5
+-echo "$as_me: error: wx-config not found" >&2;}
+- { (exit 1); exit 1; }; }
+-fi
+-
+ ac_ext=c
+ ac_cpp='$CPP $CPPFLAGS'
+ ac_compile='$CC -c $CFLAGS $CPPFLAGS conftest.$ac_ext >&5'
+@@ -10848,8 +10806,8 @@
+
+
+
+-WXCXX=`wx-config --cxxflags`
+-WXLIB=`wx-config --libs`
++WXCXX=`${WXCONFIG} --cxxflags`
++WXLIB=`${WXCONFIG} --libs`
+
+ CPPFLAGS="$WXCXX -DWXINTL_NO_GETTEXT_MACRO $CPPFLAGS"
+ LIBS="$WXLIB -lnewpki $LIBS"
diff --git a/security/newpki-client/pkg-descr b/security/newpki-client/pkg-descr
new file mode 100644
index 000000000000..661a33ae12a0
--- /dev/null
+++ b/security/newpki-client/pkg-descr
@@ -0,0 +1,5 @@
+NewPKI is a PKI based on the OpenSSL low-level API, all the datas are handled
+through a database, which provides a much more flexible PKI than with OpenSSL,
+such as seeking a certificate with a search engine.
+
+WWW: http://www.newpki.org