aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2009-04-24 06:38:26 +0000
committerKoop Mast <kwm@FreeBSD.org>2009-04-24 06:38:26 +0000
commit84cba0b9274ca2833e503ce816439bff738d2dbe (patch)
tree3596d301f3fa56467f67e1819587bba202ec692b /security
parenta16e9e5558ade712858b784dbc230f46acaefecb (diff)
downloadports-84cba0b9274ca2833e503ce816439bff738d2dbe.tar.gz
ports-84cba0b9274ca2833e503ce816439bff738d2dbe.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/gnome-keyring/Makefile3
-rw-r--r--security/gnome-keyring/files/patch-pam_gkr-pam-client.c18
-rw-r--r--security/seahorse-plugins/Makefile4
-rw-r--r--security/seahorse-plugins/distinfo6
-rw-r--r--security/seahorse/Makefile3
-rw-r--r--security/seahorse/files/patch-common_seahorse-registry.c44
-rw-r--r--security/seahorse/files/patch-common_seahorse-registry.h21
-rw-r--r--security/seahorse/files/patch-ssh_seahorse-ssh-operation.c14
8 files changed, 34 insertions, 79 deletions
diff --git a/security/gnome-keyring/Makefile b/security/gnome-keyring/Makefile
index 660c4e7a5449..897f8bd23aa8 100644
--- a/security/gnome-keyring/Makefile
+++ b/security/gnome-keyring/Makefile
@@ -3,11 +3,12 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/security/gnome-keyring/Makefile,v 1.76 2009/03/15 00:23:43 marcus Exp $
+# $MCom: ports-stable/security/gnome-keyring/Makefile,v 1.3 2009/04/20 00:24:30 marcus Exp $
#
PORTNAME= gnome-keyring
PORTVERSION= 2.26.1
+PORTREVISION= 1
CATEGORIES= security gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
diff --git a/security/gnome-keyring/files/patch-pam_gkr-pam-client.c b/security/gnome-keyring/files/patch-pam_gkr-pam-client.c
new file mode 100644
index 000000000000..05a0306e6913
--- /dev/null
+++ b/security/gnome-keyring/files/patch-pam_gkr-pam-client.c
@@ -0,0 +1,18 @@
+--- pam/gkr-pam-client.c.orig 2008-10-07 12:25:23.000000000 -0400
++++ pam/gkr-pam-client.c 2008-10-07 12:38:36.000000000 -0400
+@@ -96,12 +96,12 @@ check_peer_same_uid (int sock)
+ struct xucred xuc;
+ socklen_t xuc_len = sizeof (xuc);
+
+- if (getsockopt (sock, SOL_SOCKET, LOCAL_PEERCRED, &xuc, &xuc_len) == 0 &&
+- xuc_len == sizeof (xuc)) {
++ if (getsockopt (sock, 0, LOCAL_PEERCRED, &xuc, &xuc_len) == 0 &&
++ xuc.cr_version == XUCRED_VERSION) {
+ uid = xuc.cr_uid;
+ } else {
+ syslog (GKR_LOG_ERR, "could not get gnome-keyring-daemon socket credentials, "
+- "(returned len %d/%d)\n", xuc_len, (int)sizeof (xuc));
++ "(returned version %d/%d)\n", xuc.cr_version, XUCRED_VERSION);
+ return -1;
+ }
+
diff --git a/security/seahorse-plugins/Makefile b/security/seahorse-plugins/Makefile
index 478708eb1900..8dd70e2b6d7d 100644
--- a/security/seahorse-plugins/Makefile
+++ b/security/seahorse-plugins/Makefile
@@ -3,11 +3,11 @@
# Whom: Dave McKay <dave@mu.org>
#
# $FreeBSD$
-# $MCom: ports/security/seahorse-plugins/Makefile,v 1.10 2009/03/30 05:54:57 marcus Exp $
+# $MCom: ports-stable/security/seahorse-plugins/Makefile,v 1.1 2009/04/15 10:36:03 kwm Exp $
#
PORTNAME= seahorse-plugins
-PORTVERSION= 2.26.0
+PORTVERSION= 2.26.1
CATEGORIES= security gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
diff --git a/security/seahorse-plugins/distinfo b/security/seahorse-plugins/distinfo
index 7897b7b5507a..8e2883c653f3 100644
--- a/security/seahorse-plugins/distinfo
+++ b/security/seahorse-plugins/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/seahorse-plugins-2.26.0.tar.bz2) = 8936feb29cf9e4b935d1059ee4e416c6
-SHA256 (gnome2/seahorse-plugins-2.26.0.tar.bz2) = b56c3c947204dac0802332332feea6eee282616a654b92d3135340cb842bf377
-SIZE (gnome2/seahorse-plugins-2.26.0.tar.bz2) = 1350051
+MD5 (gnome2/seahorse-plugins-2.26.1.tar.bz2) = d0aecc4e8e008b45362adf8a8716f38c
+SHA256 (gnome2/seahorse-plugins-2.26.1.tar.bz2) = 898acf0009beff402875378483460436d64104c11235ed3a3c3ff43b5229b752
+SIZE (gnome2/seahorse-plugins-2.26.1.tar.bz2) = 1311443
diff --git a/security/seahorse/Makefile b/security/seahorse/Makefile
index 99729e102ce8..06fd9ffa046d 100644
--- a/security/seahorse/Makefile
+++ b/security/seahorse/Makefile
@@ -3,11 +3,12 @@
# Whom: Dave McKay <dave@mu.org>
#
# $FreeBSD$
-# $MCom: ports/security/seahorse/Makefile,v 1.79 2009/03/15 01:01:47 marcus Exp $
+# $MCom: ports-stable/security/seahorse/Makefile,v 1.5 2009/04/20 00:55:09 marcus Exp $
#
PORTNAME= seahorse
PORTVERSION= 2.26.1
+PORTREVISION= 1
CATEGORIES= security gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
diff --git a/security/seahorse/files/patch-common_seahorse-registry.c b/security/seahorse/files/patch-common_seahorse-registry.c
deleted file mode 100644
index d3ab78c0de42..000000000000
--- a/security/seahorse/files/patch-common_seahorse-registry.c
+++ /dev/null
@@ -1,44 +0,0 @@
---- common/seahorse-registry.c.orig 2009-02-14 19:20:38.000000000 +0100
-+++ common/seahorse-registry.c 2009-02-24 21:15:26.000000000 +0100
-@@ -51,6 +51,25 @@
- registry_singleton = NULL;
- }
-
-+static guint registry_hash (gconstpointer key)
-+{
-+ SeahorseRegistryType *rtype;
-+
-+ rtype = (SeahorseRegistryType *) key;
-+
-+ return (guint) rtype->type;
-+}
-+
-+static gboolean registry_equal (gconstpointer a, gconstpointer b)
-+{
-+ SeahorseRegistryType *rta, *rtb;
-+
-+ rta = (SeahorseRegistryType *) a;
-+ rtb = (SeahorseRegistryType *) b;
-+
-+ return (rta->type == rtb->type);
-+}
-+
- static void
- keys_to_list (gpointer key, gpointer value, gpointer user_data)
- {
-@@ -63,13 +82,14 @@
- gpointer value, GDestroyNotify destroy_func)
- {
- GHashTable *set;
-+ SeahorseRegistryType *rtype;
-
- g_return_if_fail (table);
- g_return_if_fail (category);
-
- set = g_hash_table_lookup (table, GUINT_TO_POINTER (category));
- if (!set) {
-- set = g_hash_table_new_full (g_direct_hash, g_direct_equal, destroy_func, NULL);
-+ set = g_hash_table_new_full (registry_hash, registry_equal, destroy_func, NULL);
- g_hash_table_replace (table, GUINT_TO_POINTER (category), set);
- }
-
diff --git a/security/seahorse/files/patch-common_seahorse-registry.h b/security/seahorse/files/patch-common_seahorse-registry.h
deleted file mode 100644
index f1f57de3b042..000000000000
--- a/security/seahorse/files/patch-common_seahorse-registry.h
+++ /dev/null
@@ -1,21 +0,0 @@
---- common/seahorse-registry.h.orig 2008-11-23 18:26:42.000000000 -0500
-+++ common/seahorse-registry.h 2008-11-23 18:26:47.000000000 -0500
-@@ -35,6 +35,7 @@ G_BEGIN_DECLS
-
- typedef struct _SeahorseRegistry SeahorseRegistry;
- typedef struct _SeahorseRegistryClass SeahorseRegistryClass;
-+typedef struct _SeahorseRegistryType SeahorseRegistryType;
-
- struct _SeahorseRegistry {
- GObject parent;
-@@ -44,6 +45,10 @@ struct _SeahorseRegistryClass {
- GObjectClass parent_class;
- };
-
-+struct _SeahorseRegistryType {
-+ GType type;
-+};
-+
- /* member functions */
- GType seahorse_registry_get_type (void) G_GNUC_CONST;
-
diff --git a/security/seahorse/files/patch-ssh_seahorse-ssh-operation.c b/security/seahorse/files/patch-ssh_seahorse-ssh-operation.c
index d3528e2a7a64..1c7acece0685 100644
--- a/security/seahorse/files/patch-ssh_seahorse-ssh-operation.c
+++ b/security/seahorse/files/patch-ssh_seahorse-ssh-operation.c
@@ -1,19 +1,19 @@
---- ssh/seahorse-ssh-operation.c.orig 2008-07-21 18:15:51.000000000 -0400
-+++ ssh/seahorse-ssh-operation.c 2008-07-22 22:49:51.000000000 -0400
-@@ -280,11 +280,14 @@ askpass_handler (GIOChannel *source, GIO
+--- ssh/seahorse-ssh-operation.c.orig 2009-04-12 10:29:33.000000000 -0400
++++ ssh/seahorse-ssh-operation.c 2009-04-19 20:44:50.000000000 -0400
+@@ -281,11 +281,14 @@ askpass_handler (GIOChannel *source, GIO
const gchar *result = NULL;
if (condition & G_IO_IN) {
-+ GIOStatus status;
++ GIOStatus status;
/* Read 1 line from the io channel, including newline character */
- g_io_channel_read_line (source, &string, &length, NULL, &err);
+ status = g_io_channel_read_line (source, &string, &length, NULL, &err);
- if (err != NULL) {
-+ if (status == G_IO_STATUS_EOF) {
-+ ret = FALSE;
-+ } else if (err != NULL) {
++ if (status == G_IO_STATUS_EOF) {
++ ret = FALSE;
++ } else if (err != NULL) {
g_critical ("couldn't read from seahorse-ssh-askpass: %s", err->message);
g_clear_error (&err);
ret = FALSE;