aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorGabor Kovesdan <gabor@FreeBSD.org>2008-09-22 09:30:48 +0000
committerGabor Kovesdan <gabor@FreeBSD.org>2008-09-22 09:30:48 +0000
commit856c5bf9f133ae5d553d972d5a940586d3f56048 (patch)
tree84bdb77ffaaa93558fedaca5a8bed0aca22b8ad6 /security
parent73f3a0d1a6927e4be45c04dd45f4f872eee32fe5 (diff)
downloadports-856c5bf9f133ae5d553d972d5a940586d3f56048.tar.gz
ports-856c5bf9f133ae5d553d972d5a940586d3f56048.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/amavisd-new/Makefile1
-rw-r--r--security/amavisd-new/files/amavisd.sh.in2
-rw-r--r--security/amavisd-new/files/patch-amavisd22
3 files changed, 24 insertions, 1 deletions
diff --git a/security/amavisd-new/Makefile b/security/amavisd-new/Makefile
index 1f52ae72f160..06fdd3739f19 100644
--- a/security/amavisd-new/Makefile
+++ b/security/amavisd-new/Makefile
@@ -8,6 +8,7 @@
PORTNAME= amavisd-new
PORTVERSION= 2.6.1
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= security
MASTER_SITES= http://www.ijs.si/software/amavisd/ \
diff --git a/security/amavisd-new/files/amavisd.sh.in b/security/amavisd-new/files/amavisd.sh.in
index 3b920269966b..3a34ef3d40f6 100644
--- a/security/amavisd-new/files/amavisd.sh.in
+++ b/security/amavisd-new/files/amavisd.sh.in
@@ -33,7 +33,7 @@ rm -rf %%AMAVISDIR%%/tmp/* %%AMAVISDIR%%/tmp/.* 2>/dev/null || true
if [ ${amavisd_ram} ];then
df %%AMAVISDIR%%/tmp | grep '^/dev/md' > /dev/null
if [ $? -eq 1 ];then
- mdmfs -M -s ${amavisd_ram} -w %%AMAVISUSER%%:%%AMAVISGROUP%% md %%AMAVISDIR%%/tmp || true
+ mdmfs -M -s ${amavisd_ram} -p 750 -w %%AMAVISUSER%%:%%AMAVISGROUP%% md %%AMAVISDIR%%/tmp || true
fi
fi
}
diff --git a/security/amavisd-new/files/patch-amavisd b/security/amavisd-new/files/patch-amavisd
new file mode 100644
index 000000000000..ebfb0f575764
--- /dev/null
+++ b/security/amavisd-new/files/patch-amavisd
@@ -0,0 +1,22 @@
+--- amavisd.orig 2008-09-22 11:21:15.000000000 +0200
++++ amavisd 2008-09-22 11:23:53.000000000 +0200
+@@ -16878,13 +16878,18 @@
+ $data_command_accepted = $smtp_resp=~/^3/ ? 1 : 0;
+ if (!$data_command_accepted) {
+ do_log(0,"Negative SMTP resp. to DATA: %s", $smtp_resp);
++ $in_datasend_mode = 0;
++ $smtp_session->timeout($smtp_rset_timeout);
++ $what_cmd = 'RSET'; $smtp_handle->rset; # send a RSET
+ } elsif (!$any_valid_recips) { # pipelining
+ do_log(2,"Too late, DATA accepted but no valid recips, send dummy");
+ $which_section = 'fwd-data-contents';
+ $smtp_session->timeout(
+- max(60,min($smtp_data_xfer_timeout,$deadline-time)));
++ max(60,min($smtp_data_done_timeout,$deadline-time)));
++ $what_cmd = 'data-dot';
+ $smtp_handle->dataend; # as required by rfc2920: if the DATA command
+ # was accepted the SMTP client should send a single dot
++ $in_datasend_mode = 0;
+ } elsif ($any_tempfail_recips && !$dsn_per_recip_capable) { # pipelining
+ # we must not proceed if mail did not came in as LMTP,
+ # or we would generate mail duplicates on each delivery attempt