aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2004-09-01 15:01:20 +0000
committerCy Schubert <cy@FreeBSD.org>2004-09-01 15:01:20 +0000
commite832541095ccd06493edaa919f1035f7ba30e6ea (patch)
tree3fc20ae9ba8639e2990bb8956dff88e68688b498 /security
parent3f9458d6ba6e6e4ea39ef091b6eb9251dc7c5445 (diff)
downloadports-e832541095ccd06493edaa919f1035f7ba30e6ea.tar.gz
ports-e832541095ccd06493edaa919f1035f7ba30e6ea.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/krb5-16/Makefile1
-rw-r--r--security/krb5-16/files/patch-lib::krb5::asn.1::asn1buf.c13
-rw-r--r--security/krb5-17/Makefile1
-rw-r--r--security/krb5-17/files/patch-lib::krb5::asn.1::asn1buf.c13
-rw-r--r--security/krb5-appl/Makefile1
-rw-r--r--security/krb5-appl/files/patch-lib::krb5::asn.1::asn1buf.c13
-rw-r--r--security/krb5/Makefile1
-rw-r--r--security/krb5/files/patch-lib::krb5::asn.1::asn1buf.c13
8 files changed, 56 insertions, 0 deletions
diff --git a/security/krb5-16/Makefile b/security/krb5-16/Makefile
index 9c3dd3045662..0e590c1b344a 100644
--- a/security/krb5-16/Makefile
+++ b/security/krb5-16/Makefile
@@ -7,6 +7,7 @@
PORTNAME= krb5
PORTVERSION= 1.3.4
+PORTREVISION= 1
CATEGORIES= security
# USE_TARBALL tells the port that the user has fetched the source
# directly from MIT or crypto-publish.org (CRYTPO-PUBLISH).
diff --git a/security/krb5-16/files/patch-lib::krb5::asn.1::asn1buf.c b/security/krb5-16/files/patch-lib::krb5::asn.1::asn1buf.c
new file mode 100644
index 000000000000..6d3da983adc3
--- /dev/null
+++ b/security/krb5-16/files/patch-lib::krb5::asn.1::asn1buf.c
@@ -0,0 +1,13 @@
+*** lib/krb5/asn.1/asn1buf.c 12 Mar 2003 04:33:30 -0000 5.24
+--- lib/krb5/asn.1/asn1buf.c 23 Aug 2004 03:43:47 -0000
+***************
+*** 122,127 ****
+--- 122,129 ----
+ return ASN1_OVERRUN;
+ }
+ while (nestlevel > 0) {
++ if (buf->bound - buf->next + 1 <= 0)
++ return ASN1_OVERRUN;
+ retval = asn1_get_tag_2(buf, &t);
+ if (retval) return retval;
+ if (!t.indef) {
diff --git a/security/krb5-17/Makefile b/security/krb5-17/Makefile
index 9c3dd3045662..0e590c1b344a 100644
--- a/security/krb5-17/Makefile
+++ b/security/krb5-17/Makefile
@@ -7,6 +7,7 @@
PORTNAME= krb5
PORTVERSION= 1.3.4
+PORTREVISION= 1
CATEGORIES= security
# USE_TARBALL tells the port that the user has fetched the source
# directly from MIT or crypto-publish.org (CRYTPO-PUBLISH).
diff --git a/security/krb5-17/files/patch-lib::krb5::asn.1::asn1buf.c b/security/krb5-17/files/patch-lib::krb5::asn.1::asn1buf.c
new file mode 100644
index 000000000000..6d3da983adc3
--- /dev/null
+++ b/security/krb5-17/files/patch-lib::krb5::asn.1::asn1buf.c
@@ -0,0 +1,13 @@
+*** lib/krb5/asn.1/asn1buf.c 12 Mar 2003 04:33:30 -0000 5.24
+--- lib/krb5/asn.1/asn1buf.c 23 Aug 2004 03:43:47 -0000
+***************
+*** 122,127 ****
+--- 122,129 ----
+ return ASN1_OVERRUN;
+ }
+ while (nestlevel > 0) {
++ if (buf->bound - buf->next + 1 <= 0)
++ return ASN1_OVERRUN;
+ retval = asn1_get_tag_2(buf, &t);
+ if (retval) return retval;
+ if (!t.indef) {
diff --git a/security/krb5-appl/Makefile b/security/krb5-appl/Makefile
index 9c3dd3045662..0e590c1b344a 100644
--- a/security/krb5-appl/Makefile
+++ b/security/krb5-appl/Makefile
@@ -7,6 +7,7 @@
PORTNAME= krb5
PORTVERSION= 1.3.4
+PORTREVISION= 1
CATEGORIES= security
# USE_TARBALL tells the port that the user has fetched the source
# directly from MIT or crypto-publish.org (CRYTPO-PUBLISH).
diff --git a/security/krb5-appl/files/patch-lib::krb5::asn.1::asn1buf.c b/security/krb5-appl/files/patch-lib::krb5::asn.1::asn1buf.c
new file mode 100644
index 000000000000..6d3da983adc3
--- /dev/null
+++ b/security/krb5-appl/files/patch-lib::krb5::asn.1::asn1buf.c
@@ -0,0 +1,13 @@
+*** lib/krb5/asn.1/asn1buf.c 12 Mar 2003 04:33:30 -0000 5.24
+--- lib/krb5/asn.1/asn1buf.c 23 Aug 2004 03:43:47 -0000
+***************
+*** 122,127 ****
+--- 122,129 ----
+ return ASN1_OVERRUN;
+ }
+ while (nestlevel > 0) {
++ if (buf->bound - buf->next + 1 <= 0)
++ return ASN1_OVERRUN;
+ retval = asn1_get_tag_2(buf, &t);
+ if (retval) return retval;
+ if (!t.indef) {
diff --git a/security/krb5/Makefile b/security/krb5/Makefile
index 9c3dd3045662..0e590c1b344a 100644
--- a/security/krb5/Makefile
+++ b/security/krb5/Makefile
@@ -7,6 +7,7 @@
PORTNAME= krb5
PORTVERSION= 1.3.4
+PORTREVISION= 1
CATEGORIES= security
# USE_TARBALL tells the port that the user has fetched the source
# directly from MIT or crypto-publish.org (CRYTPO-PUBLISH).
diff --git a/security/krb5/files/patch-lib::krb5::asn.1::asn1buf.c b/security/krb5/files/patch-lib::krb5::asn.1::asn1buf.c
new file mode 100644
index 000000000000..6d3da983adc3
--- /dev/null
+++ b/security/krb5/files/patch-lib::krb5::asn.1::asn1buf.c
@@ -0,0 +1,13 @@
+*** lib/krb5/asn.1/asn1buf.c 12 Mar 2003 04:33:30 -0000 5.24
+--- lib/krb5/asn.1/asn1buf.c 23 Aug 2004 03:43:47 -0000
+***************
+*** 122,127 ****
+--- 122,129 ----
+ return ASN1_OVERRUN;
+ }
+ while (nestlevel > 0) {
++ if (buf->bound - buf->next + 1 <= 0)
++ return ASN1_OVERRUN;
+ retval = asn1_get_tag_2(buf, &t);
+ if (retval) return retval;
+ if (!t.indef) {