aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorNorikatsu Shigemura <nork@FreeBSD.org>2003-02-08 05:50:58 +0000
committerNorikatsu Shigemura <nork@FreeBSD.org>2003-02-08 05:50:58 +0000
commitbaba95e6c3d00deec57fe46c2b5c5587bbb7d928 (patch)
treec4a3327fec99baf56922d6cea9e2c9ae603ec7eb /security
parent895e570d7d52762dcd1fc6e01e414dc254e7cf2f (diff)
downloadports-baba95e6c3d00deec57fe46c2b5c5587bbb7d928.tar.gz
ports-baba95e6c3d00deec57fe46c2b5c5587bbb7d928.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/pinentry/Makefile6
-rw-r--r--security/pinentry/distinfo2
-rw-r--r--security/pinentry/files/patch-qt::main.cpp15
-rw-r--r--security/pinentry/files/patch-qt::pinentrycontroller.cpp11
4 files changed, 5 insertions, 29 deletions
diff --git a/security/pinentry/Makefile b/security/pinentry/Makefile
index 4bba97a95676..bb1b2ab4b977 100644
--- a/security/pinentry/Makefile
+++ b/security/pinentry/Makefile
@@ -6,9 +6,9 @@
#
PORTNAME= pinentry
-PORTVERSION= 0.6.7
+PORTVERSION= 0.6.8
CATEGORIES= security
-MASTER_SITES= ftp://ftp.gnupg.org/gcrypt/pinentry/ \
+MASTER_SITES= ftp://ftp.gnupg.org/gcrypt/alpha/aegypten/ \
http://tigress.com/lofi/
DISTFILES= ${PORTNAME}-${PORTVERSION}.tar.gz \
common.tar.gz \
@@ -38,6 +38,8 @@ CONFIGURE_ARGS+=--with-included-gettext=no
.if defined(WITH_QT)
#USE_QT_VER= 3
BROKEN= The QT pinentry-helper is currently non-functional
+.else
+CONFIGURE_ARGS+=--disable-pinentry-qt
.endif
.if defined(HAVE_GTK)
diff --git a/security/pinentry/distinfo b/security/pinentry/distinfo
index 7e4289b719a7..ff8fd8ab40da 100644
--- a/security/pinentry/distinfo
+++ b/security/pinentry/distinfo
@@ -1,3 +1,3 @@
-MD5 (pinentry-0.6.7.tar.gz) = d1fd852644571ab7edf6c01f51078210
+MD5 (pinentry-0.6.8.tar.gz) = be8460bc1ecc2596fabea931a48c5080
MD5 (common.tar.gz) = 4f5171946f83dfe64761344d7e86af05
MD5 (jnlib.tar.gz) = 9e8d48da4e6f8db94da64d444f4b3687
diff --git a/security/pinentry/files/patch-qt::main.cpp b/security/pinentry/files/patch-qt::main.cpp
deleted file mode 100644
index be62eb2ae09f..000000000000
--- a/security/pinentry/files/patch-qt::main.cpp
+++ /dev/null
@@ -1,15 +0,0 @@
---- qt/main.cpp.orig Thu Jan 30 09:25:31 2003
-+++ qt/main.cpp Thu Jan 30 09:26:10 2003
-@@ -157,6 +157,12 @@
- #ifdef FALLBACK_CURSES
- if( pinentry_have_display (argc, argv) ) {
- #endif
-+ // Work around non-standard handling of DISPLAY
-+ for( int i = 1; i < argc; ++i ) {
-+ if( !strcmp( "--display", argv[i] ) ) {
-+ argv[i] = "-display";
-+ }
-+ }
- return qt_main( argc, argv );
- #ifdef FALLBACK_CURSES
- } else {
diff --git a/security/pinentry/files/patch-qt::pinentrycontroller.cpp b/security/pinentry/files/patch-qt::pinentrycontroller.cpp
deleted file mode 100644
index db9614385560..000000000000
--- a/security/pinentry/files/patch-qt::pinentrycontroller.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- qt/pinentrycontroller.cpp.orig Thu Jan 30 09:25:51 2003
-+++ qt/pinentrycontroller.cpp Thu Jan 30 09:26:15 2003
-@@ -56,6 +56,8 @@
-
- assuan_set_malloc_hooks( secmem_malloc, secmem_realloc, secmem_free );
- int rc = assuan_init_pipe_server( &_ctx, fds );
-+ assuan_set_log_stream (_ctx, stderr);
-+
- if( rc ) {
- qDebug(assuan_strerror( static_cast<AssuanError>(rc) ));
- exit(-1);