aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2016-11-07 13:02:18 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2016-11-07 13:02:18 +0000
commitdd8fb84cc5a09f1af77ae6cbaa2526d9bbd6da07 (patch)
treed07097d16b8b89a2affc2875190dbab9fa3dbebc /security
parentbd563bb850c49babed42c80a8ffc7feb1959ef5b (diff)
downloadports-dd8fb84cc5a09f1af77ae6cbaa2526d9bbd6da07.tar.gz
ports-dd8fb84cc5a09f1af77ae6cbaa2526d9bbd6da07.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/py-mixbox/Makefile29
-rw-r--r--security/py-mixbox/distinfo3
-rw-r--r--security/py-mixbox/pkg-descr4
4 files changed, 37 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 15f046412e73..7c88b7598a0c 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -870,6 +870,7 @@
SUBDIR += py-maec
SUBDIR += py-mcrypt
SUBDIR += py-mhash
+ SUBDIR += py-mixbox
SUBDIR += py-oauth2client
SUBDIR += py-oauthlib
SUBDIR += py-openssl
diff --git a/security/py-mixbox/Makefile b/security/py-mixbox/Makefile
new file mode 100644
index 000000000000..ebe4f15f8892
--- /dev/null
+++ b/security/py-mixbox/Makefile
@@ -0,0 +1,29 @@
+# Created by: Antoine Brodin <antoine@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= mixbox
+PORTVERSION= 1.0.1
+CATEGORIES= security python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= antoine@FreeBSD.org
+COMMENT= Utility library for cybox, maec, and stix
+
+LICENSE= BSD3CLAUSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dateutil>=0:devel/py-dateutil \
+ ${PYTHON_PKGNAMEPREFIX}lxml>=0:devel/py-lxml \
+ ${PYTHON_PKGNAMEPREFIX}ordered-set>=0:devel/py-ordered-set
+
+NO_ARCH= yes
+USES= python
+USE_PYTHON= distutils autoplist
+
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_REL} < 3400
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}weakrefmethod>=1.0.3:devel/py-weakrefmethod
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/security/py-mixbox/distinfo b/security/py-mixbox/distinfo
new file mode 100644
index 000000000000..e4179edc33c0
--- /dev/null
+++ b/security/py-mixbox/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1477212259
+SHA256 (mixbox-1.0.1.tar.gz) = 4256ba29f9e629a300b91530871e8dc6ed576d7648f757ce6a990c8cabc1a0be
+SIZE (mixbox-1.0.1.tar.gz) = 39781
diff --git a/security/py-mixbox/pkg-descr b/security/py-mixbox/pkg-descr
new file mode 100644
index 000000000000..22ab8e645a79
--- /dev/null
+++ b/security/py-mixbox/pkg-descr
@@ -0,0 +1,4 @@
+A library of common code leveraged by python-cybox, python-maec, and
+python-stix.
+
+WWW: https://github.com/CybOXProject/mixbox