aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorPhilippe Audeoud <jadawin@FreeBSD.org>2008-03-26 15:17:28 +0000
committerPhilippe Audeoud <jadawin@FreeBSD.org>2008-03-26 15:17:28 +0000
commitf70644a0c571843996b3ce4e3f103855797a50f2 (patch)
treede235e57b754873c8a736f857fc74288a358440b /security
parent08f8396490051fba8bd974aef70d2e9324fb0676 (diff)
downloadports-f70644a0c571843996b3ce4e3f103855797a50f2.tar.gz
ports-f70644a0c571843996b3ce4e3f103855797a50f2.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/fakeroot/Makefile21
-rw-r--r--security/fakeroot/distinfo6
-rw-r--r--security/fakeroot/files/patch-doc.diff107
-rw-r--r--security/fakeroot/pkg-plist1
4 files changed, 126 insertions, 9 deletions
diff --git a/security/fakeroot/Makefile b/security/fakeroot/Makefile
index 0abb285c3503..33a83fc8bbc3 100644
--- a/security/fakeroot/Makefile
+++ b/security/fakeroot/Makefile
@@ -6,23 +6,32 @@
#
PORTNAME= fakeroot
-PORTVERSION= 1.5.8
+PORTVERSION= 1.9.3
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_DEBIAN}
MASTER_SITE_SUBDIR= pool/main/f/fakeroot
DISTNAME= ${PORTNAME}_${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= ganael.laplanche@martymac.com
COMMENT= Simulate the root user behaviour
-BUILD_DEPENDS= ${LOCALBASE}/bin/po4a:${PORTSDIR}/textproc/po4a
-
GNU_CONFIGURE= yes
-INSTALLS_SHLIB= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ARGS= --with-ipc=tcp
+USE_AUTOTOOLS= libtool:15
+USE_LDCONFIG= yes
+
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-MANLANG= "" es sv fr
+MANLANG= "" es sv fr nl
MAN1= faked.1 fakeroot.1
+pre-configure:
+ @${REINPLACE_CMD} -e 's/-lpthread/${PTHREAD_LIBS}/g' \
+ ${WRKSRC}/${CONFIGURE_SCRIPT}
+
+post-install:
+ @${MV} ${PREFIX}/lib/libfakeroot-0.so ${PREFIX}/lib/libfakeroot.so.0
+ @${LN} -sf ${PREFIX}/lib/libfakeroot.so.0 ${PREFIX}/lib/libfakeroot-0.so
+
.include <bsd.port.mk>
diff --git a/security/fakeroot/distinfo b/security/fakeroot/distinfo
index e699a667a92e..8e37d086dd0c 100644
--- a/security/fakeroot/distinfo
+++ b/security/fakeroot/distinfo
@@ -1,3 +1,3 @@
-MD5 (fakeroot_1.5.8.tar.gz) = 02a410fade33f08d2556fdb60edaaf62
-SHA256 (fakeroot_1.5.8.tar.gz) = c627f7feea7b647ab8c66c347e2fb98645f532483cb61ca5f8134bcf458d06e0
-SIZE (fakeroot_1.5.8.tar.gz) = 787949
+MD5 (fakeroot_1.9.3.tar.gz) = d96c9bf27590d6da4215f0af998f1ee9
+SHA256 (fakeroot_1.9.3.tar.gz) = 5166b1f6f269c5d9744fa62d4153382cf8ab270699ee4904cc2a6464f0714208
+SIZE (fakeroot_1.9.3.tar.gz) = 393232
diff --git a/security/fakeroot/files/patch-doc.diff b/security/fakeroot/files/patch-doc.diff
new file mode 100644
index 000000000000..408af51ec1ce
--- /dev/null
+++ b/security/fakeroot/files/patch-doc.diff
@@ -0,0 +1,107 @@
+diff -aur doc.orig/es/faked.1 doc/es/faked.1
+--- doc.orig/es/faked.1 2008-03-18 11:35:33.029414914 +0100
++++ doc/es/faked.1 2008-03-18 11:35:38.848400009 +0100
+@@ -86,5 +86,4 @@
+ la mayor parte de J.H.M. Dassen <jdassen@debian.org> con muchas
+ modificaciones y añadiduras de joost y Clint.
+ .SH "VÉASE ADEMÁS"
+-\fBfakeroot\fP(1), \fBdpkg\-buildpackage\fP(1), \fBdebuild\fP(1)
+-\fB/usr/share/doc/fakeroot/DEBUG\fP
++\fBfakeroot\fP(1)
+diff -aur doc.orig/es/fakeroot.1 doc/es/fakeroot.1
+--- doc.orig/es/fakeroot.1 2008-03-18 11:35:33.029414914 +0100
++++ doc/es/fakeroot.1 2008-03-18 11:35:38.849399857 +0100
+@@ -236,6 +236,4 @@
+ la mayor parte de J.H.M. Dassen <jdassen@debian.org> con muchas
+ modificaciones y añadiduras de joost y Clint.
+ .SH "VÉASE ADEMÁS"
+-\fBfaked\fP(1) \fBdpkg\-buildpackage\fP(1), \fBdebuild\fP(1)
+-\fB/usr/share/doc/fakeroot/DEBUG\fP
+-
++\fBfaked\fP(1)
+diff -aur doc.orig/faked.1 doc/faked.1
+--- doc.orig/faked.1 2008-03-18 11:35:33.030415042 +0100
++++ doc/faked.1 2008-03-18 11:36:10.811317084 +0100
+@@ -91,7 +91,4 @@
+ .RI <jdassen@debian.org>
+ mods/additions by joost and Clint.
+ .SH "SEE ALSO"
+-.BR fakeroot (1),
+-.BR dpkg-buildpackage (1),
+-.BR debuild (1)
+-.BR /usr/share/doc/fakeroot/DEBUG
++.BR fakeroot (1)
+diff -aur doc.orig/fakeroot.1 doc/fakeroot.1
+--- doc.orig/fakeroot.1 2008-03-18 11:35:33.030415042 +0100
++++ doc/fakeroot.1 2008-03-18 11:35:38.850399704 +0100
+@@ -297,7 +297,3 @@
+ Rather a lot mods/additions by joost and Clint.
+ .SH "SEE ALSO"
+ .BR faked (1)
+-.BR dpkg\-buildpackage (1),
+-.BR debuild (1)
+-.BR /usr/share/doc/fakeroot/DEBUG
+-
+diff -aur doc.orig/fr/faked.1 doc/fr/faked.1
+--- doc.orig/fr/faked.1 2008-03-18 11:35:33.026414813 +0100
++++ doc/fr/faked.1 2008-03-18 11:35:38.850399704 +0100
+@@ -90,5 +90,4 @@
+ En majeure partie écrite par J.H.M. Dassen <jdassen@debian.org>. La
+ plupart des ajouts et des modifications par Joost et Clint.
+ .SH "VOIR AUSSI"
+-\fBfakeroot\fP(1) \fBdpkg\-buildpackage\fP(1), \fBdebuild\fP(1)
+-\fB/usr/share/doc/fakeroot/DEBUG\fP
++\fBfakeroot\fP(1)
+diff -aur doc.orig/fr/fakeroot.1 doc/fr/fakeroot.1
+--- doc.orig/fr/fakeroot.1 2008-03-18 11:35:33.026414813 +0100
++++ doc/fr/fakeroot.1 2008-03-18 11:35:38.851402625 +0100
+@@ -243,6 +243,4 @@
+ En majeure partie écrite par J.H.M. Dassen <jdassen@debian.org>: La
+ plupart des ajouts et des modifications par Joost et Clint.
+ .SH "VOIR AUSSI"
+-\fBfaked\fP(1) \fBdpkg\-buildpackage\fP(1), \fBdebuild\fP(1)
+-\fB/usr/share/doc/fakeroot/DEBUG\fP
+-
++\fBfaked\fP(1)
+diff -aur doc.orig/nl/faked.1 doc/nl/faked.1
+--- doc.orig/nl/faked.1 2008-03-18 11:35:33.026414813 +0100
++++ doc/nl/faked.1 2008-03-18 11:35:38.852399958 +0100
+@@ -90,5 +90,4 @@
+ Vooral door J.H.M. Dassen <\fIjdassen@debian.org\fP>. Wijzigingen en
+ aanvullingen door joost en Clint.
+ .SH "ZIE OOK"
+-\fBfakeroot\fP(1), \fBdpkg\-buildpackage\fP(1), \fBdebuild\fP(1),
+-\fB/usr/share/doc/fakeroot/DEBUG\fP
++\fBfakeroot\fP(1)
+diff -aur doc.orig/nl/fakeroot.1 doc/nl/fakeroot.1
+--- doc.orig/nl/fakeroot.1 2008-03-18 11:35:33.025414965 +0100
++++ doc/nl/fakeroot.1 2008-03-18 11:35:38.852399958 +0100
+@@ -249,6 +249,4 @@
+ Vooral door J.H.M. Dassen <\fIjdassen@debian.org\fP>. Nogal wat
+ wijzigingen en aanvullingen door joost en Clint.
+ .SH "ZIE OOK"
+-\fBfaked\fP(1), \fBdpkg\-buildpackage\fP(1), \fBdebuild\fP(1),
+-\fB/usr/share/doc/fakeroot/DEBUG\fP
+-
++\fBfaked\fP(1)
+diff -aur doc.orig/sv/faked.1 doc/sv/faked.1
+--- doc.orig/sv/faked.1 2008-03-18 11:35:33.029414914 +0100
++++ doc/sv/faked.1 2008-03-18 11:35:38.853399806 +0100
+@@ -87,5 +87,4 @@
+ mostly by J.H.M. Dassen <jdassen@debian.org> mods/additions by joost
+ and Clint.
+ .SH "SE ÄVEN"
+-\fBfakeroot\fP(1), \fBdpkg\-buildpackage\fP(1), \fBdebuild\fP(1)
+-\fB/usr/share/doc/fakeroot/DEBUG\fP
++\fBfakeroot\fP(1)
+diff -aur doc.orig/sv/fakeroot.1 doc/sv/fakeroot.1
+--- doc.orig/sv/fakeroot.1 2008-03-18 11:35:33.029414914 +0100
++++ doc/sv/fakeroot.1 2008-03-18 11:35:38.853399806 +0100
+@@ -228,6 +228,4 @@
+ mostly by J.H.M. Dassen <jdassen@debian.org> Rather a lot
+ mods/additions by joost and Clint.
+ .SH "SE ÄVEN"
+-\fBfaked\fP(1) \fBdpkg\-buildpackage\fP(1), \fBdebuild\fP(1)
+-\fB/usr/share/doc/fakeroot/DEBUG\fP
+-
++\fBfaked\fP(1)
diff --git a/security/fakeroot/pkg-plist b/security/fakeroot/pkg-plist
index dcd79ddbf18a..09e510443c53 100644
--- a/security/fakeroot/pkg-plist
+++ b/security/fakeroot/pkg-plist
@@ -1,6 +1,7 @@
bin/faked
bin/fakeroot
lib/libfakeroot-0.so
+lib/libfakeroot.so.0
lib/libfakeroot.a
lib/libfakeroot.la
lib/libfakeroot.so