aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2001-12-02 06:52:44 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2001-12-02 06:52:44 +0000
commitb8cb1c43d7e8cb30d2fa5bfd59c54fabe5076adc (patch)
tree955217cc4f2d2e590ba16d481eb8ce9723e09ff9 /security
parentd9b14b9d5a08c708b2e506316b7e476d0604afcf (diff)
downloadports-b8cb1c43d7e8cb30d2fa5bfd59c54fabe5076adc.tar.gz
ports-b8cb1c43d7e8cb30d2fa5bfd59c54fabe5076adc.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/hpn-ssh/Makefile9
-rw-r--r--security/hpn-ssh/distinfo2
-rw-r--r--security/hpn-ssh/files/batch.patch11
-rw-r--r--security/openssh-portable/Makefile9
-rw-r--r--security/openssh-portable/distinfo2
-rw-r--r--security/openssh-portable/files/batch.patch11
-rw-r--r--security/openssh/Makefile4
-rw-r--r--security/openssh/distinfo4
8 files changed, 38 insertions, 14 deletions
diff --git a/security/hpn-ssh/Makefile b/security/hpn-ssh/Makefile
index 6d93acb48218..472fc894bde9 100644
--- a/security/hpn-ssh/Makefile
+++ b/security/hpn-ssh/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= openssh
-PORTVERSION= 3.0.1p1
+PORTVERSION= 3.0.2p1
CATEGORIES= security ipv6
MASTER_SITES= ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/ \
ftp://ftp.op.net/pub/OpenBSD/OpenSSH/portable/ \
@@ -36,10 +36,11 @@ CONFIGURE_ARGS+= --with-pam
CONFIGURE_ARGS+= --with-tcp-wrappers
.endif
-post-install:
- @${CAT} ${PKGMESSAGE}
.if defined(BATCH)
- @(cd ${PREFIX} && ${RM} -f ${CLEAN})
+EXTRA_PATCHES+= ${FILESDIR}/batch.patch
.endif
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
.include <bsd.port.mk>
diff --git a/security/hpn-ssh/distinfo b/security/hpn-ssh/distinfo
index a5e34c67f017..6bfa94872b46 100644
--- a/security/hpn-ssh/distinfo
+++ b/security/hpn-ssh/distinfo
@@ -1 +1 @@
-MD5 (openssh-3.0.1p1.tar.gz) = ded31e3ca433790bab7584b4521ddd52
+MD5 (openssh-3.0.2p1.tar.gz) = 2fa62bf878862cb47a7515c35afe35b6
diff --git a/security/hpn-ssh/files/batch.patch b/security/hpn-ssh/files/batch.patch
new file mode 100644
index 000000000000..3dc880149595
--- /dev/null
+++ b/security/hpn-ssh/files/batch.patch
@@ -0,0 +1,11 @@
+--- Makefile.in.orig Mon Nov 12 00:34:23 2001
++++ Makefile.in Sun Dec 2 07:45:09 2001
+@@ -176,7 +176,7 @@
+ autoreconf
+ (cd scard && $(MAKE) -f Makefile.in distprep)
+
+-install: $(CONFIGFILES) $(MANPAGES) $(TARGETS) install-files host-key
++install: $(CONFIGFILES) $(MANPAGES) $(TARGETS) install-files
+ install-nokeys: $(CONFIGFILES) $(MANPAGES) $(TARGETS) install-files
+
+ scard-install:
diff --git a/security/openssh-portable/Makefile b/security/openssh-portable/Makefile
index 6d93acb48218..472fc894bde9 100644
--- a/security/openssh-portable/Makefile
+++ b/security/openssh-portable/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= openssh
-PORTVERSION= 3.0.1p1
+PORTVERSION= 3.0.2p1
CATEGORIES= security ipv6
MASTER_SITES= ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/ \
ftp://ftp.op.net/pub/OpenBSD/OpenSSH/portable/ \
@@ -36,10 +36,11 @@ CONFIGURE_ARGS+= --with-pam
CONFIGURE_ARGS+= --with-tcp-wrappers
.endif
-post-install:
- @${CAT} ${PKGMESSAGE}
.if defined(BATCH)
- @(cd ${PREFIX} && ${RM} -f ${CLEAN})
+EXTRA_PATCHES+= ${FILESDIR}/batch.patch
.endif
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
.include <bsd.port.mk>
diff --git a/security/openssh-portable/distinfo b/security/openssh-portable/distinfo
index a5e34c67f017..6bfa94872b46 100644
--- a/security/openssh-portable/distinfo
+++ b/security/openssh-portable/distinfo
@@ -1 +1 @@
-MD5 (openssh-3.0.1p1.tar.gz) = ded31e3ca433790bab7584b4521ddd52
+MD5 (openssh-3.0.2p1.tar.gz) = 2fa62bf878862cb47a7515c35afe35b6
diff --git a/security/openssh-portable/files/batch.patch b/security/openssh-portable/files/batch.patch
new file mode 100644
index 000000000000..3dc880149595
--- /dev/null
+++ b/security/openssh-portable/files/batch.patch
@@ -0,0 +1,11 @@
+--- Makefile.in.orig Mon Nov 12 00:34:23 2001
++++ Makefile.in Sun Dec 2 07:45:09 2001
+@@ -176,7 +176,7 @@
+ autoreconf
+ (cd scard && $(MAKE) -f Makefile.in distprep)
+
+-install: $(CONFIGFILES) $(MANPAGES) $(TARGETS) install-files host-key
++install: $(CONFIGFILES) $(MANPAGES) $(TARGETS) install-files
+ install-nokeys: $(CONFIGFILES) $(MANPAGES) $(TARGETS) install-files
+
+ scard-install:
diff --git a/security/openssh/Makefile b/security/openssh/Makefile
index d054fd618c14..640fcf3cf67c 100644
--- a/security/openssh/Makefile
+++ b/security/openssh/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= openssh
-PORTVERSION= 3.0.1
+PORTVERSION= 3.0.2
CATEGORIES= security
MASTER_SITES= ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/ \
ftp://ftp.usa.openbsd.org/pub/OpenBSD/OpenSSH/ \
@@ -15,7 +15,7 @@ DISTNAME= openssh-${PORTVERSION}
EXTRACT_SUFX= .tgz
PATCH_SITES= ${MASTER_SITES}
-PATCHFILES= openbsd28_3.0.1.patch
+PATCHFILES= openbsd28_3.0.2.patch
MAINTAINER= dinoex@FreeBSD.org
diff --git a/security/openssh/distinfo b/security/openssh/distinfo
index 5ac26fdd752e..2433c3978ee3 100644
--- a/security/openssh/distinfo
+++ b/security/openssh/distinfo
@@ -1,2 +1,2 @@
-MD5 (openssh-3.0.1.tgz) = 7101eb5ad3546e1031e5358a6d40c009
-MD5 (openbsd28_3.0.1.patch) = 57d102fcfd92d98ff90faf3f0bb91020
+MD5 (openssh-3.0.2.tgz) = 83c508a4be90bf9b089db45ac6e28614
+MD5 (openbsd28_3.0.2.patch) = 44cb043a46770c53f9a0345d79dddfc1