aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorHajimu UMEMOTO <ume@FreeBSD.org>2003-09-01 10:44:42 +0000
committerHajimu UMEMOTO <ume@FreeBSD.org>2003-09-01 10:44:42 +0000
commitd6c32c2c4078d713f9f16e8f9d58d37ec5294956 (patch)
tree3207c7c0c8ea55851f95dada1bb112bc36832be1 /security
parent871f31e386fb4ffec69c0db86a30e9032f8f2ceb (diff)
downloadports-d6c32c2c4078d713f9f16e8f9d58d37ec5294956.tar.gz
ports-d6c32c2c4078d713f9f16e8f9d58d37ec5294956.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/cyrus-sasl2-saslauthd/Makefile7
-rw-r--r--security/cyrus-sasl2/Makefile7
2 files changed, 4 insertions, 10 deletions
diff --git a/security/cyrus-sasl2-saslauthd/Makefile b/security/cyrus-sasl2-saslauthd/Makefile
index eae84c6999f2..a43e8ee4f942 100644
--- a/security/cyrus-sasl2-saslauthd/Makefile
+++ b/security/cyrus-sasl2-saslauthd/Makefile
@@ -29,6 +29,7 @@ DOCSDIR= ${PREFIX}/share/doc/cyrus-sasl2
USE_RC_SUBR= YES
+USE_OPENSSL= yes
GNU_CONFIGURE= YES
CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc \
@@ -39,6 +40,7 @@ CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc \
--enable-static \
--enable-login \
--enable-auth-sasldb \
+ --with-openssl=${OPENSSLBASE} \
--with-rc4=openssl \
--with-saslauthd
@@ -101,11 +103,6 @@ CONFIGURE_ARGS+=--enable-krb4=${LOCALBASE}/krb4
CONFIGURE_ARGS+=--disable-krb4
.endif
-USE_OPENSSL= yes
-.if !defined(WITH_OPENSSL_BASE)
-CONFIGURE_ARGS+=--with-openssl=${OPENSSLBASE}
-.endif
-
CONFIGURE_ENV+= LOCALBASE=${LOCALBASE} \
OPENSSLINC=${OPENSSLINC} \
OPENSSLLIB=${OPENSSLLIB} \
diff --git a/security/cyrus-sasl2/Makefile b/security/cyrus-sasl2/Makefile
index b1efaae1498c..ab76327eca44 100644
--- a/security/cyrus-sasl2/Makefile
+++ b/security/cyrus-sasl2/Makefile
@@ -38,6 +38,7 @@ MAN3= sasl.3 sasl_authorize_t.3 sasl_auxprop.3 \
sasl_user_exists.3 sasl_verifyfile_t.3
MAN8= sasldblistusers2.8 saslpasswd2.8
+USE_OPENSSL= yes
GNU_CONFIGURE= YES
CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc \
@@ -48,6 +49,7 @@ CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc \
--enable-static \
--enable-login \
--enable-auth-sasldb \
+ --with-openssl=${OPENSSLBASE} \
--with-rc4=openssl \
--with-saslauthd
@@ -142,11 +144,6 @@ CONFIGURE_ARGS+=--disable-krb4
EBONES= "@comment "
.endif
-USE_OPENSSL= yes
-.if !defined(WITH_OPENSSL_BASE)
-CONFIGURE_ARGS+=--with-openssl=${OPENSSLBASE}
-.endif
-
CONFIGURE_ENV+= LOCALBASE=${LOCALBASE} \
OPENSSLINC=${OPENSSLINC} \
OPENSSLLIB=${OPENSSLLIB} \