aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2018-02-22 14:29:19 +0000
committerMathieu Arnold <mat@FreeBSD.org>2018-02-22 14:29:19 +0000
commit79d61483a6d60299ac995ad2ff77202e2f7e1885 (patch)
tree51d908db8b188773415710f50470599dda06c3ad /security
parent773e971073d140af93db33e4b9c1e17f21004ffd (diff)
downloadports-79d61483a6d60299ac995ad2ff77202e2f7e1885.tar.gz
ports-79d61483a6d60299ac995ad2ff77202e2f7e1885.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/py-acme/Makefile3
-rw-r--r--security/py-acme/version.mk1
-rw-r--r--security/py-certbot/Makefile5
3 files changed, 6 insertions, 3 deletions
diff --git a/security/py-acme/Makefile b/security/py-acme/Makefile
index 18b831a32bf0..e4c7bbb07618 100644
--- a/security/py-acme/Makefile
+++ b/security/py-acme/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= acme
-PORTVERSION= 0.21.1
+PORTVERSION= ${ACME_VERSION}
PORTEPOCH= 1
CATEGORIES= security python
MASTER_SITES= CHEESESHOP
@@ -33,4 +33,5 @@ NO_ARCH= yes
do-test:
@cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
+.include "version.mk"
.include <bsd.port.mk>
diff --git a/security/py-acme/version.mk b/security/py-acme/version.mk
new file mode 100644
index 000000000000..30cb982414d3
--- /dev/null
+++ b/security/py-acme/version.mk
@@ -0,0 +1 @@
+ACME_VERSION= 0.21.1
diff --git a/security/py-certbot/Makefile b/security/py-certbot/Makefile
index 40ce1e3feed5..afd118499d80 100644
--- a/security/py-certbot/Makefile
+++ b/security/py-certbot/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= certbot
-PORTVERSION= 0.21.1
+PORTVERSION= ${ACME_VERSION}
PORTEPOCH= 1
CATEGORIES= security python
MASTER_SITES= CHEESESHOP
@@ -14,7 +14,7 @@ COMMENT= Let's Encrypt client
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}acme>=${PORTVERSION}:security/py-acme@${FLAVOR} \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}acme>=${ACME_VERSION}:security/py-acme@${FLAVOR} \
${PYTHON_PKGNAMEPREFIX}configargparse>=0.9.3:devel/py-configargparse@${FLAVOR} \
${PYTHON_PKGNAMEPREFIX}configobj>0:devel/py-configobj@${FLAVOR} \
${PYTHON_PKGNAMEPREFIX}cryptography>=1.2:security/py-cryptography@${FLAVOR} \
@@ -42,4 +42,5 @@ post-patch:
do-test:
@cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
+.include "${.CURDIR}/../py-acme/version.mk"
.include <bsd.port.mk>