aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorFUJISHIMA Satsuki <sf@FreeBSD.org>2003-07-14 02:53:03 +0000
committerFUJISHIMA Satsuki <sf@FreeBSD.org>2003-07-14 02:53:03 +0000
commitb185046be2ec03555daaf4f26d38542c403a9955 (patch)
tree0274ce607614533de66837fc1f70d4c35770d9e1 /security
parent88d002074007544d532f2495aeb93729291e6275 (diff)
downloadports-b185046be2ec03555daaf4f26d38542c403a9955.tar.gz
ports-b185046be2ec03555daaf4f26d38542c403a9955.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/authforce/Makefile28
-rw-r--r--security/ccrypt/Makefile6
-rw-r--r--security/dirmngr/Makefile3
-rw-r--r--security/pinentry/Makefile3
-rw-r--r--security/pinentry/files/patch-curses::Makefile.am2
-rw-r--r--security/pinentry/files/patch-gtk::Makefile.am2
-rw-r--r--security/pinentry/files/patch-qt::Makefile.am2
-rw-r--r--security/poc/Makefile8
-rw-r--r--security/smtpmap/Makefile6
9 files changed, 30 insertions, 30 deletions
diff --git a/security/authforce/Makefile b/security/authforce/Makefile
index 0a85f7f8066c..83af959597bc 100644
--- a/security/authforce/Makefile
+++ b/security/authforce/Makefile
@@ -5,26 +5,26 @@
# $FreeBSD$
#
-PORTNAME= authforce
-PORTVERSION= 0.9.6
-CATEGORIES= security www
-MASTER_SITES= http://kapheine.hypa.net/authforce/
+PORTNAME= authforce
+PORTVERSION= 0.9.6
+PORTREVISION= 1
+CATEGORIES= security www
+MASTER_SITES= http://kapheine.hypa.net/authforce/
-MAINTAINER= ache@FreeBSD.org
+MAINTAINER= ache@FreeBSD.org
COMMENT= HTTP authentication brute forcer
-LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt \
- curl.2:${PORTSDIR}/ftp/curl \
+LIB_DEPENDS= curl.2:${PORTSDIR}/ftp/curl \
intl.4:${PORTSDIR}/devel/gettext
-USE_BZIP2= yes
-
-GNU_CONFIGURE= yes
-CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
+USE_BZIP2= yes
+USE_GETOPT_LONG=yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib" \
- LIBS="-lgnugetopt -lintl"
+ LIBS="-lintl"
-MAN1= authforce.1
-MANCOMPRESSED= yes
+MAN1= authforce.1
+MANCOMPRESSED= yes
.include <bsd.port.mk>
diff --git a/security/ccrypt/Makefile b/security/ccrypt/Makefile
index 5e3e173f6259..e227420f0366 100644
--- a/security/ccrypt/Makefile
+++ b/security/ccrypt/Makefile
@@ -8,6 +8,7 @@
PORTNAME= ccrypt
PORTVERSION= 1.3
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://quasar.mathstat.uottawa.ca/~selinger/ccrypt/download/
@@ -16,12 +17,9 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= jim@corebsd.or.id
COMMENT= A command-line utility for encrypting and decrypting files and streams
-LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
-
+USE_GETOPT_LONG=yes
USE_REINPLACE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib -lgnugetopt"
MAN1= ccrypt.1
MLINKS= ccrypt.1 ccencrypt.1 \
diff --git a/security/dirmngr/Makefile b/security/dirmngr/Makefile
index d07bc05e197e..d4b56839713c 100644
--- a/security/dirmngr/Makefile
+++ b/security/dirmngr/Makefile
@@ -7,6 +7,7 @@
PORTNAME= dirmngr
PORTVERSION= 0.4.5
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_GNUPG} \
http://tigress.com/lofi/:lofi/
@@ -19,9 +20,9 @@ COMMENT= A client for managing and downloading certificate revocation lists
LIB_DEPENDS= db2.0:${PORTSDIR}/databases/db2 \
gcrypt.6:${PORTSDIR}/security/libgcrypt \
- gnugetopt.1:${PORTSDIR}/devel/libgnugetopt \
ksba.7:${PORTSDIR}/security/libksba
+USE_GETOPT_LONG=yes
USE_AUTOMAKE_VER= 15
USE_LIBTOOL= yes
USE_GMAKE= yes
diff --git a/security/pinentry/Makefile b/security/pinentry/Makefile
index 2d34d775a574..93d65144e2f8 100644
--- a/security/pinentry/Makefile
+++ b/security/pinentry/Makefile
@@ -7,6 +7,7 @@
PORTNAME= pinentry
PORTVERSION= 0.6.9
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= ftp://ftp.klaralvdalens-datakonsult.se/pub/aegypten/alpha/latest/ \
${MASTER_SITE_GNUPG} \
@@ -20,9 +21,9 @@ MAINTAINER= michaelnottebrock@gmx.net
COMMENT= A collection of simple PIN or passphrase entry dialogs
LIB_DEPENDS= gcrypt.6:${PORTSDIR}/security/libgcrypt \
- gnugetopt.1:${PORTSDIR}/devel/libgnugetopt \
ksba.7:${PORTSDIR}/security/libksba
+USE_GETOPT_LONG=yes
USE_AUTOMAKE_VER= 15
WANT_GNOME= yes
USE_LIBTOOL= yes
diff --git a/security/pinentry/files/patch-curses::Makefile.am b/security/pinentry/files/patch-curses::Makefile.am
index 42222522344b..36dce30e679c 100644
--- a/security/pinentry/files/patch-curses::Makefile.am
+++ b/security/pinentry/files/patch-curses::Makefile.am
@@ -7,6 +7,6 @@
- ../assuan/libassuan.a ../secmem/libsecmem.a \
- $(LIBCAP) $(LIBCURSES) $(LIBICONV)
+ ../assuan/libassuan.a ../secmem/libsecmem.a ../common/libcommon.a \
-+ $(LIBCAP) $(LIBCURSES) $(LIBICONV) -lgnugetopt
++ $(LIBCAP) $(LIBCURSES) $(LIBICONV)
pinentry_curses_SOURCES = pinentry-curses.c
diff --git a/security/pinentry/files/patch-gtk::Makefile.am b/security/pinentry/files/patch-gtk::Makefile.am
index 8d7b22ebbcf7..42ec50ec2448 100644
--- a/security/pinentry/files/patch-gtk::Makefile.am
+++ b/security/pinentry/files/patch-gtk::Makefile.am
@@ -5,7 +5,7 @@
-I$(top_srcdir)/secmem -I$(top_srcdir)/pinentry
LDADD = ../pinentry/libpinentry.a ../assuan/libassuan.a ../secmem/libsecmem.a \
- $(LIBCAP) $(GTK_LIBS) $(libcurses)
-+ ../common/libcommon.a $(LIBCAP) $(GTK_LIBS) $(libcurses) -lgnugetopt
++ ../common/libcommon.a $(LIBCAP) $(GTK_LIBS) $(libcurses)
pinentry_gtk_SOURCES = pinentry-gtk.c \
gtksecentry.c gtksecentry.h
diff --git a/security/pinentry/files/patch-qt::Makefile.am b/security/pinentry/files/patch-qt::Makefile.am
index fd0629c05073..a25aafba5f7b 100644
--- a/security/pinentry/files/patch-qt::Makefile.am
+++ b/security/pinentry/files/patch-qt::Makefile.am
@@ -7,7 +7,7 @@
- $(top_builddir)/secmem/libsecmem.a $(LIBCAP) \
- $(QT_LIBS) $(libcurses)
+ $(top_builddir)/secmem/libsecmem.a $(top_builddir)/common/libcommon.a \
-+ $(LIBCAP) $(QT_LIBS) $(libcurses) -lgnugetopt
++ $(LIBCAP) $(QT_LIBS) $(libcurses)
pinentry_qt_LDFLAGS = $(QT_LDFLAGS)
pinentry_qt_SOURCES = pinentrydialog.h pinentrydialog.cpp \
diff --git a/security/poc/Makefile b/security/poc/Makefile
index e3e93084add1..42d79061eb21 100644
--- a/security/poc/Makefile
+++ b/security/poc/Makefile
@@ -7,6 +7,7 @@
PORTNAME= poc
PORTVERSION= 1.2
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR=poc
@@ -14,13 +15,12 @@ MASTER_SITE_SUBDIR=poc
MAINTAINER= king@v2project.com
COMMENT= Program for managing passwords on smartcards
-LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt \
- towitoko.2:${PORTSDIR}/devel/towitoko
+LIB_DEPENDS= towitoko.2:${PORTSDIR}/devel/towitoko
+USE_GETOPT_LONG=yes
USE_GMAKE= yes
USE_AUTOMAKE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib" \
- LIBS="-lgnugetopt"
+ LDFLAGS="-L${LOCALBASE}/lib"
.include <bsd.port.mk>
diff --git a/security/smtpmap/Makefile b/security/smtpmap/Makefile
index 3f878226c3ea..52a23021d378 100644
--- a/security/smtpmap/Makefile
+++ b/security/smtpmap/Makefile
@@ -7,6 +7,7 @@
PORTNAME= smtpmap
PORTVERSION= 0.8
+PORTREVISION= 1
CATEGORIES= security mail net
MASTER_SITES= http://plasmahh.free-bsd.org/
@@ -14,11 +15,10 @@ MAINTAINER= hubert@frbsd.org
COMMENT= An SMTP software identifier
.if !exists(/usr/include/getopt.h)
-LIB_DEPENDS= gnugetopt:${PORTSDIR}/devel/libgnugetopt
-MAKE_ENV= LIBS="-L${LOCALBASE}/lib -lgnugetopt" \
- INC=-I${LOCALBASE}/include
+MAKE_ENV= LIBS="${LDFLAGS}" INC="${CPPFLAGS}"
.endif
+USE_GETOPT_LONG=yes
USE_BZIP2= yes
USE_REINPLACE= yes
USE_GMAKE= yes