aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2006-07-30 18:15:59 +0000
committerRong-En Fan <rafan@FreeBSD.org>2006-07-30 18:15:59 +0000
commit21f7b02baad2150748e5fcd50c4b798c650974f5 (patch)
treeda4a20c069d82a8322881b7927e1839a73a8d2fb /security
parent4f4e6ed97d245c3269c1cc6f8b1db329d618ebc0 (diff)
downloadports-21f7b02baad2150748e5fcd50c4b798c650974f5.tar.gz
ports-21f7b02baad2150748e5fcd50c4b798c650974f5.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/isnprober/Makefile34
-rw-r--r--security/isnprober/distinfo3
-rw-r--r--security/isnprober/pkg-descr5
4 files changed, 43 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 1e3c618f02b6..00c6369357b1 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -186,6 +186,7 @@
SUBDIR += ipguard
SUBDIR += ipsec-tools
SUBDIR += isakmpd
+ SUBDIR += isnprober
SUBDIR += its4
SUBDIR += jailaudit
SUBDIR += jce_policy14
diff --git a/security/isnprober/Makefile b/security/isnprober/Makefile
new file mode 100644
index 000000000000..ebf461462353
--- /dev/null
+++ b/security/isnprober/Makefile
@@ -0,0 +1,34 @@
+# Ports collection makefile for: isnprober
+# Date created: 28/7/2006
+# Whom: Yonatan <onatan@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= isnprober
+PORTVERSION= 1.02
+CATEGORIES= security
+MASTER_SITES= ftp://ftp.ubizen.com/tools/ \
+ ${MASTER_SITE_PACKETSTORM}
+MASTER_SITE_SUBDIR= UNIX/scanners
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= onatan@gmail.com
+COMMENT= PenTest tool for TCP Initial Sequence Numbers research
+
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Net/RawIP.pm:${PORTSDIR}/net/p5-Net-RawIP
+
+PLIST_FILES= bin/${PORTNAME}
+PORTDOCS= README
+
+USE_PERL5_RUN= yes
+NO_BUILD= yes
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
+.ifndef NOPORTDOCS
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${DOCSDIR}/
+.endif
+
+.include <bsd.port.mk>
diff --git a/security/isnprober/distinfo b/security/isnprober/distinfo
new file mode 100644
index 000000000000..6255bb9136d1
--- /dev/null
+++ b/security/isnprober/distinfo
@@ -0,0 +1,3 @@
+MD5 (isnprober-1.02.tgz) = 25d3db5751d0b83116bd5f7fc64778b5
+SHA256 (isnprober-1.02.tgz) = 8d31129ad28b47eeac556a5e0bf64aca2c47c0c71b2c91e10ce374b15eabaf20
+SIZE (isnprober-1.02.tgz) = 10604
diff --git a/security/isnprober/pkg-descr b/security/isnprober/pkg-descr
new file mode 100644
index 000000000000..e7c199b333fe
--- /dev/null
+++ b/security/isnprober/pkg-descr
@@ -0,0 +1,5 @@
+-- ISNprober / Tom Vandepoel (Tom.Vandepoel@ubizen.com) --
+
+ISNprober is a tool that samples TCP Initial Sequence Numbers or IP ID's
+and can use that information to determine if a set of IP addresses belong
+to the same TCP/IP stack (machine) or not.