aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2012-02-13 02:39:04 +0000
committerGabor Pali <pgj@FreeBSD.org>2012-02-13 02:39:04 +0000
commitb342c113c2a867d7373d357e2edf17daef917fac (patch)
tree5cc3559e1775c1f0613125399155fa693c79b68b /security
parent8bd3d20de21276e7f0817c32f06a39bf84679062 (diff)
Notes
Diffstat (limited to 'security')
-rw-r--r--security/hs-cprng-aes/Makefile21
-rw-r--r--security/hs-cprng-aes/distinfo2
-rw-r--r--security/hs-cprng-aes/pkg-descr4
3 files changed, 27 insertions, 0 deletions
diff --git a/security/hs-cprng-aes/Makefile b/security/hs-cprng-aes/Makefile
new file mode 100644
index 000000000000..69cd7c61bde7
--- /dev/null
+++ b/security/hs-cprng-aes/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: hs-cprng-aes
+# Date created: December 2, 2011
+# Whom: haskell@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= cprng-aes
+PORTVERSION= 0.2.3
+CATEGORIES= security haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= Crypto Pseudo Random Number Generator using AES
+
+LICENSE= BSD
+
+CABAL_SETUP= Setup.hs
+USE_CABAL= cereal>=0.3.0 crypto-api>=0.8 cryptocipher>=0.2.5 entropy>=0.2
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/security/hs-cprng-aes/distinfo b/security/hs-cprng-aes/distinfo
new file mode 100644
index 000000000000..312a61e58b6a
--- /dev/null
+++ b/security/hs-cprng-aes/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cabal/cprng-aes-0.2.3.tar.gz) = c35a07a941069e4bc3530f1ca4912a3717b20c62600dfcee3c7c3b35d687d7f7
+SIZE (cabal/cprng-aes-0.2.3.tar.gz) = 3596
diff --git a/security/hs-cprng-aes/pkg-descr b/security/hs-cprng-aes/pkg-descr
new file mode 100644
index 000000000000..4e9630d7c273
--- /dev/null
+++ b/security/hs-cprng-aes/pkg-descr
@@ -0,0 +1,4 @@
+Simple crypto pseudo-random-number-generator with really good randomness
+property.
+
+WWW: http://github.com/vincenthz/hs-cprng-aes