aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2004-11-05 13:45:19 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2004-11-05 13:45:19 +0000
commitc15e1bf37fcc8880a4bf8bf8ac42498ae70b497e (patch)
tree68f342bf05025b460029c29c749816c7d15b480b /security
parent0b0600e04792f74cbdb55f2d868857ba35e602c8 (diff)
downloadports-c15e1bf37fcc8880a4bf8bf8ac42498ae70b497e.tar.gz
ports-c15e1bf37fcc8880a4bf8bf8ac42498ae70b497e.zip
Add p5-POE-Component-SSLify 0.03, integrate SSL into POE.
Notes
Notes: svn path=/head/; revision=120871
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/p5-POE-Component-SSLify/Makefile27
-rw-r--r--security/p5-POE-Component-SSLify/distinfo2
-rw-r--r--security/p5-POE-Component-SSLify/pkg-descr3
-rw-r--r--security/p5-POE-Component-SSLify/pkg-plist10
5 files changed, 43 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index b266dd347b6c..0449649cf982 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -299,6 +299,7 @@
SUBDIR += p5-OpenCA-REQ
SUBDIR += p5-PGP
SUBDIR += p5-PGP-Sign
+ SUBDIR += p5-POE-Component-SSLify
SUBDIR += p5-SHA
SUBDIR += p5-Safe-Hole
SUBDIR += p5-Tie-EncryptedHash
diff --git a/security/p5-POE-Component-SSLify/Makefile b/security/p5-POE-Component-SSLify/Makefile
new file mode 100644
index 000000000000..c9d489fed460
--- /dev/null
+++ b/security/p5-POE-Component-SSLify/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: POE-Component-SSLify
+# Date created: 05 November 2004
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= POE-Component-SSLify
+PORTVERSION= 0.03
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/A/AP/APOCAL
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@FreeBSD.org
+COMMENT= Integrate SSL into POE
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Net/SSLeay.pm:${PORTSDIR}/security/p5-Net-SSLeay
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= POE::Component::SSLify.3 \
+ POE::Component::SSLify::ClientHandle.3 \
+ POE::Component::SSLify::ServerHandle.3
+
+.include <bsd.port.mk>
diff --git a/security/p5-POE-Component-SSLify/distinfo b/security/p5-POE-Component-SSLify/distinfo
new file mode 100644
index 000000000000..e11a4316ea31
--- /dev/null
+++ b/security/p5-POE-Component-SSLify/distinfo
@@ -0,0 +1,2 @@
+MD5 (POE-Component-SSLify-0.03.tar.gz) = aee216947a6682d5cd449a73f671dc55
+SIZE (POE-Component-SSLify-0.03.tar.gz) = 5579
diff --git a/security/p5-POE-Component-SSLify/pkg-descr b/security/p5-POE-Component-SSLify/pkg-descr
new file mode 100644
index 000000000000..0584457c15e0
--- /dev/null
+++ b/security/p5-POE-Component-SSLify/pkg-descr
@@ -0,0 +1,3 @@
+This component represents the standard way to do SSL in POE.
+
+WWW: http://search.cpan.org/dist/POE-Component-SSLify/
diff --git a/security/p5-POE-Component-SSLify/pkg-plist b/security/p5-POE-Component-SSLify/pkg-plist
new file mode 100644
index 000000000000..fd0fb1561d57
--- /dev/null
+++ b/security/p5-POE-Component-SSLify/pkg-plist
@@ -0,0 +1,10 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/SSLify/.packlist
+%%SITE_PERL%%/POE/Component/SSLify.pm
+%%SITE_PERL%%/POE/Component/SSLify/ClientHandle.pm
+%%SITE_PERL%%/POE/Component/SSLify/ServerHandle.pm
+@dirrm %%SITE_PERL%%/POE/Component/SSLify
+@unexec rmdir %D/%%SITE_PERL%%/POE/Component 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/POE 2>/dev/null || true
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/SSLify
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/POE 2>/dev/null || true