aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2016-02-18 14:47:05 +0000
committerMartin Wilke <miwi@FreeBSD.org>2016-02-18 14:47:05 +0000
commit5a67738f00f2c73ee582719beead9c63ffe151d2 (patch)
treee69b03665ccb6cfc03028cfd2ad64ba204ed3d0f /security
parentd5fe20d168ccdd92ecca8045d08c444895d116d0 (diff)
downloadports-5a67738f00f2c73ee582719beead9c63ffe151d2.tar.gz
ports-5a67738f00f2c73ee582719beead9c63ffe151d2.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/pecl-crack/Makefile2
-rw-r--r--security/pecl-gnupg/Makefile1
-rw-r--r--security/pecl-pam/Makefile1
-rw-r--r--security/pecl-scrypt/Makefile1
-rw-r--r--security/pecl-ssh2/Makefile1
-rw-r--r--security/pecl-taint/Makefile2
-rw-r--r--security/pecl-tcpwrap/Makefile2
7 files changed, 8 insertions, 2 deletions
diff --git a/security/pecl-crack/Makefile b/security/pecl-crack/Makefile
index 172daa31908f..4b1c4ac5f33e 100644
--- a/security/pecl-crack/Makefile
+++ b/security/pecl-crack/Makefile
@@ -22,6 +22,8 @@ USE_PHPIZE= yes
USE_PHP_BUILD= yes
USE_PHPEXT= yes
PHP_MODNAME= crack
+IGNORE_WITH_PHP= 70
+
EXTRACT_AFTER_ARGS=--no-same-permissions --no-same-owner --exclude libcrack
CONFIGURE_ARGS= --with-crack=${LOCALBASE}
CFLAGS+= -Wno-deprecated
diff --git a/security/pecl-gnupg/Makefile b/security/pecl-gnupg/Makefile
index 5ec9c037e274..a827a40fcc07 100644
--- a/security/pecl-gnupg/Makefile
+++ b/security/pecl-gnupg/Makefile
@@ -21,6 +21,7 @@ CONFIGURE_ARGS= --with-gnupg=${LOCALBASE}/include/gpgme
USE_PHP= yes
USE_PHPEXT= yes
USES= localbase tar:tgz
+IGNORE_WITH_PHP= 70
post-patch:
@${REINPLACE_CMD} -e 's|$$GNUPG_DIR/lib|${LOCALBASE}/lib|; s| -ldl||g' ${WRKSRC}/config.m4
diff --git a/security/pecl-pam/Makefile b/security/pecl-pam/Makefile
index ccfb774b16b7..cb2a62ed910c 100644
--- a/security/pecl-pam/Makefile
+++ b/security/pecl-pam/Makefile
@@ -16,5 +16,6 @@ USES= tar:tgz
USE_PHP= yes
USE_PHPIZE= yes
USE_PHPEXT= yes
+IGNORE_WITH_PHP= 70
.include <bsd.port.mk>
diff --git a/security/pecl-scrypt/Makefile b/security/pecl-scrypt/Makefile
index 4200a602fb6d..7299577e7fd4 100644
--- a/security/pecl-scrypt/Makefile
+++ b/security/pecl-scrypt/Makefile
@@ -18,6 +18,7 @@ USE_PHP= hash
USE_PHPEXT= yes
USE_PHP_BUILD= yes
INSTALL_TARGET= install-strip
+IGNORE_WITH_PHP= 70
DOCSDIR= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
PORTDOCS= README.md
diff --git a/security/pecl-ssh2/Makefile b/security/pecl-ssh2/Makefile
index f677ba188828..271fc98b1ebf 100644
--- a/security/pecl-ssh2/Makefile
+++ b/security/pecl-ssh2/Makefile
@@ -17,6 +17,7 @@ LIB_DEPENDS= libssh2.so:${PORTSDIR}/security/libssh2
USES= tar:tgz
USE_PHP= yes
USE_PHPEXT= yes
+IGNORE_WITH_PHP= 70
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib ${EXTRA_LIBS}
diff --git a/security/pecl-taint/Makefile b/security/pecl-taint/Makefile
index 901404a3c5b3..0f4b70480183 100644
--- a/security/pecl-taint/Makefile
+++ b/security/pecl-taint/Makefile
@@ -21,6 +21,6 @@ CONFIGURE_ARGS= --with-php-config=${PREFIX}/bin/php-config
USE_PHP= yes
USE_PHPEXT= yes
USE_PHPIZE= yes
-IGNORE_WITH_PHP= 55 56
+IGNORE_WITH_PHP= 55 56 70
.include <bsd.port.mk>
diff --git a/security/pecl-tcpwrap/Makefile b/security/pecl-tcpwrap/Makefile
index 1d4214a47f63..6f7b11c15537 100644
--- a/security/pecl-tcpwrap/Makefile
+++ b/security/pecl-tcpwrap/Makefile
@@ -16,7 +16,7 @@ LICENSE= PHP202
USES= tar:tgz
USE_PHP= yes
USE_PHPEXT= yes
-IGNORE_WITH_PHP=5 56
+IGNORE_WITH_PHP= 56 70
post-patch:
@${REINPLACE_CMD} -e 's, -ldl,,' ${WRKSRC}/config.m4