aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2018-03-29 14:53:23 +0000
committerMathieu Arnold <mat@FreeBSD.org>2018-03-29 14:53:23 +0000
commit921597722013b1123b6775e8f314063132cca72a (patch)
tree3b60dfc298ce215e08fe82984e17fdbbdd5feacd /security
parent34063c028207afd0e6fde774216128e13210357e (diff)
downloadports-921597722013b1123b6775e8f314063132cca72a.tar.gz
ports-921597722013b1123b6775e8f314063132cca72a.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/botan110/Makefile3
-rw-r--r--security/dsniff/Makefile3
-rw-r--r--security/krb5-116/Makefile3
-rw-r--r--security/libssh/Makefile3
-rw-r--r--security/openssh-portable/Makefile3
-rw-r--r--security/py-m2crypto/Makefile3
6 files changed, 17 insertions, 1 deletions
diff --git a/security/botan110/Makefile b/security/botan110/Makefile
index 7f291dd2061a..a8918792f82e 100644
--- a/security/botan110/Makefile
+++ b/security/botan110/Makefile
@@ -12,6 +12,9 @@ DISTNAME= Botan-${PORTVERSION}
MAINTAINER= lapo@lapo.it
COMMENT= Portable, easy to use, and efficient C++ crypto library
+BROKEN_SSL= openssl-devel
+BROKEN_SSL_REASON_openssl-devel= error: variable has incomplete type 'EVP_MD_CTX' (aka 'struct evp_md_ctx_st')
+
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/doc/license.txt
diff --git a/security/dsniff/Makefile b/security/dsniff/Makefile
index fabd531b04ae..5441e59f321e 100644
--- a/security/dsniff/Makefile
+++ b/security/dsniff/Makefile
@@ -14,6 +14,9 @@ COMMENT= Various sniffing utilities for penetration testing
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
+BROKEN_SSL= openssl-devel
+BROKEN_SSL_REASON_openssl-devel= incomplete definition of type 'struct rsa_st'
+
BUILD_DEPENDS= ${LOCALBASE}/lib/libnids.a:net/libnids
LIB_DEPENDS= libnet.so:net/libnet
diff --git a/security/krb5-116/Makefile b/security/krb5-116/Makefile
index 68ae19123aa2..8c54aeefe66d 100644
--- a/security/krb5-116/Makefile
+++ b/security/krb5-116/Makefile
@@ -18,6 +18,9 @@ COMMENT= MIT implementation of RFC 4120 network authentication service
LICENSE= MIT
+BROKEN_SSL= openssl-devel
+BROKEN_SSL_REASON_openssl-devel= error: "This file is obsolete; please update your software."
+
CONFLICTS= heimdal-[0-9]* srp-[0-9]* krb5-11[34]-[0-9]* \
krb5-1.[0-9]* krb5-devel-*
diff --git a/security/libssh/Makefile b/security/libssh/Makefile
index 02b9ec4cd8c9..d88ecd7bb063 100644
--- a/security/libssh/Makefile
+++ b/security/libssh/Makefile
@@ -12,6 +12,9 @@ COMMENT= Library implementing the SSH1 and SSH2 protocol
LICENSE= LGPL21
LICENSE_FILE= ${WRKSRC}/COPYING
+BROKEN_SSL= openssl-devel
+BROKEN_SSL_REASON_openssl-devel= error: variable has incomplete type 'EVP_MD_CTX' (aka 'struct evp_md_ctx_st')
+
OPTIONS_DEFINE= SSH1 STATIC
OPTIONS_RADIO= CRYPTO
OPTIONS_RADIO_CRYPTO= GCRYPT OPENSSL
diff --git a/security/openssh-portable/Makefile b/security/openssh-portable/Makefile
index 4f11637393f0..3aec1c4b905b 100644
--- a/security/openssh-portable/Makefile
+++ b/security/openssh-portable/Makefile
@@ -26,7 +26,8 @@ CONFIGURE_ARGS= --prefix=${PREFIX} --with-md5-passwords \
ETCOLD= ${PREFIX}/etc
-BROKEN_SSL_REASON_openssl-devel= incomplete definition of type struct rsa_st
+BROKEN_SSL= openssl-devel libressl
+BROKEN_SSL_REASON_openssl-devel= error: OpenSSL >= 1.1.0 is not yet supported
BROKEN_SSL_REASON_libressl= random crashes with 7.6 PR 223000
OPTIONS_DEFINE= PAM TCP_WRAPPERS LIBEDIT BSM \
diff --git a/security/py-m2crypto/Makefile b/security/py-m2crypto/Makefile
index 9b9026060c8e..b1a2ab2b03c9 100644
--- a/security/py-m2crypto/Makefile
+++ b/security/py-m2crypto/Makefile
@@ -14,6 +14,9 @@ COMMENT= Crypto and SSL toolkit for Python
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENCE
+BROKEN_SSL= openssl-devel
+BROKEN_SSL_REASON_openssl-devel= Error: Syntax error in input(1).
+
BUILD_DEPENDS= swig3.0:devel/swig30
PYDISTUTILS_BUILDARGS= build_ext --include=${OPENSSLINC} --openssl=${OPENSSLBASE} --swig=${LOCALBASE}/bin/swig3.0