aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorJoseph Mingrone <jrm@FreeBSD.org>2017-03-13 00:50:36 +0000
committerJoseph Mingrone <jrm@FreeBSD.org>2017-03-13 00:50:36 +0000
commit9a5c5e3d7600230afce351fac1e87933f37064b3 (patch)
tree4528db696c5445839434d478978a79d2e3c81935 /security
parent1959d1a36dbf956667e4e84cb81ab19a3d153635 (diff)
Notes
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/py-onetime/Makefile26
-rw-r--r--security/py-onetime/distinfo3
-rw-r--r--security/py-onetime/pkg-descr5
4 files changed, 35 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index fbd754adffa2..f0bec454adfb 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -880,6 +880,7 @@
SUBDIR += py-mixbox
SUBDIR += py-oauth2client
SUBDIR += py-oauthlib
+ SUBDIR += py-onetime
SUBDIR += py-openssl
SUBDIR += py-paramiko
SUBDIR += py-paramiko1
diff --git a/security/py-onetime/Makefile b/security/py-onetime/Makefile
new file mode 100644
index 000000000000..af73da8942a3
--- /dev/null
+++ b/security/py-onetime/Makefile
@@ -0,0 +1,26 @@
+# Created by: Vidar Karlsen <vidar@karlsen.tech>
+# $FreeBSD$
+
+PORTNAME= onetime
+PORTVERSION= 1.81
+CATEGORIES= security
+MASTER_SITES= http://www.red-bean.com/onetime/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= vidar@karlsen.tech
+COMMENT= Encryption program that uses the one-time pad algorithm
+
+LICENSE= PD
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USES= python:2 shebangfix
+SHEBANG_FILES= onetime
+
+NO_ARCH= yes
+
+PLIST_FILES= bin/onetime
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/onetime ${STAGEDIR}${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/security/py-onetime/distinfo b/security/py-onetime/distinfo
new file mode 100644
index 000000000000..f6f0a4b7dbcf
--- /dev/null
+++ b/security/py-onetime/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1489349430
+SHA256 (onetime-1.81.tar.gz) = 36a83a83ac9f4018278bf48e868af00f3326b853229fae7e43b38d167e628348
+SIZE (onetime-1.81.tar.gz) = 1810196
diff --git a/security/py-onetime/pkg-descr b/security/py-onetime/pkg-descr
new file mode 100644
index 000000000000..212c8e813b52
--- /dev/null
+++ b/security/py-onetime/pkg-descr
@@ -0,0 +1,5 @@
+OneTime is an open source encryption program that uses the one-time pad
+algorithm to allow two parties to communicate privately. It has features to
+assist with pad management, and comes with built-in help.
+
+WWW: http://www.red-bean.com/onetime/