aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2016-04-27 16:36:41 +0000
committerSteve Wills <swills@FreeBSD.org>2016-04-27 16:36:41 +0000
commitb3e8fe8d85d1f32b6b8813589ed8637a8accb185 (patch)
tree146c1b1aad08357a95df3348dea477d956cd3816 /security
parentfa3799f9e7a9b9095ece07d487dbe794356ec5ba (diff)
Notes
Diffstat (limited to 'security')
-rw-r--r--security/ruby-hmac/Makefile3
-rw-r--r--security/rubygem-attr_encrypted/Makefile3
-rw-r--r--security/rubygem-bcrypt-ruby/Makefile3
-rw-r--r--security/rubygem-bcrypt/Makefile3
-rw-r--r--security/rubygem-devise-two-factor/Makefile3
-rw-r--r--security/rubygem-doorkeeper/Makefile3
-rw-r--r--security/rubygem-encryptor/Makefile3
-rw-r--r--security/rubygem-ezcrypto/Makefile3
-rw-r--r--security/rubygem-gpgr/Makefile3
-rw-r--r--security/rubygem-gssapi/Makefile3
-rw-r--r--security/rubygem-jugyo-twitter_oauth/Makefile3
-rw-r--r--security/rubygem-metasploit-concern/Makefile3
-rw-r--r--security/rubygem-metasploit-credential/Makefile3
-rw-r--r--security/rubygem-metasploit-model/Makefile3
-rw-r--r--security/rubygem-metasploit-payloads/Makefile3
-rw-r--r--security/rubygem-metasploit_data_models/Makefile3
-rw-r--r--security/rubygem-net-scp/Makefile3
-rw-r--r--security/rubygem-net-sftp/Makefile3
-rw-r--r--security/rubygem-net-ssh-gateway/Makefile3
-rw-r--r--security/rubygem-net-ssh-multi/Makefile3
-rw-r--r--security/rubygem-net-ssh/Makefile4
-rw-r--r--security/rubygem-nmap-parser/Makefile3
-rw-r--r--security/rubygem-omniauth-bitbucket/Makefile3
-rw-r--r--security/rubygem-omniauth-cas3/Makefile3
-rw-r--r--security/rubygem-omniauth-gitlab/Makefile3
-rw-r--r--security/rubygem-omniauth-multipassword/Makefile3
-rw-r--r--security/rubygem-omniauth-saml/Makefile3
-rw-r--r--security/rubygem-omniauth-shibboleth/Makefile3
-rw-r--r--security/rubygem-omniauth/Makefile3
-rw-r--r--security/rubygem-origami/Makefile4
-rw-r--r--security/rubygem-pyu-ruby-sasl/Makefile3
-rw-r--r--security/rubygem-rack-oauth2/Makefile3
-rw-r--r--security/rubygem-razorback-scriptNugget/Makefile4
-rw-r--r--security/rubygem-recog/Makefile3
-rw-r--r--security/rubygem-roauth/Makefile3
-rw-r--r--security/rubygem-ruby-hmac/Makefile3
-rw-r--r--security/rubygem-ruby-rc4/Makefile3
-rw-r--r--security/rubygem-ruby-saml/Makefile3
-rw-r--r--security/rubygem-scrypt/Makefile3
-rw-r--r--security/rubygem-six/Makefile3
-rw-r--r--security/rubygem-sshkey/Makefile3
-rw-r--r--security/rubygem-sshkit/Makefile3
-rw-r--r--security/rubygem-twitter_oauth/Makefile3
43 files changed, 43 insertions, 89 deletions
diff --git a/security/ruby-hmac/Makefile b/security/ruby-hmac/Makefile
index 3d0dc7b02529..f25a766bf216 100644
--- a/security/ruby-hmac/Makefile
+++ b/security/ruby-hmac/Makefile
@@ -12,8 +12,7 @@ MAINTAINER= ruby@FreeBSD.org
COMMENT= Ruby library which implements the HMAC algorithm
USE_RUBY= yes
-USE_RUBYGEMS= yes
-RUBYGEM_AUTOPLIST= yes
+USES= gem:autoplist
GEM_NAME= ${DISTNAME}
.include <bsd.port.mk>
diff --git a/security/rubygem-attr_encrypted/Makefile b/security/rubygem-attr_encrypted/Makefile
index 3fe44ae09c90..f95120c61122 100644
--- a/security/rubygem-attr_encrypted/Makefile
+++ b/security/rubygem-attr_encrypted/Makefile
@@ -16,7 +16,6 @@ RUN_DEPENDS= rubygem-encryptor>=1.3.0:security/rubygem-encryptor
NO_ARCH= yes
USE_RUBY= yes
-USE_RUBYGEMS= yes
-RUBYGEM_AUTOPLIST=yes
+USES= gem:autoplist
.include <bsd.port.mk>
diff --git a/security/rubygem-bcrypt-ruby/Makefile b/security/rubygem-bcrypt-ruby/Makefile
index e21a6ee1f5ff..8c205f17b474 100644
--- a/security/rubygem-bcrypt-ruby/Makefile
+++ b/security/rubygem-bcrypt-ruby/Makefile
@@ -16,7 +16,6 @@ RUN_DEPENDS= rubygem-bcrypt>=3.1.3:security/rubygem-bcrypt
NO_ARCH= yes
USE_RUBY= yes
-USE_RUBYGEMS= yes
-RUBYGEM_AUTOPLIST= yes
+USES= gem:autoplist
.include <bsd.port.mk>
diff --git a/security/rubygem-bcrypt/Makefile b/security/rubygem-bcrypt/Makefile
index 8bc1125100db..158e141ead21 100644
--- a/security/rubygem-bcrypt/Makefile
+++ b/security/rubygem-bcrypt/Makefile
@@ -13,7 +13,6 @@ LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/COPYING
USE_RUBY= yes
-USE_RUBYGEMS= yes
-RUBYGEM_AUTOPLIST= yes
+USES= gem:autoplist
.include <bsd.port.mk>
diff --git a/security/rubygem-devise-two-factor/Makefile b/security/rubygem-devise-two-factor/Makefile
index 89c72ad83d5f..a2fb31357732 100644
--- a/security/rubygem-devise-two-factor/Makefile
+++ b/security/rubygem-devise-two-factor/Makefile
@@ -20,7 +20,6 @@ RUN_DEPENDS= rubygem-activesupport4>=0:devel/rubygem-activesupport4 \
NO_ARCH= yes
USE_RUBY= yes
-USE_RUBYGEMS= yes
-RUBYGEM_AUTOPLIST= yes
+USES= gem:autoplist
.include <bsd.port.mk>
diff --git a/security/rubygem-doorkeeper/Makefile b/security/rubygem-doorkeeper/Makefile
index 8b2da8ee4c7c..5cee9876b582 100644
--- a/security/rubygem-doorkeeper/Makefile
+++ b/security/rubygem-doorkeeper/Makefile
@@ -24,7 +24,6 @@ RAILTIES4_RUN_DEPENDS= rubygem-railties4>=4.0:www/rubygem-railties4
NO_ARCH= yes
USE_RUBY= yes
-USE_RUBYGEMS= yes
-RUBYGEM_AUTOPLIST= yes
+USES= gem:autoplist
.include <bsd.port.mk>
diff --git a/security/rubygem-encryptor/Makefile b/security/rubygem-encryptor/Makefile
index 58e1532c52b2..09c1b9f3ae86 100644
--- a/security/rubygem-encryptor/Makefile
+++ b/security/rubygem-encryptor/Makefile
@@ -14,7 +14,6 @@ LICENSE_FILE= ${WRKSRC}/MIT-LICENSE
NO_ARCH= yes
USE_RUBY= yes
-USE_RUBYGEMS= yes
-RUBYGEM_AUTOPLIST=yes
+USES= gem:autoplist
.include <bsd.port.mk>
diff --git a/security/rubygem-ezcrypto/Makefile b/security/rubygem-ezcrypto/Makefile
index b70ad0987d33..3186dbb6fff2 100644
--- a/security/rubygem-ezcrypto/Makefile
+++ b/security/rubygem-ezcrypto/Makefile
@@ -12,7 +12,6 @@ COMMENT= Wrapper for the poorly documented OpenSSL ruby library
NO_ARCH= yes
USE_RUBY= yes
-USE_RUBYGEMS= yes
-RUBYGEM_AUTOPLIST= yes
+USES= gem:autoplist
.include <bsd.port.mk>
diff --git a/security/rubygem-gpgr/Makefile b/security/rubygem-gpgr/Makefile
index f61fb7fc1e47..f9d346960441 100644
--- a/security/rubygem-gpgr/Makefile
+++ b/security/rubygem-gpgr/Makefile
@@ -17,7 +17,6 @@ RUN_DEPENDS= gpg:security/gnupg
NO_ARCH= yes
USE_RUBY= yes
-USE_RUBYGEMS= yes
-RUBYGEM_AUTOPLIST= yes
+USES= gem:autoplist
.include <bsd.port.mk>
diff --git a/security/rubygem-gssapi/Makefile b/security/rubygem-gssapi/Makefile
index 62d56d38c472..0817e4d2259f 100644
--- a/security/rubygem-gssapi/Makefile
+++ b/security/rubygem-gssapi/Makefile
@@ -16,7 +16,6 @@ RUN_DEPENDS= rubygem-ffi>=1.9.3:devel/rubygem-ffi
NO_ARCH= yes
USE_RUBY= yes
-USE_RUBYGEMS= yes
-RUBYGEM_AUTOPLIST= yes
+USES= gem:autoplist
.include <bsd.port.mk>
diff --git a/security/rubygem-jugyo-twitter_oauth/Makefile b/security/rubygem-jugyo-twitter_oauth/Makefile
index 1b9fc7203cf9..11bc325e4f36 100644
--- a/security/rubygem-jugyo-twitter_oauth/Makefile
+++ b/security/rubygem-jugyo-twitter_oauth/Makefile
@@ -18,8 +18,7 @@ RUN_DEPENDS= rubygem-json>=1.1.9:devel/rubygem-json \
NO_ARCH= yes
USE_RUBY= yes
-USE_RUBYGEMS= yes
GEM_NAME= ${PORTNAME}-${DISTVERSION}
-RUBYGEM_AUTOPLIST= yes
+USES= gem:autoplist
.include <bsd.port.mk>
diff --git a/security/rubygem-metasploit-concern/Makefile b/security/rubygem-metasploit-concern/Makefile
index 8022ee037c66..3d851df30d0c 100644
--- a/security/rubygem-metasploit-concern/Makefile
+++ b/security/rubygem-metasploit-concern/Makefile
@@ -17,8 +17,7 @@ RUN_DEPENDS= rubygem-activesupport>=3.0.0:devel/rubygem-activesupport \
NO_ARCH= yes
USE_RUBY= yes
-USE_RUBYGEMS= yes
-RUBYGEM_AUTOPLIST= yes
+USES= gem:autoplist
PORTSCOUT= ignore:1
diff --git a/security/rubygem-metasploit-credential/Makefile b/security/rubygem-metasploit-credential/Makefile
index e6d92b2c41a1..91153d7a0f64 100644
--- a/security/rubygem-metasploit-credential/Makefile
+++ b/security/rubygem-metasploit-credential/Makefile
@@ -21,8 +21,7 @@ RUN_DEPENDS= rubygem-metasploit-concern>=0.4.0:security/rubygem-metasploit-conce
NO_ARCH= yes
USE_RUBY= yes
-USE_RUBYGEMS= yes
-RUBYGEM_AUTOPLIST= yes
+USES= gem:autoplist
PORTSCOUT= ignore:1
diff --git a/security/rubygem-metasploit-model/Makefile b/security/rubygem-metasploit-model/Makefile
index 68c2aafa178c..a0bc974ccb07 100644
--- a/security/rubygem-metasploit-model/Makefile
+++ b/security/rubygem-metasploit-model/Makefile
@@ -17,8 +17,7 @@ RUN_DEPENDS= rubygem-activesupport>=0:devel/rubygem-activesupport \
NO_ARCH= yes
USE_RUBY= yes
-USE_RUBYGEMS= yes
-RUBYGEM_AUTOPLIST= yes
+USES= gem:autoplist
PORTSCOUT= ignore:1
diff --git a/security/rubygem-metasploit-payloads/Makefile b/security/rubygem-metasploit-payloads/Makefile
index a7da3d3aa9d3..5d19242fbf07 100644
--- a/security/rubygem-metasploit-payloads/Makefile
+++ b/security/rubygem-metasploit-payloads/Makefile
@@ -12,8 +12,7 @@ LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
USE_RUBY= yes
-USE_RUBYGEMS= yes
-RUBYGEM_AUTOPLIST= yes
+USES= gem:autoplist
PORTSCOUT= ignore:1
diff --git a/security/rubygem-metasploit_data_models/Makefile b/security/rubygem-metasploit_data_models/Makefile
index a160231614ac..e4c75f91a544 100644
--- a/security/rubygem-metasploit_data_models/Makefile
+++ b/security/rubygem-metasploit_data_models/Makefile
@@ -23,8 +23,7 @@ RUN_DEPENDS= rubygem-activerecord>=3.2.13:databases/rubygem-activerecord \
NO_ARCH= yes
USE_RUBY= yes
-USE_RUBYGEMS= yes
-RUBYGEM_AUTOPLIST= yes
+USES= gem:autoplist
PLIST_FILES= bin/mdm_console
PORTSCOUT= ignore:1
diff --git a/security/rubygem-net-scp/Makefile b/security/rubygem-net-scp/Makefile
index 702413d34ad5..f13ae2097121 100644
--- a/security/rubygem-net-scp/Makefile
+++ b/security/rubygem-net-scp/Makefile
@@ -14,7 +14,6 @@ RUN_DEPENDS= rubygem-net-ssh>=2.6.5:security/rubygem-net-ssh
NO_ARCH= yes
USE_RUBY= yes
-USE_RUBYGEMS= yes
-RUBYGEM_AUTOPLIST= yes
+USES= gem:autoplist
.include <bsd.port.mk>
diff --git a/security/rubygem-net-sftp/Makefile b/security/rubygem-net-sftp/Makefile
index f726097ac03f..9ed347efd453 100644
--- a/security/rubygem-net-sftp/Makefile
+++ b/security/rubygem-net-sftp/Makefile
@@ -15,7 +15,6 @@ RUN_DEPENDS= rubygem-net-ssh>=2.6.5:security/rubygem-net-ssh
NO_ARCH= yes
USE_RUBY= yes
-USE_RUBYGEMS= yes
-RUBYGEM_AUTOPLIST= yes
+USES= gem:autoplist
.include <bsd.port.mk>
diff --git a/security/rubygem-net-ssh-gateway/Makefile b/security/rubygem-net-ssh-gateway/Makefile
index d4718cb25769..76008ec52752 100644
--- a/security/rubygem-net-ssh-gateway/Makefile
+++ b/security/rubygem-net-ssh-gateway/Makefile
@@ -14,7 +14,6 @@ RUN_DEPENDS= rubygem-net-ssh>=2.6.5:security/rubygem-net-ssh
NO_ARCH= yes
USE_RUBY= yes
-USE_RUBYGEMS= yes
-RUBYGEM_AUTOPLIST= yes
+USES= gem:autoplist
.include <bsd.port.mk>
diff --git a/security/rubygem-net-ssh-multi/Makefile b/security/rubygem-net-ssh-multi/Makefile
index 8206dd38d324..4464ddb3d978 100644
--- a/security/rubygem-net-ssh-multi/Makefile
+++ b/security/rubygem-net-ssh-multi/Makefile
@@ -17,7 +17,6 @@ RUN_DEPENDS= rubygem-net-ssh>=2.6.5:security/rubygem-net-ssh \
NO_ARCH= yes
USE_RUBY= yes
-USE_RUBYGEMS= yes
-RUBYGEM_AUTOPLIST= yes
+USES= gem:autoplist
.include <bsd.port.mk>
diff --git a/security/rubygem-net-ssh/Makefile b/security/rubygem-net-ssh/Makefile
index ab0239d259dd..e2f5f22d972b 100644
--- a/security/rubygem-net-ssh/Makefile
+++ b/security/rubygem-net-ssh/Makefile
@@ -19,9 +19,7 @@ PROMPT_PASSPHRASES_DESC= Prompt for passphrases on keys
NO_ARCH= yes
USE_RUBY= yes
-USE_RUBYGEMS= yes
-RUBYGEM_AUTOPLIST= yes
-USES= shebangfix
+USES= gem:autoplist shebangfix
SHEBANG_FILES= support/ssh_tunnel_bug.rb
PROMPT_PASSPHRASES_RUN_DEPENDS= rubygem-ruby-termios>=0:comms/rubygem-ruby-termios
diff --git a/security/rubygem-nmap-parser/Makefile b/security/rubygem-nmap-parser/Makefile
index 157c22ff391d..13220e740b85 100644
--- a/security/rubygem-nmap-parser/Makefile
+++ b/security/rubygem-nmap-parser/Makefile
@@ -16,7 +16,6 @@ RUN_DEPENDS= nmap:security/nmap
NO_ARCH= yes
USE_RUBY= yes
-USE_RUBYGEMS= yes
-RUBYGEM_AUTOPLIST= yes
+USES= gem:autoplist
.include <bsd.port.mk>
diff --git a/security/rubygem-omniauth-bitbucket/Makefile b/security/rubygem-omniauth-bitbucket/Makefile
index 6575a2b3501f..36b1e98d99bb 100644
--- a/security/rubygem-omniauth-bitbucket/Makefile
+++ b/security/rubygem-omniauth-bitbucket/Makefile
@@ -16,7 +16,6 @@ RUN_DEPENDS= rubygem-multi_json>=1.7:devel/rubygem-multi_json \
NO_ARCH= yes
USE_RUBY= yes
-USE_RUBYGEMS= yes
-RUBYGEM_AUTOPLIST= yes
+USES= gem:autoplist
.include <bsd.port.mk>
diff --git a/security/rubygem-omniauth-cas3/Makefile b/security/rubygem-omniauth-cas3/Makefile
index 9d3db1bce7e2..a94a5f290789 100644
--- a/security/rubygem-omniauth-cas3/Makefile
+++ b/security/rubygem-omniauth-cas3/Makefile
@@ -18,7 +18,6 @@ RUN_DEPENDS= rubygem-addressable>=2.3:www/rubygem-addressable \
NO_ARCH= yes
USE_RUBY= yes
-USE_RUBYGEMS= yes
-RUBYGEM_AUTOPLIST= yes
+USES= gem:autoplist
.include <bsd.port.mk>
diff --git a/security/rubygem-omniauth-gitlab/Makefile b/security/rubygem-omniauth-gitlab/Makefile
index 51882c45998c..75352d7ef56c 100644
--- a/security/rubygem-omniauth-gitlab/Makefile
+++ b/security/rubygem-omniauth-gitlab/Makefile
@@ -16,7 +16,6 @@ RUN_DEPENDS= rubygem-omniauth>=1.0:security/rubygem-omniauth \
NO_ARCH= yes
USE_RUBY= yes
-USE_RUBYGEMS= yes
-RUBYGEM_AUTOPLIST= yes
+USES= gem:autoplist
.include <bsd.port.mk>
diff --git a/security/rubygem-omniauth-multipassword/Makefile b/security/rubygem-omniauth-multipassword/Makefile
index 60f73fb96687..b7679570313e 100644
--- a/security/rubygem-omniauth-multipassword/Makefile
+++ b/security/rubygem-omniauth-multipassword/Makefile
@@ -16,7 +16,6 @@ RUN_DEPENDS= rubygem-omniauth>=1.0:security/rubygem-omniauth
NO_ARCH= yes
USE_RUBY= yes
-USE_RUBYGEMS= yes
-RUBYGEM_AUTOPLIST= yes
+USES= gem:autoplist
.include <bsd.port.mk>
diff --git a/security/rubygem-omniauth-saml/Makefile b/security/rubygem-omniauth-saml/Makefile
index 3d80dcb39dd9..0bcb0557745a 100644
--- a/security/rubygem-omniauth-saml/Makefile
+++ b/security/rubygem-omniauth-saml/Makefile
@@ -17,7 +17,6 @@ RUN_DEPENDS= rubygem-omniauth>=1.3:security/rubygem-omniauth \
NO_ARCH= yes
USE_RUBY= yes
-USE_RUBYGEMS= yes
-RUBYGEM_AUTOPLIST= yes
+USES= gem:autoplist
.include <bsd.port.mk>
diff --git a/security/rubygem-omniauth-shibboleth/Makefile b/security/rubygem-omniauth-shibboleth/Makefile
index 1945fa59e21c..08c3706d405b 100644
--- a/security/rubygem-omniauth-shibboleth/Makefile
+++ b/security/rubygem-omniauth-shibboleth/Makefile
@@ -14,7 +14,6 @@ RUN_DEPENDS= rubygem-omniauth>=1.0:security/rubygem-omniauth
NO_ARCH= yes
USE_RUBY= yes
-USE_RUBYGEMS= yes
-RUBYGEM_AUTOPLIST= yes
+USES= gem:autoplist
.include <bsd.port.mk>
diff --git a/security/rubygem-omniauth/Makefile b/security/rubygem-omniauth/Makefile
index 67020a53b1af..3403a7dd2d47 100644
--- a/security/rubygem-omniauth/Makefile
+++ b/security/rubygem-omniauth/Makefile
@@ -16,7 +16,6 @@ RUN_DEPENDS= rubygem-hashie>=1.2:devel/rubygem-hashie \
NO_ARCH= yes
USE_RUBY= yes
-USE_RUBYGEMS= yes
-RUBYGEM_AUTOPLIST= yes
+USES= gem:autoplist
.include <bsd.port.mk>
diff --git a/security/rubygem-origami/Makefile b/security/rubygem-origami/Makefile
index 1fc6819eb21b..db4bea19f263 100644
--- a/security/rubygem-origami/Makefile
+++ b/security/rubygem-origami/Makefile
@@ -14,9 +14,7 @@ LICENSE= LGPL3
NO_ARCH= yes
USE_RUBY= yes
-USE_RUBYGEMS= yes
-RUBYGEM_AUTOPLIST=yes
-USES= shebangfix
+USES= gem:autoplist shebangfix
SHEBANG_FILES= samples/actions/launch/calc.rb \
samples/actions/launch/winparams.rb \
samples/actions/named/named.rb \
diff --git a/security/rubygem-pyu-ruby-sasl/Makefile b/security/rubygem-pyu-ruby-sasl/Makefile
index 3bb5dbfa3300..0b1debd9dc09 100644
--- a/security/rubygem-pyu-ruby-sasl/Makefile
+++ b/security/rubygem-pyu-ruby-sasl/Makefile
@@ -13,7 +13,6 @@ LICENSE= MIT
NO_ARCH= yes
USE_RUBY= yes
-USE_RUBYGEMS= yes
-RUBYGEM_AUTOPLIST= yes
+USES= gem:autoplist
.include <bsd.port.mk>
diff --git a/security/rubygem-rack-oauth2/Makefile b/security/rubygem-rack-oauth2/Makefile
index 5061be5b17db..31918436fb13 100644
--- a/security/rubygem-rack-oauth2/Makefile
+++ b/security/rubygem-rack-oauth2/Makefile
@@ -19,7 +19,6 @@ RUN_DEPENDS= rubygem-activesupport4>=2.3:devel/rubygem-activesupport4 \
NO_ARCH= yes
USE_RUBY= yes
-USE_RUBYGEMS= yes
-RUBYGEM_AUTOPLIST= yes
+USES= gem:autoplist
.include <bsd.port.mk>
diff --git a/security/rubygem-razorback-scriptNugget/Makefile b/security/rubygem-razorback-scriptNugget/Makefile
index 77d4c1c13505..ad07b894ced0 100644
--- a/security/rubygem-razorback-scriptNugget/Makefile
+++ b/security/rubygem-razorback-scriptNugget/Makefile
@@ -15,9 +15,7 @@ GEM_NAME= ${DISTNAME}
NO_ARCH= yes
USE_RUBY= yes
-USE_RUBYGEMS= yes
-RUBYGEM_AUTOPLIST= yes
-USES= shebangfix
+USES= gem:autoplist shebangfix
SHEBANG_FILES= lib/razorback.rb
.include <bsd.port.mk>
diff --git a/security/rubygem-recog/Makefile b/security/rubygem-recog/Makefile
index 4132a5abe703..dd4035a31f00 100644
--- a/security/rubygem-recog/Makefile
+++ b/security/rubygem-recog/Makefile
@@ -14,8 +14,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= rubygem-nokogiri>=0:textproc/rubygem-nokogiri
USE_RUBY= yes
-USE_RUBYGEMS= yes
-RUBYGEM_AUTOPLIST= yes
+USES= gem:autoplist
PLIST_FILES= bin/recog_export \
bin/recog_match \
bin/recog_verify
diff --git a/security/rubygem-roauth/Makefile b/security/rubygem-roauth/Makefile
index 0602c96d0399..6cac630bd511 100644
--- a/security/rubygem-roauth/Makefile
+++ b/security/rubygem-roauth/Makefile
@@ -12,7 +12,6 @@ COMMENT= Simple Ruby OAuth library
NO_ARCH= yes
USE_RUBY= yes
-USE_RUBYGEMS= yes
-RUBYGEM_AUTOPLIST= yes
+USES= gem:autoplist
.include <bsd.port.mk>
diff --git a/security/rubygem-ruby-hmac/Makefile b/security/rubygem-ruby-hmac/Makefile
index 4552a972ea05..59953d907da8 100644
--- a/security/rubygem-ruby-hmac/Makefile
+++ b/security/rubygem-ruby-hmac/Makefile
@@ -13,7 +13,6 @@ LICENSE= MIT
NO_ARCH= yes
USE_RUBY= yes
-USE_RUBYGEMS= yes
-RUBYGEM_AUTOPLIST= yes
+USES= gem:autoplist
.include <bsd.port.mk>
diff --git a/security/rubygem-ruby-rc4/Makefile b/security/rubygem-ruby-rc4/Makefile
index 1c6ea2f962cd..eda605d244e1 100644
--- a/security/rubygem-ruby-rc4/Makefile
+++ b/security/rubygem-ruby-rc4/Makefile
@@ -14,7 +14,6 @@ LICENSE= MIT
NO_ARCH= yes
USE_RUBY= yes
-USE_RUBYGEMS= yes
-RUBYGEM_AUTOPLIST= yes
+USES= gem:autoplist
.include <bsd.port.mk>
diff --git a/security/rubygem-ruby-saml/Makefile b/security/rubygem-ruby-saml/Makefile
index 220b6009fbf5..cfbaa918a4de 100644
--- a/security/rubygem-ruby-saml/Makefile
+++ b/security/rubygem-ruby-saml/Makefile
@@ -17,7 +17,6 @@ RUN_DEPENDS= rubygem-nokogiri>=1.5.10:textproc/rubygem-nokogiri \
NO_ARCH= yes
USE_RUBY= yes
-USE_RUBYGEMS= yes
-RUBYGEM_AUTOPLIST= yes
+USES= gem:autoplist
.include <bsd.port.mk>
diff --git a/security/rubygem-scrypt/Makefile b/security/rubygem-scrypt/Makefile
index 288ec0baecf1..361a343a16a6 100644
--- a/security/rubygem-scrypt/Makefile
+++ b/security/rubygem-scrypt/Makefile
@@ -17,8 +17,7 @@ RUN_DEPENDS= rubygem-ffi-compiler>=0.0.2:devel/rubygem-ffi-compiler \
NO_ARCH= yes
USE_RUBY= yes
-USE_RUBYGEMS= yes
-RUBYGEM_AUTOPLIST= yes
+USES= gem:autoplist
ONLY_FOR_ARCHS= amd64 i386 ia64
ONLY_FOR_ARCHS_REASON= invokes SSE compiler flags
diff --git a/security/rubygem-six/Makefile b/security/rubygem-six/Makefile
index 95261f788e1e..6bde55430494 100644
--- a/security/rubygem-six/Makefile
+++ b/security/rubygem-six/Makefile
@@ -13,7 +13,6 @@ LICENSE= MIT
NO_ARCH= yes
USE_RUBY= yes
-USE_RUBYGEMS= yes
-RUBYGEM_AUTOPLIST= yes
+USES= gem:autoplist
.include <bsd.port.mk>
diff --git a/security/rubygem-sshkey/Makefile b/security/rubygem-sshkey/Makefile
index b882e7ddf3fa..6d3bce08f479 100644
--- a/security/rubygem-sshkey/Makefile
+++ b/security/rubygem-sshkey/Makefile
@@ -14,7 +14,6 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
NO_ARCH= yes
USE_RUBY= yes
-USE_RUBYGEMS= yes
-RUBYGEM_AUTOPLIST= yes
+USES= gem:autoplist
.include <bsd.port.mk>
diff --git a/security/rubygem-sshkit/Makefile b/security/rubygem-sshkit/Makefile
index 2b40ce68d18f..a9d1ff9a5c58 100644
--- a/security/rubygem-sshkit/Makefile
+++ b/security/rubygem-sshkit/Makefile
@@ -17,7 +17,6 @@ RUN_DEPENDS= rubygem-net-scp>=1.1.2:security/rubygem-net-scp \
NO_ARCH= yes
USE_RUBY= yes
-USE_RUBYGEMS= yes
-RUBYGEM_AUTOPLIST= yes
+USES= gem:autoplist
.include <bsd.port.mk>
diff --git a/security/rubygem-twitter_oauth/Makefile b/security/rubygem-twitter_oauth/Makefile
index a35290689d48..0daa69c921bb 100644
--- a/security/rubygem-twitter_oauth/Makefile
+++ b/security/rubygem-twitter_oauth/Makefile
@@ -18,7 +18,6 @@ RUN_DEPENDS= rubygem-json>=1.8.0:devel/rubygem-json \
NO_ARCH= yes
USE_RUBY= yes
-USE_RUBYGEMS= yes
-RUBYGEM_AUTOPLIST= yes
+USES= gem:autoplist
.include <bsd.port.mk>