aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2014-07-29 18:41:15 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2014-07-29 18:41:15 +0000
commitbbc8c4d740872dbe971f6164448e5ba893cb166f (patch)
treec756810defa7862a81134a13cec391bfef55e24e /security
parent7eb500363752ce8dd82189f56d621b11450e92f9 (diff)
downloadports-bbc8c4d740872dbe971f6164448e5ba893cb166f.tar.gz
ports-bbc8c4d740872dbe971f6164448e5ba893cb166f.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/botan110/Makefile3
-rw-r--r--security/courier-authlib/Makefile3
-rw-r--r--security/dirmngr/Makefile3
-rw-r--r--security/gpa/Makefile3
-rw-r--r--security/hotssh/Makefile3
-rw-r--r--security/ike/Makefile3
-rw-r--r--security/john/Makefile3
-rw-r--r--security/libpwquality/Makefile3
-rw-r--r--security/libssh/Makefile3
-rw-r--r--security/nikto/Makefile3
-rw-r--r--security/opencdk/Makefile3
-rw-r--r--security/ophcrack/Makefile3
-rw-r--r--security/revelation/Makefile3
13 files changed, 13 insertions, 26 deletions
diff --git a/security/botan110/Makefile b/security/botan110/Makefile
index 295ecee2d8db..60964dfdf4fd 100644
--- a/security/botan110/Makefile
+++ b/security/botan110/Makefile
@@ -21,8 +21,7 @@ OPTIONS_DEFINE= SSL GMP ECC DOCS
OPTIONS_DEFAULT= SSL GMP ECC
ECC_DESC= ECC support
-USES= compiler gmake
-USE_BZIP2= yes
+USES= compiler gmake tar:bzip2
USE_PYTHON_BUILD= yes
HAS_CONFIGURE= yes
CONFIGURE_SCRIPT= configure.py
diff --git a/security/courier-authlib/Makefile b/security/courier-authlib/Makefile
index eb9d39eaa6a4..59ceb5690022 100644
--- a/security/courier-authlib/Makefile
+++ b/security/courier-authlib/Makefile
@@ -30,9 +30,8 @@ OPTIONS_DEFINE+= GDBM
.else # !defined(PKGNAMESUFFIX)
-USES= iconv gmake perl5
+USES= iconv gmake perl5 tar:bzip2
USE_AUTOTOOLS= libltdl
-USE_BZIP2= yes
GNU_CONFIGURE= yes
USE_SUBMAKE= yes
USE_LDCONFIG= ${PREFIX}/lib/${PORTNAME}
diff --git a/security/dirmngr/Makefile b/security/dirmngr/Makefile
index 78b9a67f1c68..12000e44dc68 100644
--- a/security/dirmngr/Makefile
+++ b/security/dirmngr/Makefile
@@ -19,8 +19,7 @@ LIB_DEPENDS= libassuan.so:${PORTSDIR}/security/libassuan \
libksba.so:${PORTSDIR}/security/libksba \
libpth.so:${PORTSDIR}/devel/pth
-USES= gmake iconv
-USE_BZIP2= yes
+USES= gmake iconv tar:bzip2
USE_OPENLDAP= yes
GNU_CONFIGURE= yes
INFO= dirmngr
diff --git a/security/gpa/Makefile b/security/gpa/Makefile
index 21b06fb302f4..d05cf3ccda60 100644
--- a/security/gpa/Makefile
+++ b/security/gpa/Makefile
@@ -17,8 +17,7 @@ LIB_DEPENDS= libassuan.so:${PORTSDIR}/security/libassuan \
BUILD_DEPENDS= gpgv2:${PORTSDIR}/security/gnupg
RUN_DEPENDS= gpgv2:${PORTSDIR}/security/gnupg
-USES= gmake pkgconfig
-USE_BZIP2= yes
+USES= gmake pkgconfig tar:bzip2
USE_GNOME= gtk20
GNU_CONFIGURE= yes
CONFIGURE_ENV+= GPGKEYS_LDAP="${LOCALBASE}/libexec/gpg2keys_ldap" \
diff --git a/security/hotssh/Makefile b/security/hotssh/Makefile
index ecad26c4183a..49dbcaa798c2 100644
--- a/security/hotssh/Makefile
+++ b/security/hotssh/Makefile
@@ -25,10 +25,9 @@ RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/dbus-python.pc:${PORTSDIR}/devel/py-
${PYTHON_SITELIBDIR}/gtk-2.0/vtemodule.so:${PORTSDIR}/x11-toolkits/py-vte
USE_GNOME= pygtk2 gnomedocutils libxslt glib20
-USES= gettext
+USES= gettext tar:bzip2
USE_PYTHON= yes
INSTALLS_ICONS= yes
-USE_BZIP2= yes
B64DECODE?= /usr/bin/b64decode
BSPATCH?= /usr/bin/bspatch
diff --git a/security/ike/Makefile b/security/ike/Makefile
index accc67ec45e8..931503176a16 100644
--- a/security/ike/Makefile
+++ b/security/ike/Makefile
@@ -15,9 +15,8 @@ COMMENT= Shrew Soft IKE daemon and client tools
ONLY_FOR_ARCHS= i386 amd64
USE_RC_SUBR= iked
-USES= bison cmake
+USES= bison cmake tar:bzip2
USE_OPENSSL= yes
-USE_BZIP2= yes
USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
diff --git a/security/john/Makefile b/security/john/Makefile
index ecbccc604b6f..6c7529275daa 100644
--- a/security/john/Makefile
+++ b/security/john/Makefile
@@ -14,8 +14,7 @@ COMMENT= Featureful Unix password cracker
LICENSE= GPLv2
-USES= gmake shebangfix
-USE_BZIP2= yes
+USES= gmake shebangfix tar:bzip2
SHEBANG_FILES= run/*.pl
BUILD_WRKSRC= ${WRKDIR}/${DISTNAME}/src
diff --git a/security/libpwquality/Makefile b/security/libpwquality/Makefile
index ee7f9367b539..dd188d7112a5 100644
--- a/security/libpwquality/Makefile
+++ b/security/libpwquality/Makefile
@@ -11,8 +11,7 @@ COMMENT= Library for generating random passwords and quality checking
LIB_DEPENDS= libcrack.so:${PORTSDIR}/security/cracklib
-USES= gettext gmake libtool:keepla pathfix
-USE_BZIP2= yes
+USES= gettext gmake libtool:keepla pathfix tar:bzip2
USE_GNOME= intltool
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
diff --git a/security/libssh/Makefile b/security/libssh/Makefile
index 4048be3fa076..d8cb628b4f0a 100644
--- a/security/libssh/Makefile
+++ b/security/libssh/Makefile
@@ -16,8 +16,7 @@ OPTIONS_RADIO_CRYPTO= GCRYPT OPENSSL
OPTIONS_DEFAULT= OPENSSL STATIC
OPTIONS_SUB= yes
-USE_BZIP2= yes
-USES= cmake
+USES= cmake tar:bzip2
CMAKE_SOURCE_PATH= ${WRKSRC}
CONFIGURE_WRKSRC= ${CMAKE_SOURCE_PATH}/build
BUILD_WRKSRC= ${CONFIGURE_WRKSRC}
diff --git a/security/nikto/Makefile b/security/nikto/Makefile
index faf14796177d..b4cb8029e0d0 100644
--- a/security/nikto/Makefile
+++ b/security/nikto/Makefile
@@ -21,8 +21,7 @@ SSLEAY_RUN_DEPENDS= p5-Net-SSLeay>0:${PORTSDIR}/security/p5-Net-SSLeay
NO_BUILD= yes
-USE_BZIP2= yes
-USES= perl5 shebangfix
+USES= perl5 shebangfix tar:bzip2
USE_PERL5= run
SHEBANG_FILES= nikto.pl
diff --git a/security/opencdk/Makefile b/security/opencdk/Makefile
index ee1b7ca4c23b..e9b1785be8dd 100644
--- a/security/opencdk/Makefile
+++ b/security/opencdk/Makefile
@@ -17,8 +17,7 @@ OPTIONS_DEFINE= DOCS
LIB_DEPENDS= libgcrypt.so:${PORTSDIR}/security/libgcrypt
GNU_CONFIGURE= yes
-USES= libtool:keepla pathfix pkgconfig
-USE_BZIP2= yes
+USES= libtool:keepla pathfix pkgconfig tar:bzip2
USE_LDCONFIG= yes
CONFIGURE_ARGS= --with-libgcrypt-prefix=${LOCALBASE}
diff --git a/security/ophcrack/Makefile b/security/ophcrack/Makefile
index 56261e5d5cdc..27fcd4282403 100644
--- a/security/ophcrack/Makefile
+++ b/security/ophcrack/Makefile
@@ -14,8 +14,7 @@ LICENSE_COMB= multi
LIB_DEPENDS= libexpat.so:${PORTSDIR}/textproc/expat2
-USES= gmake
-USE_BZIP2= yes
+USES= gmake tar:bzip2
GNU_CONFIGURE= yes
USE_OPENSSL= yes
diff --git a/security/revelation/Makefile b/security/revelation/Makefile
index 8a00dfa1e88c..96e8002b2d38 100644
--- a/security/revelation/Makefile
+++ b/security/revelation/Makefile
@@ -18,8 +18,7 @@ LIB_DEPENDS= libcrack.so:${PORTSDIR}/security/cracklib
RUN_DEPENDS:= ${BULID_DEPENDS} \
${PYTHON_PKGNAMEPREFIX}cracklib>0:${PORTSDIR}/security/py-cracklib
-USE_BZIP2= yes
-USES= desktop-file-utils gettext gmake pathfix pkgconfig \
+USES= desktop-file-utils gettext gmake pathfix pkgconfig \ tar:bzip2
shared-mime-info shebangfix
SHEBANG_FILES= src/revelation.py
USE_GNOME= gnomeprefix pygnome2