aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2016-05-23 20:35:01 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2016-05-23 20:35:01 +0000
commitc86e9d97241f251304781abec881b7b5a934f12a (patch)
tree6a64949cd1d37fc2302e761cd239d30738f2b760 /security
parent1b68d5eb0ccf36adc2ddc3545e89811c794dec49 (diff)
Notes
Diffstat (limited to 'security')
-rw-r--r--security/afl/Makefile2
-rw-r--r--security/amavisd-new/Makefile2
-rw-r--r--security/arm/Makefile2
-rw-r--r--security/clamav/Makefile2
-rw-r--r--security/heimdal/Makefile2
-rw-r--r--security/snort/Makefile2
-rw-r--r--security/sssd/Makefile1
7 files changed, 6 insertions, 7 deletions
diff --git a/security/afl/Makefile b/security/afl/Makefile
index a18e4b92dcab..21824a36548a 100644
--- a/security/afl/Makefile
+++ b/security/afl/Makefile
@@ -18,7 +18,7 @@ OPTIONS_DEFINE= DEBUG DOCS MINIMIZE_CORPUS LLVM TEST_INSTRUMENTATION
MINIMIZE_CORPUS_DESC= Install afl-cmin. Adds bash dependency
TEST_INSTRUMENTATION_DESC= Execute tests (expected to fail in jails)
LLVM_DESC= LLVM-based instrumentation (broken on 9.x)
-OPTIONS_DEFAULT= DOCS LLVM MINIMIZE_CORPUS
+OPTIONS_DEFAULT= LLVM MINIMIZE_CORPUS
OPTIONS_SUB= yes
diff --git a/security/amavisd-new/Makefile b/security/amavisd-new/Makefile
index 0eeb426ea193..d1c3042164a9 100644
--- a/security/amavisd-new/Makefile
+++ b/security/amavisd-new/Makefile
@@ -45,7 +45,7 @@ DAEMON?= /usr/sbin/daemon -p
OPTIONS_DEFINE= IPV6 BDB SNMP SQLITE MYSQL PGSQL LDAP SASL SPAMASSASSIN P0F ALTERMIME \
FILE RAR UNRAR ARJ UNARJ LHA ARC NOMARCH CAB RPM ZOO UNZOO LZOP FREEZE \
P7ZIP MSWORD TNEF DOCS
-OPTIONS_DEFAULT= IPV6 BDB SPAMASSASSIN FILE UNRAR ARJ LHA ARC CAB RPM ZOO LZOP \
+OPTIONS_DEFAULT= BDB SPAMASSASSIN FILE UNRAR ARJ LHA ARC CAB RPM ZOO LZOP \
FREEZE P7ZIP MSWORD
BDB_DESC= Use BerkeleyDB for nanny/cache/snmp
SNMP_DESC= Install amavisd snmp subagent
diff --git a/security/arm/Makefile b/security/arm/Makefile
index 45c46a421548..6da8ecdb6a9e 100644
--- a/security/arm/Makefile
+++ b/security/arm/Makefile
@@ -25,7 +25,7 @@ PORTDOCS= armrc.sample
OPTIONS_DEFINE= TOR \
DOCS
-OPTIONS_DEFAULT=TOR DOCS
+OPTIONS_DEFAULT=TOR
TOR_DESC= Enable local tor support
diff --git a/security/clamav/Makefile b/security/clamav/Makefile
index 22bc89ff26f2..696d895a16da 100644
--- a/security/clamav/Makefile
+++ b/security/clamav/Makefile
@@ -29,7 +29,7 @@ STDERR_DESC= Print logs to stderr instead of stdout
EXPERIMENTAL_DESC= Build experimental code
DMG_XAR_DESC= Enable DMG and XAR archives support
-OPTIONS_DEFAULT= ARC ARJ LHA UNZOO UNRAR LLVM DOCS IPV6 DMG_XAR \
+OPTIONS_DEFAULT= ARC ARJ LHA UNZOO UNRAR LLVM DMG_XAR \
JSON PCRE
ARC_RUN_DEPENDS= arc:archivers/arc
diff --git a/security/heimdal/Makefile b/security/heimdal/Makefile
index b2f3cf6c400b..ac97261c78df 100644
--- a/security/heimdal/Makefile
+++ b/security/heimdal/Makefile
@@ -50,7 +50,7 @@ INFO= heimdal hx509
MAKE_JOBS_UNSAFE= yes
OPTIONS_DEFINE= IPV6 BDB SQLITE LDAP PKINIT DIGEST KX509 CRACKLIB X11
-OPTIONS_DEFAULT=IPV6 BDB PKINIT DIGEST KX509
+OPTIONS_DEFAULT= BDB PKINIT DIGEST KX509
OPTIONS_SUB= yes
IPV6_CONFIGURE_WITH= ipv6
diff --git a/security/snort/Makefile b/security/snort/Makefile
index d623767f5a0c..68462e7768bf 100644
--- a/security/snort/Makefile
+++ b/security/snort/Makefile
@@ -30,7 +30,7 @@ OPTIONS_GROUP= ADDONS DEV
OPTIONS_GROUP_ADDONS= BARNYARD PULLEDPORK
OPTIONS_GROUP_DEV= DBGSNORT
OPTIONS_SUB= yes
-OPTIONS_DEFAULT= IPV6 GRE NORMALIZER BARNYARD \
+OPTIONS_DEFAULT= GRE NORMALIZER BARNYARD \
PERFPROFILE SOURCEFIRE PULLEDPORK
GRE_DESC= GRE support
diff --git a/security/sssd/Makefile b/security/sssd/Makefile
index 18c69feb25e5..c191549617dc 100644
--- a/security/sssd/Makefile
+++ b/security/sssd/Makefile
@@ -67,7 +67,6 @@ USE_RC_SUBR= ${PORTNAME}
PORTDATA= *
OPTIONS_DEFINE= DOCS SMB
-OPTIONS_DEFAULT= DOCS
OPTIONS_SUB= yes
SMB_DESC= Install IPA and AD providers (requires Samba4)