aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2008-05-10 07:40:22 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2008-05-10 07:40:22 +0000
commitd0e1dc3fbd926ab2519ca4d3774e997bb427ec57 (patch)
tree974c9cc9dbb1188ebcafc02c16cb83325cfb7b7e /security
parentd3265ce5d68fbcca6e63172bf8f8e37188ef89f7 (diff)
downloadports-d0e1dc3fbd926ab2519ca4d3774e997bb427ec57.tar.gz
ports-d0e1dc3fbd926ab2519ca4d3774e997bb427ec57.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/klamav/Makefile6
-rw-r--r--security/klamav/distinfo6
-rw-r--r--security/klamav/files/patch-clamav-0.9391
-rw-r--r--security/klamav/files/patch-po35
-rw-r--r--security/klamav/pkg-plist1
5 files changed, 29 insertions, 110 deletions
diff --git a/security/klamav/Makefile b/security/klamav/Makefile
index 3f077a8b7127..1f6e3835aaa5 100644
--- a/security/klamav/Makefile
+++ b/security/klamav/Makefile
@@ -6,11 +6,9 @@
#
PORTNAME= klamav
-PORTVERSION= 0.42
-PORTREVISION= 3
+PORTVERSION= 0.43
CATEGORIES= security
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= klamav
+MASTER_SITES= SF
DISTNAME= ${PORTNAME}-${PORTVERSION}-source
MAINTAINER= anderson@cnpm.embrapa.br
diff --git a/security/klamav/distinfo b/security/klamav/distinfo
index 216ae7c0a6fa..186d29f5ce29 100644
--- a/security/klamav/distinfo
+++ b/security/klamav/distinfo
@@ -1,3 +1,3 @@
-SIZE (klamav-0.42-source.tar.gz) = 1920149
-MD5 (klamav-0.42-source.tar.gz) = 4cf95f5e9d8a215f2cd2c312612811f6
-SHA256 (klamav-0.42-source.tar.gz) = 3dd03c802a24d0fe033bdd7f27ec77b2fd5c9aedf18ebec30cee801e36966ca7
+SIZE (klamav-0.43-source.tar.gz) = 2029200
+MD5 (klamav-0.43-source.tar.gz) = 1422e0649626f4ea20b46fc0b0bcf1d7
+SHA256 (klamav-0.43-source.tar.gz) = de92736c18b47da69ffef17747f16c105d8772b2369026f82c2cec000c00a13e
diff --git a/security/klamav/files/patch-clamav-0.93 b/security/klamav/files/patch-clamav-0.93
deleted file mode 100644
index 2fbbd67f9c0a..000000000000
--- a/security/klamav/files/patch-clamav-0.93
+++ /dev/null
@@ -1,91 +0,0 @@
-diff -ur src/klammail/cfgparser.c klamav-0.42-clamav093/src/klammail/cfgparser.c
---- src/klammail/cfgparser.c 2008-01-06 17:00:35.000000000 +0100
-+++ klamav-0.42-clamav093/src/klammail/cfgparser.c 2008-03-28 07:00:26.000000000 +0100
-@@ -63,10 +63,10 @@
- {"ScanOLE2", OPT_NOARG},
- {"ScanArchive", OPT_NOARG},
- {"ScanRAR", OPT_NOARG},
-- {"ArchiveMaxFileSize", OPT_COMPSIZE},
-- {"ArchiveMaxRecursion", OPT_NUM},
-- {"ArchiveMaxFiles", OPT_NUM},
-- {"ArchiveMaxCompressionRatio", OPT_NUM},
-+ {"MaxScanSize", OPT_COMPSIZE},
-+ {"MaxFileSize", OPT_COMPSIZE},
-+ {"MaxRecursion", OPT_NUM},
-+ {"MaxFiles", OPT_NUM},
- {"ArchiveLimitMemoryUsage", OPT_NOARG},
- {"ArchiveBlockEncrypted", OPT_NOARG},
- {"DataDirectory", OPT_STR}, /* obsolete */
-diff -ur src/klammail/clamdmail.c klamav-0.42-clamav093/src/klammail/clamdmail.c
---- src/klammail/clamdmail.c 2008-01-06 17:00:35.000000000 +0100
-+++ klamav-0.42-clamav093/src/klammail/clamdmail.c 2008-03-28 07:10:31.000000000 +0100
-@@ -151,14 +151,14 @@
- while((bytes = read(0, buff, BUFFSIZE)) > 0) {
-
- if(write(fd, buff, bytes) != bytes) {
-- cli_dbgmsg("clamdmail -> Can't write() file.\n");
-+ printf("clamdmail -> Can't write() file.\n");
- close(fd);
- return CL_EMEM;
- }
- }
-
- if(fsync(fd) == -1) {
-- cli_dbgmsg("fsync() failed for descriptor %d\n", fd);
-+ printf("fsync() failed for descriptor %d\n", fd);
- close(fd);
- return CL_EFSYNC;
- }
-@@ -202,13 +202,12 @@
- /* set up archive limits */
- memset(&limits, 0, sizeof(struct cl_limits));
- limits.maxfiles = 1000; /* max files */
-- limits.maxfilesize = 10 * 1048576; /* maximum size of archived/compressed
-+ limits.maxfilesize = 10 * 1048576; /* maximum size of
- * file (files exceeding this limit
- * will be ignored)
- */
-- limits.maxreclevel = 5; /* maximum recursion level for archives */
-- limits.maxmailrec = 64; /* maximum recursion level for mail files */
-- limits.maxratio = 200; /* maximum compression ratio */
-+ limits.maxreclevel = 5; /* maximum recursion level for archives and mail files */
-+ limits.maxscansize = 200 * limits.maxfilesize; /* maximum compression ratio */
-
- ret = cl_scandesc(fd, &virname, &size, engine, &limits, CL_SCAN_STDOPT | CL_ARCHIVE | CL_MAIL | CL_OLE2 | CL_SCAN_HTML);
-
-@@ -368,7 +367,7 @@
- while((bytes = read(fd, buff, BUFFSIZE)) > 0) {
-
- if(write(1, buff, bytes) != bytes) {
-- cli_dbgmsg("clamdmail -> Can't write() file.\n");
-+ printf("clamdmail -> Can't write() file.\n");
- close(fd);
- return CL_EMEM;
- }
-diff -ur src/scanviewer.cpp klamav-0.42-clamav093/src/scanviewer.cpp
---- src/scanviewer.cpp 2008-01-06 17:00:35.000000000 +0100
-+++ klamav-0.42-clamav093/src/scanviewer.cpp 2008-03-28 07:00:26.000000000 +0100
-@@ -393,18 +393,18 @@
- options += "--max-files=" + QString("%1").arg(KlamavConfig::noFilesToExtract()) + " ";
-
- if (KlamavConfig::mBsToExtract() > 0)
-- options += "--max-space=" + QString("%1").arg(KlamavConfig::mBsToExtract()) + " ";
-+ options += "--max-filesize=" + QString("%1").arg(KlamavConfig::mBsToExtract()) + " ";
-
-- if (KlamavConfig::compressionRatio() > 0)
-- options += "--max-ratio=" + QString("%1").arg(KlamavConfig::compressionRatio()) + " ";
-+ if (KlamavConfig::mBsToExtract() > 0 && KlamavConfig::compressionRatio() > 0)
-+ options += "--max-scansize=" + QString("%1").arg(KlamavConfig::mBsToExtract() * KlamavConfig::compressionRatio()) + " ";
-
- if (KlamavConfig::recursionLevel() > 0)
- options += "--max-recursion=" + QString("%1").arg(KlamavConfig::recursionLevel()) + " ";
-
-
- //config->setGroup("Klamscan");
-- if (KlamavConfig::virusLimitsExceeded())
-- options += "--block-max ";
-+// if (KlamavConfig::virusLimitsExceeded())
-+// options += "--block-max ";
-
- if (KlamavConfig::virusEncrypted())
- options += "--block-encrypted ";
diff --git a/security/klamav/files/patch-po b/security/klamav/files/patch-po
index e6f2a04f6ad1..26fa89d32965 100644
--- a/security/klamav/files/patch-po
+++ b/security/klamav/files/patch-po
@@ -5,13 +5,13 @@
"to gain real-time access to files. If you don't want this message to appear "
"in future, put the following command in your initialization scripts: "
-"'modprobe dazuko.o'. You will next be asked for the root password."
-+"'kldload dazuko.ko'. You will next be asked for the root password."
++"'modprobe dazuko.ko'. You will next be asked for the root password."
msgstr ""
"KlamAV potřebuje nejprve zavést modul 'dazuko'. Tento modul KlamAVu umožní "
"přístup k souborům v reálném čase. Pokud nechcete, aby se tato zpráva v "
"budoucnu zobrazovala, přidejte následující řádek do vašeho init skriptu: "
-"'modprobe dazuko.o'. Nyní budete požádáni o heslo roota."
-+"'kldload dazuko.ko'. Nyní budete požádáni o heslo roota."
++"'kldload dazuko.o'. Nyní budete požádáni o heslo roota."
#: klamd.cpp:734 klamd.cpp:735
msgid "Load Module"
@@ -22,7 +22,7 @@
"to gain real-time access to files. If you don't want this message to appear "
"in future, put the following command in your initialization scripts: "
-"'modprobe dazuko.o'. You will next be asked for the root password."
-+"'kldload dazuko.ko'. You will next be asked for the root password."
++"'modprobe dazuko.o'. You will next be asked for the root password."
msgstr ""
"Es muß das Modul mit dem Namen \"dazuko\" geladen werden. Dies ermöglicht "
"einen verbesserten Zugriffn auf die Datein. Wenn sie nicht möchten, dass "
@@ -33,13 +33,13 @@
"to gain real-time access to files. If you don't want this message to appear "
"in future, put the following command in your initialization scripts: "
-"'modprobe dazuko.o'. You will next be asked for the root password."
-+"'kldload dazuko.ko'. You will next be asked for the root password."
++"'kldload dazuko.o'. You will next be asked for the root password."
msgstr ""
"Se necesita cargar un módulo llamado 'dazuko' primero. Este módulo le "
"permite a KlamAV acceso en tiempo real a los ficheros. Si no quiere que este "
"mensaje aparezca en el futuro, ponga lo siguiente en los scripts de "
-"inicialización: 'modprobe dazuko.o'. Necesita la clave de administrador."
-+"inicialización: 'kldload dazuko.ko'. Necesita la clave de administrador."
++"inicialización: 'modprobe dazuko.ko'. Necesita la clave de administrador."
#: klamd.cpp:734 klamd.cpp:735
msgid "Load Module"
@@ -51,7 +51,7 @@
#: klamd.cpp:733
-msgid "I need to load a module called 'dazuko' first. This module will allow KlamAV to gain real-time access to files. If you don't want this message to appear in future, put the following command in your initialization scripts: 'modprobe dazuko.o'. You will next be asked for the root password."
-msgstr "Auparavant, KlamAV a besoin de charger un module appelé 'dazuko'. Ce module permettra un accès temps réel aux fichiers. Si vous ne voulez pas que ce message apparaisse dans le futur, mettez la commande suivante dans vos scripts d'initialisation: 'modprobe dazuko.o'. Il vous sera demander le mot de passe administrateur."
-+msgid "I need to load a module called 'dazuko' first. This module will allow KlamAV to gain real-time access to files. If you don't want this message to appear in future, put the following command in your initialization scripts: 'kldload dazuko.ko'. You will next be asked for the root password."
++msgid "I need to load a module called 'dazuko' first. This module will allow KlamAV to gain real-time access to files. If you don't want this message to appear in future, put the following command in your initialization scripts: 'modprobe dazuko.o'. You will next be asked for the root password."
+msgstr "Auparavant, KlamAV a besoin de charger un module appelé 'dazuko'. Ce module permettra un accès temps réel aux fichiers. Si vous ne voulez pas que ce message apparaisse dans le futur, mettez la commande suivante dans vos scripts d'initialisation: 'kldload dazuko.ko'. Il vous sera demander le mot de passe administrateur."
#: klamd.cpp:734
@@ -63,7 +63,7 @@
"to gain real-time access to files. If you don't want this message to appear "
"in future, put the following command in your initialization scripts: "
-"'modprobe dazuko.o'. You will next be asked for the root password."
-+"'kldload dazuko.ko'. You will next be asked for the root password."
++"'modprobe dazuko.o'. You will next be asked for the root password."
msgstr ""
"Először be kell tölteni a 'dazuko' nevű modult. Ez a modul teszi lehetővé a "
"KlamAV számára a fájlok valós idejű elérését. Ha azt szeretné, hogy ez az "
@@ -81,7 +81,7 @@
"in future, put the following command in your initialization scripts: "
-"'modprobe dazuko.o'. You will next be asked for the root password."
-msgstr "Necessiti dapprima di caricare un modulo chiamato 'dazuko'. Questo modulo permetterà a KlamAv di avere funzionalità 'real time' per l'accesso ai file. Se vuoi che questo messaggio non appaia più in futuro, importa il seguente comando nello script di inizializzazione: 'modprobe dazuko.o'. Per compiere questa azione ti verrà chiesta la password di amministratore."
-+"'kldload dazuko.ko'. You will next be asked for the root password."
++"'modprobe dazuko.o'. You will next be asked for the root password."
+msgstr "Necessiti dapprima di caricare un modulo chiamato 'dazuko'. Questo modulo permetterà a KlamAv di avere funzionalità 'real time' per l'accesso ai file. Se vuoi che questo messaggio non appaia più in futuro, importa il seguente comando nello script di inizializzazione: 'kldload dazuko.ko'. Per compiere questa azione ti verrà chiesta la password di amministratore."
#: klamd.cpp:734 klamd.cpp:735
@@ -93,7 +93,7 @@
"to gain real-time access to files. If you don't want this message to appear "
"in future, put the following command in your initialization scripts: "
-"'modprobe dazuko.o'. You will next be asked for the root password."
-+"'kldload dazuko.ko'. You will next be asked for the root password."
++"'modprobe dazuko.o'. You will next be asked for the root password."
msgstr ""
"Konieczne jest załadowanie najpier modułu Dazuko. Moduł ten pozwoli "
"programowi KlamAV uzyskać dostęp do skanowania plików w czasie rzeczywistym. "
@@ -110,7 +110,7 @@
"to gain real-time access to files. If you don't want this message to appear "
"in future, put the following command in your initialization scripts: "
-"'modprobe dazuko.o'. You will next be asked for the root password."
-+"'kldload dazuko.ko'. You will next be asked for the root password."
++"'modprobe dazuko.o'. You will next be asked for the root password."
msgstr ""
"Preciso carregar um módulo chamado 'dazuko' antes. Este módulo permitirá ao "
"KlamAV obter acesso em tempo real a arquivos. Se não desejar que esta "
@@ -127,7 +127,7 @@
"to gain real-time access to files. If you don't want this message to appear "
"in future, put the following command in your initialization scripts: "
-"'modprobe dazuko.o'. You will next be asked for the root password."
-+"'kldload dazuko.ko'. You will next be asked for the root password."
++"'modprobe dazuko.o'. You will next be asked for the root password."
msgstr ""
"Необходимо запустить модуль, называемый dazuko. Этот модуль разрешит KlamAV "
"получать доступ в реальном времени к файлам. Далее Вас попросят ввести "
@@ -138,7 +138,18 @@
"to gain real-time access to files. If you don't want this message to appear "
"in future, put the following command in your initialization scripts: "
-"'modprobe dazuko.o'. You will next be asked for the root password."
-+"'kldload dazuko.ko'. You will next be asked for the root password."
++"'modprobe dazuko.o'. You will next be asked for the root password."
msgstr ""
#: klamd.cpp:734 klamd.cpp:735
+--- po/tr.po 2008-05-09 15:45:18.000000000 -0300
++++ po/tr.po 2008-05-09 15:48:44.000000000 -0300
+@@ -996,7 +996,7 @@
+ msgstr ""
+ "İlk önce 'dazuko' adlı bir modülü yüklemem gerekiyor. Bu modül KlamAV'ın "
+ "dosyalara gerçek-zamanlı erşimini sağlar.Bu mesajın gelecekte görünmesini "
+-"istemiyorsanız, şu komutu başlangıç betiklerinize ekleyin: 'modprobe dazuko."
++"istemiyorsanız, şu komutu başlangıç betiklerinize ekleyin: 'kldload dazuko.k"
+ "o'. Daha sonra yetkili kullanıcı şifresi sorulacak."
+
+ #: klamd.cpp:734 klamd.cpp:735
diff --git a/security/klamav/pkg-plist b/security/klamav/pkg-plist
index 5b2573513c39..8821481c5411 100644
--- a/security/klamav/pkg-plist
+++ b/security/klamav/pkg-plist
@@ -13,6 +13,7 @@ share/locale/pl/LC_MESSAGES/klamav.mo
share/locale/ru/LC_MESSAGES/klamav.mo
share/locale/pt_BR/LC_MESSAGES/klamav.mo
share/locale/fr/LC_MESSAGES/klamav.mo
+share/locale/tr/LC_MESSAGES/klamav.mo
share/locale/zh_CN/LC_MESSAGES/klamav.mo
bin/klamav
share/apps/klamav/eventsrc