aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2012-08-03 02:30:07 +0000
committerGabor Pali <pgj@FreeBSD.org>2012-08-03 02:30:07 +0000
commitdb8a630740d7952632fca1d12503a442fc625335 (patch)
tree8ee3a15fcf61eb9a77ce79ffe7cc567f6e56e480 /security
parent336cf4f81e31ae43ff7b5ec434e2305615de4392 (diff)
downloadports-db8a630740d7952632fca1d12503a442fc625335.tar.gz
ports-db8a630740d7952632fca1d12503a442fc625335.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/hs-Crypto/Makefile1
-rw-r--r--security/hs-RSA/Makefile13
-rw-r--r--security/hs-SHA/Makefile15
-rw-r--r--security/hs-certificate/Makefile8
-rw-r--r--security/hs-clientsession/Makefile1
-rw-r--r--security/hs-cprng-aes/Makefile2
-rw-r--r--security/hs-crypto-api/Makefile1
-rw-r--r--security/hs-crypto-conduit/Makefile1
-rw-r--r--security/hs-crypto-pubkey-types/Makefile1
-rw-r--r--security/hs-cryptohash/Makefile1
-rw-r--r--security/hs-digest/Makefile1
-rw-r--r--security/hs-entropy/Makefile2
-rw-r--r--security/hs-monadcryptorandom/Makefile1
-rw-r--r--security/hs-pem/Makefile1
-rw-r--r--security/hs-pureMD5/Makefile2
-rw-r--r--security/hs-pwstore-fast/Makefile2
-rw-r--r--security/hs-skein/Makefile1
-rw-r--r--security/hs-tls-extra/Makefile1
-rw-r--r--security/hs-tls/Makefile8
19 files changed, 38 insertions, 25 deletions
diff --git a/security/hs-Crypto/Makefile b/security/hs-Crypto/Makefile
index 06262b6b3d2a..40d91f535e73 100644
--- a/security/hs-Crypto/Makefile
+++ b/security/hs-Crypto/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Crypto
PORTVERSION= 4.2.5
+PORTREVISION= 1
CATEGORIES= security haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/security/hs-RSA/Makefile b/security/hs-RSA/Makefile
index 3ac87e7ca170..30aef7812354 100644
--- a/security/hs-RSA/Makefile
+++ b/security/hs-RSA/Makefile
@@ -7,6 +7,7 @@
PORTNAME= RSA
PORTVERSION= 1.2.1.0
+PORTREVISION= 1
CATEGORIES= security haskell
MAINTAINER= haskell@FreeBSD.org
@@ -17,20 +18,22 @@ LICENSE= BSD
CABAL_SETUP= Setup.hs
USE_CABAL= crypto-api>=0.10 crypto-pubkey-types monadcryptorandom SHA
-OPTIONS= MD5 "Include support for using MD5" on \
- BINARY "Use the binary package for serialization" on
+OPTIONS_DEFINE= MD5 BINARY
+OPTIONS_DEFAULT= MD5 BINARY
+
+MD5_DESC= Include support for using MD5
+BINARY_DESC= Use the binary package for serialization
-.include "${.CURDIR}/../../lang/ghc/bsd.cabal.options.mk"
.include <bsd.port.options.mk>
-.if defined(WITH_MD5)
+.if ${PORT_OPTIONS:MMD5}
CONFIGURE_ARGS+= --flags="IncludeMD5"
USE_CABAL+= pureMD5
.else
CONFIGURE_ARGS+= --flags="-IncludeMD5"
.endif
-.if defined(WITH_BINARY)
+.if ${PORT_OPTIONS:MBINARY}
CONFIGURE_ARGS+= --flags="UseBinary"
.else
CONFIGURE_ARGS+= --flags="-UseBinary"
diff --git a/security/hs-SHA/Makefile b/security/hs-SHA/Makefile
index ae1da19a6562..b696fd0b73a9 100644
--- a/security/hs-SHA/Makefile
+++ b/security/hs-SHA/Makefile
@@ -7,6 +7,7 @@
PORTNAME= SHA
PORTVERSION= 1.5.0.1
+PORTREVISION= 1
CATEGORIES= security haskell
MAINTAINER= haskell@FreeBSD.org
@@ -16,21 +17,15 @@ LICENSE= BSD
CABAL_SETUP= Setup.hs
-OPTIONS= TEST "Build the SHA test suite" off \
- EXE "Build a SHA2-384 executable similar to 'md5sum'" off
+OPTIONS_DEFINE= EXE
+
+EXE_DESC= Build a SHA2-384 executable similar to 'md5sum'
-.include "${.CURDIR}/../../lang/ghc/bsd.cabal.options.mk"
.include <bsd.port.options.mk>
-.if defined(WITH_TEST)
-CONFIGURE_ARGS+= --flags="Test"
-USE_CABAL+= QuickCheck>=2 test-framework>=0.3 test-framework-quickcheck2>=0.2
-EXECUTABLE+= test_sha
-.else
CONFIGURE_ARGS+= --flags="-Test"
-.endif
-.if defined(WITH_EXE)
+.if ${PORT_OPTIONS:MEXE}
CONFIGURE_ARGS+= --flags="exe"
EXECUTABLE+= sha1 sha384
.else
diff --git a/security/hs-certificate/Makefile b/security/hs-certificate/Makefile
index 186b599975a5..c732c661bb31 100644
--- a/security/hs-certificate/Makefile
+++ b/security/hs-certificate/Makefile
@@ -7,6 +7,7 @@
PORTNAME= certificate
PORTVERSION= 1.2.3
+PORTREVISION= 1
CATEGORIES= security haskell
MAINTAINER= haskell@FreeBSD.org
@@ -18,12 +19,13 @@ CABAL_SETUP= Setup.hs
USE_CABAL= asn1-data>=0.6.1.3 crypto-pubkey-types>=0.1 mtl pem>=0.1
-OPTIONS= EXECUTABLE "Build the executable" off
+OPTIONS_DEFINE= EXECUTABLE
+
+EXECUTABLE_DESC= Build the executable
-.include "${.CURDIR}/../../lang/ghc/bsd.cabal.options.mk"
.include <bsd.port.options.mk>
-.if defined(WITH_EXECUTABLE)
+.if ${PORT_OPTIONS:MEXECUTABLE}
CONFIGURE_ARGS+= --flags="executable"
USE_CABAL+= cmdargs text>=0.11 cryptohash cryptocipher>=0.3.0
EXECUTABLE+= certificate
diff --git a/security/hs-clientsession/Makefile b/security/hs-clientsession/Makefile
index d513df039b03..c04a5389deef 100644
--- a/security/hs-clientsession/Makefile
+++ b/security/hs-clientsession/Makefile
@@ -7,6 +7,7 @@
PORTNAME= clientsession
PORTVERSION= 0.7.5
+PORTREVISION= 1
CATEGORIES= security haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/security/hs-cprng-aes/Makefile b/security/hs-cprng-aes/Makefile
index c4b38b81be8f..0ccca95a953b 100644
--- a/security/hs-cprng-aes/Makefile
+++ b/security/hs-cprng-aes/Makefile
@@ -7,7 +7,7 @@
PORTNAME= cprng-aes
PORTVERSION= 0.2.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/security/hs-crypto-api/Makefile b/security/hs-crypto-api/Makefile
index d4535322a3a7..390fb3c78a63 100644
--- a/security/hs-crypto-api/Makefile
+++ b/security/hs-crypto-api/Makefile
@@ -7,6 +7,7 @@
PORTNAME= crypto-api
PORTVERSION= 0.10.2
+PORTREVISION= 1
CATEGORIES= security haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/security/hs-crypto-conduit/Makefile b/security/hs-crypto-conduit/Makefile
index 33db39c274c6..66c28dbc9bdf 100644
--- a/security/hs-crypto-conduit/Makefile
+++ b/security/hs-crypto-conduit/Makefile
@@ -7,6 +7,7 @@
PORTNAME= crypto-conduit
PORTVERSION= 0.3.2
+PORTREVISION= 1
CATEGORIES= security haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/security/hs-crypto-pubkey-types/Makefile b/security/hs-crypto-pubkey-types/Makefile
index 112cf9410444..3de98969aef0 100644
--- a/security/hs-crypto-pubkey-types/Makefile
+++ b/security/hs-crypto-pubkey-types/Makefile
@@ -7,6 +7,7 @@
PORTNAME= crypto-pubkey-types
PORTVERSION= 0.1.1
+PORTREVISION= 1
CATEGORIES= security haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/security/hs-cryptohash/Makefile b/security/hs-cryptohash/Makefile
index ac381ff99887..c8b2f6fed56b 100644
--- a/security/hs-cryptohash/Makefile
+++ b/security/hs-cryptohash/Makefile
@@ -7,6 +7,7 @@
PORTNAME= cryptohash
PORTVERSION= 0.7.5
+PORTREVISION= 1
CATEGORIES= security haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/security/hs-digest/Makefile b/security/hs-digest/Makefile
index b61ea190cab0..1baa1a644594 100644
--- a/security/hs-digest/Makefile
+++ b/security/hs-digest/Makefile
@@ -7,6 +7,7 @@
PORTNAME= digest
PORTVERSION= 0.0.1.1
+PORTREVISION= 1
CATEGORIES= security haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/security/hs-entropy/Makefile b/security/hs-entropy/Makefile
index 3b4ad0784c09..00e91591ce46 100644
--- a/security/hs-entropy/Makefile
+++ b/security/hs-entropy/Makefile
@@ -7,7 +7,7 @@
PORTNAME= entropy
PORTVERSION= 0.2.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/security/hs-monadcryptorandom/Makefile b/security/hs-monadcryptorandom/Makefile
index 36bab79ad77a..cb30acb9fac3 100644
--- a/security/hs-monadcryptorandom/Makefile
+++ b/security/hs-monadcryptorandom/Makefile
@@ -7,6 +7,7 @@
PORTNAME= monadcryptorandom
PORTVERSION= 0.4.1
+PORTREVISION= 1
CATEGORIES= security haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/security/hs-pem/Makefile b/security/hs-pem/Makefile
index 8766696ce471..799cf6c8f721 100644
--- a/security/hs-pem/Makefile
+++ b/security/hs-pem/Makefile
@@ -7,6 +7,7 @@
PORTNAME= pem
PORTVERSION= 0.1.1
+PORTREVISION= 1
CATEGORIES= security haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/security/hs-pureMD5/Makefile b/security/hs-pureMD5/Makefile
index befcc5457e20..baa58982c89a 100644
--- a/security/hs-pureMD5/Makefile
+++ b/security/hs-pureMD5/Makefile
@@ -7,7 +7,7 @@
PORTNAME= pureMD5
PORTVERSION= 2.1.0.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/security/hs-pwstore-fast/Makefile b/security/hs-pwstore-fast/Makefile
index 5fdf0f13df28..ce87c046a09a 100644
--- a/security/hs-pwstore-fast/Makefile
+++ b/security/hs-pwstore-fast/Makefile
@@ -7,7 +7,7 @@
PORTNAME= pwstore-fast
PORTVERSION= 2.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/security/hs-skein/Makefile b/security/hs-skein/Makefile
index 45e18dcab8b2..9cfb15ab670b 100644
--- a/security/hs-skein/Makefile
+++ b/security/hs-skein/Makefile
@@ -7,6 +7,7 @@
PORTNAME= skein
PORTVERSION= 0.1.0.7
+PORTREVISION= 1
CATEGORIES= security haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/security/hs-tls-extra/Makefile b/security/hs-tls-extra/Makefile
index 742ec52c51e5..8195250b1ece 100644
--- a/security/hs-tls-extra/Makefile
+++ b/security/hs-tls-extra/Makefile
@@ -7,6 +7,7 @@
PORTNAME= tls-extra
PORTVERSION= 0.4.6
+PORTREVISION= 1
CATEGORIES= security haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/security/hs-tls/Makefile b/security/hs-tls/Makefile
index 3658ba1761d1..510a2db20a54 100644
--- a/security/hs-tls/Makefile
+++ b/security/hs-tls/Makefile
@@ -7,6 +7,7 @@
PORTNAME= tls
PORTVERSION= 0.9.5
+PORTREVISION= 1
CATEGORIES= security haskell
MAINTAINER= haskell@FreeBSD.org
@@ -19,12 +20,13 @@ CABAL_SETUP= Setup.hs
USE_CABAL= cereal>=0.3 certificate>=1.2.0 crypto-api>=0.5 \
cryptocipher>=0.3.0 cryptohash>=0.6 mtl
-OPTIONS= EXECUTABLE "Build the executables" off
+OPTIONS_DEFINE= EXECUTABLE
+
+EXECUTABLE_DESC= Build the executables
-.include "${.CURDIR}/../../lang/ghc/bsd.cabal.options.mk"
.include <bsd.port.options.mk>
-.if defined(WITH_EXECUTABLE)
+.if ${PORT_OPTIONS:MEXECUTABLE}
CONFIGURE_ARGS+= --flags="executable"
USE_CABAL+= cmdargs cprng-aes>=0.2.3 network
EXECUTABLE+= stunnel checkciphers retrievecertificate simpleclient