aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2002-02-17 15:00:25 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2002-02-17 15:00:25 +0000
commitf90e5def7fe54a3cdab2df7fee006f1e3aa22dbb (patch)
tree0cddc2431be3ffde4d7d86c2033e631e3fa2bbb6 /security
parent1872f119c59ca5e4e974cfadcbdd19627f7ee23e (diff)
Notes
Diffstat (limited to 'security')
-rw-r--r--security/hpn-ssh/Makefile24
-rw-r--r--security/hpn-ssh/distinfo2
-rw-r--r--security/openssh-portable/Makefile24
-rw-r--r--security/openssh-portable/distinfo2
4 files changed, 52 insertions, 0 deletions
diff --git a/security/hpn-ssh/Makefile b/security/hpn-ssh/Makefile
index ead7b3a3db01..8d6fe1acf548 100644
--- a/security/hpn-ssh/Makefile
+++ b/security/hpn-ssh/Makefile
@@ -48,6 +48,30 @@ CONFIGURE_ARGS+= --mandir=${MANPREFIX}/man \
EXTRA_PATCHES+= ${FILESDIR}/batch.patch
.endif
+.if defined(KRB5_HOME)
+MASTER_SITES+= ${PATCH_SITES}
+DISTFILES= ${EXTRACT_ONLY} ${PORTNAME}-${PORTVERSION}-gssapi.patch
+EXTRACT_ONLY= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}
+PATCH_SITES= http://www.sxw.org.uk/computing/patches/
+PATCHFILES= ${PORTNAME}-${PORTVERSION}-krb5.patch
+BUILD_DEPENDS= autoconf:${PORTSDIR}/devel/autoconf
+# USE_AUTOCONF_VER= 252 # broken
+CONFIGURE_ARGS+= --with-kerberos5=${KRB5_HOME}
+AUTOCONF= autoconf
+AUTOHEADER= autoheader
+
+post-patch:
+ @${ECHO_MSG} Applying extra patch for GSS-API key-exchange...
+ @${PATCH} ${PATCH_DIST_ARGS:S/-p0/-p1/} \
+ < ${DISTDIR}/${PORTNAME}-${PORTVERSION}-gssapi.patch
+
+pre-configure:
+ @${ECHO_MSG} !!!! Warning this option uses autoconf/autoheader !!!
+ (cd ${CONFIGURE_WRKSRC} && ${SETENV} ${AUTOCONF_ENV} ${AUTOCONF} \
+ ${AUTOCONF_ARGS})
+ (cd ${CONFIGURE_WRKSRC} && ${SETENV} ${AUTOCONF_ENV} ${AUTOHEADER})
+.endif
+
post-install:
@${CAT} ${PKGMESSAGE}
diff --git a/security/hpn-ssh/distinfo b/security/hpn-ssh/distinfo
index 6bfa94872b46..4f636c0ddd6d 100644
--- a/security/hpn-ssh/distinfo
+++ b/security/hpn-ssh/distinfo
@@ -1 +1,3 @@
MD5 (openssh-3.0.2p1.tar.gz) = 2fa62bf878862cb47a7515c35afe35b6
+MD5 (openssh-3.0.2p1-gssapi.patch) = 66ce171ac4b09603c7069cea198d2090
+MD5 (openssh-3.0.2p1-krb5.patch) = c6fe5622607b3137fa22741897cbd5db
diff --git a/security/openssh-portable/Makefile b/security/openssh-portable/Makefile
index ead7b3a3db01..8d6fe1acf548 100644
--- a/security/openssh-portable/Makefile
+++ b/security/openssh-portable/Makefile
@@ -48,6 +48,30 @@ CONFIGURE_ARGS+= --mandir=${MANPREFIX}/man \
EXTRA_PATCHES+= ${FILESDIR}/batch.patch
.endif
+.if defined(KRB5_HOME)
+MASTER_SITES+= ${PATCH_SITES}
+DISTFILES= ${EXTRACT_ONLY} ${PORTNAME}-${PORTVERSION}-gssapi.patch
+EXTRACT_ONLY= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}
+PATCH_SITES= http://www.sxw.org.uk/computing/patches/
+PATCHFILES= ${PORTNAME}-${PORTVERSION}-krb5.patch
+BUILD_DEPENDS= autoconf:${PORTSDIR}/devel/autoconf
+# USE_AUTOCONF_VER= 252 # broken
+CONFIGURE_ARGS+= --with-kerberos5=${KRB5_HOME}
+AUTOCONF= autoconf
+AUTOHEADER= autoheader
+
+post-patch:
+ @${ECHO_MSG} Applying extra patch for GSS-API key-exchange...
+ @${PATCH} ${PATCH_DIST_ARGS:S/-p0/-p1/} \
+ < ${DISTDIR}/${PORTNAME}-${PORTVERSION}-gssapi.patch
+
+pre-configure:
+ @${ECHO_MSG} !!!! Warning this option uses autoconf/autoheader !!!
+ (cd ${CONFIGURE_WRKSRC} && ${SETENV} ${AUTOCONF_ENV} ${AUTOCONF} \
+ ${AUTOCONF_ARGS})
+ (cd ${CONFIGURE_WRKSRC} && ${SETENV} ${AUTOCONF_ENV} ${AUTOHEADER})
+.endif
+
post-install:
@${CAT} ${PKGMESSAGE}
diff --git a/security/openssh-portable/distinfo b/security/openssh-portable/distinfo
index 6bfa94872b46..4f636c0ddd6d 100644
--- a/security/openssh-portable/distinfo
+++ b/security/openssh-portable/distinfo
@@ -1 +1,3 @@
MD5 (openssh-3.0.2p1.tar.gz) = 2fa62bf878862cb47a7515c35afe35b6
+MD5 (openssh-3.0.2p1-gssapi.patch) = 66ce171ac4b09603c7069cea198d2090
+MD5 (openssh-3.0.2p1-krb5.patch) = c6fe5622607b3137fa22741897cbd5db