aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2013-03-22 20:06:14 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2013-03-22 20:06:14 +0000
commitffd97a0193e0238aa21bc32b570fd052292e0fe5 (patch)
treeb368198f913179c06dafd19ac72527fcf9836f6d /security
parentccbdf54cacb9796580726f8d5278fe3fa53d5e53 (diff)
Notes
Diffstat (limited to 'security')
-rw-r--r--security/bro/Makefile2
-rw-r--r--security/ike/Makefile3
-rw-r--r--security/libssh/Makefile2
-rw-r--r--security/nmapsi4/Makefile2
-rw-r--r--security/quantis/Makefile2
-rw-r--r--security/spass/Makefile2
6 files changed, 6 insertions, 7 deletions
diff --git a/security/bro/Makefile b/security/bro/Makefile
index fbca9812ea60..a4a61ea8b8f8 100644
--- a/security/bro/Makefile
+++ b/security/bro/Makefile
@@ -14,7 +14,7 @@ BUILD_DEPENDS= bison:${PORTSDIR}/devel/bison \
LIB_DEPENDS= GeoIP:${PORTSDIR}/net/GeoIP
USE_PERL5= yes
-USE_CMAKE= yes
+USES= cmake
CONFIGURE_WRKSRC= ${WRKSRC}/build
BUILD_WRKSRC= ${CONFIGURE_WRKSRC}
INSTALL_WRKSRC= ${CONFIGURE_WRKSRC}
diff --git a/security/ike/Makefile b/security/ike/Makefile
index 290eef91476e..bc5c8f922789 100644
--- a/security/ike/Makefile
+++ b/security/ike/Makefile
@@ -15,9 +15,8 @@ COMMENT= Shrew Soft IKE daemon and client tools
ONLY_FOR_ARCHS= i386 amd64
USE_RC_SUBR= iked
-USES= bison
+USES= bison cmake
USE_OPENSSL= yes
-USE_CMAKE= yes
USE_BZIP2= yes
USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
diff --git a/security/libssh/Makefile b/security/libssh/Makefile
index e492f5dd923b..42e2a87a5bb7 100644
--- a/security/libssh/Makefile
+++ b/security/libssh/Makefile
@@ -15,7 +15,7 @@ GCRYPT_DESC= Build with libgcrypt
SSH1_DESC= Build with SSH1 support
MAKE_JOBS_SAFE= yes
-USE_CMAKE= yes
+USES= cmake
CMAKE_SOURCE_PATH= ${WRKSRC}
CONFIGURE_WRKSRC= ${CMAKE_SOURCE_PATH}/build
BUILD_WRKSRC= ${CONFIGURE_WRKSRC}
diff --git a/security/nmapsi4/Makefile b/security/nmapsi4/Makefile
index a62142e09c7f..49747e47e982 100644
--- a/security/nmapsi4/Makefile
+++ b/security/nmapsi4/Makefile
@@ -18,7 +18,7 @@ LICENSE= GPLv2
RUN_DEPENDS= ${LOCALBASE}/bin/nmap:${PORTSDIR}/security/nmap
-USE_CMAKE= yes
+USES= cmake
USE_BZIP2= yes
INSTALLS_ICONS= yes
USE_QT4= gui xml qmake_build uic_build moc_build rcc_build network \
diff --git a/security/quantis/Makefile b/security/quantis/Makefile
index b58c184e34c8..ac23ea8db106 100644
--- a/security/quantis/Makefile
+++ b/security/quantis/Makefile
@@ -29,7 +29,7 @@ GUI_DESC= Build QT4 GUI for EasyQuantis application
USE_ZIP= yes
EXTRACT_BEFORE_ARGS= -aqo
-USE_CMAKE= yes
+USES= cmake
USE_QT4= # empty but required
USE_LDCONFIG= yes
diff --git a/security/spass/Makefile b/security/spass/Makefile
index c98feed49535..4f8a7350efc9 100644
--- a/security/spass/Makefile
+++ b/security/spass/Makefile
@@ -19,7 +19,7 @@ GH_ACCOUNT= guyru
GH_TAGNAME= cb0de64
GH_COMMIT= cb0de64
-USE_CMAKE= yes
+USES= cmake
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib