aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2017-05-22 22:29:17 +0000
committerMark Linimon <linimon@FreeBSD.org>2017-05-22 22:29:17 +0000
commit197f08abf4fd25e8493f6391ed2c5cac9671e9bb (patch)
treeac17d1ab15d23a2dc3fe9bfd156a7ffcf551a8e7 /security
parent6b97e9ecbf788aed773a5284b3624b26725f6e67 (diff)
downloadports-197f08abf4fd25e8493f6391ed2c5cac9671e9bb.tar.gz
ports-197f08abf4fd25e8493f6391ed2c5cac9671e9bb.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/arirang/Makefile2
-rw-r--r--security/dsniff/Makefile2
-rw-r--r--security/pecl-crypto/Makefile4
-rw-r--r--security/pidentd/Makefile2
-rw-r--r--security/quantis-kmod/Makefile2
-rw-r--r--security/revealrk/Makefile2
-rw-r--r--security/titus/Makefile2
7 files changed, 16 insertions, 0 deletions
diff --git a/security/arirang/Makefile b/security/arirang/Makefile
index 4c43bbb96dbf..04a01c8b8d56 100644
--- a/security/arirang/Makefile
+++ b/security/arirang/Makefile
@@ -15,6 +15,8 @@ LICENSE= BSD3CLAUSE
LIB_DEPENDS= lib${RUBY_NAME}.so:${RUBY_PORT}
+BROKEN_powerpc64= fails to compile: ruby.h: wrong number of arguments specified for 'deprecated' attribute
+
USES= ssl
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
diff --git a/security/dsniff/Makefile b/security/dsniff/Makefile
index b3c7ff523abb..893b34ea86d2 100644
--- a/security/dsniff/Makefile
+++ b/security/dsniff/Makefile
@@ -16,6 +16,8 @@ LICENSE= BSD3CLAUSE
LIB_DEPENDS= libnet.so:net/libnet
BUILD_DEPENDS= ${LOCALBASE}/lib/libnids.a:net/libnids
+BROKEN_FreeBSD_12= fails to compile: pcaputil.c: '/usr/include/pcap-int.h' file not found
+
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-libnet=${LOCALBASE}
DESTDIRNAME= install_prefix
diff --git a/security/pecl-crypto/Makefile b/security/pecl-crypto/Makefile
index 1da5764d5ea4..f0550fb7dc9d 100644
--- a/security/pecl-crypto/Makefile
+++ b/security/pecl-crypto/Makefile
@@ -10,6 +10,10 @@ COMMENT= Objective wrapper for OpenSSL Crypto Library
LICENSE= PHP301
+BROKEN_mips= fails to configure: C compiler cannot create executables
+BROKEN_mips64= fails to configure: C compiler cannot create executables
+BROKEN_powerpc64= fails to configure: C compiler cannot create executables
+
USES= php:pecl
CONFIGURE_ARGS= --with-crypto
CFLAGS+= -I${OPENSSLINC}
diff --git a/security/pidentd/Makefile b/security/pidentd/Makefile
index 603d850969b3..2a8b44a59512 100644
--- a/security/pidentd/Makefile
+++ b/security/pidentd/Makefile
@@ -16,6 +16,8 @@ PATCH_DIST_STRIP= -p0
MAINTAINER= johans@FreeBSD.org
COMMENT= RFC1413 identification server
+BROKEN_FreeBSD_12= fails to compile: k_freebsd2.c: storage size of 'pcbp' isn't known
+
CONFLICTS_INSTALL= fakeident-[0-9]*
GNU_CONFIGURE= yes
diff --git a/security/quantis-kmod/Makefile b/security/quantis-kmod/Makefile
index ed32888d1cb4..6bbea7c23379 100644
--- a/security/quantis-kmod/Makefile
+++ b/security/quantis-kmod/Makefile
@@ -16,6 +16,8 @@ LICENSE= BSD3CLAUSE GPLv2
LICENSE_COMB= dual
LICENSE_FILE= ${WRKDIR}/Quantis-${DISTVERSION}/License.txt
+BROKEN_powerpc64= fails to compile: pcpu.h: size of array '__assert_0' is negative
+
USES= kmod uidfix zip:infozip
EXTRACT_BEFORE_ARGS= -aqo
diff --git a/security/revealrk/Makefile b/security/revealrk/Makefile
index a691803b8bc6..c9af6dbed2f7 100644
--- a/security/revealrk/Makefile
+++ b/security/revealrk/Makefile
@@ -10,6 +10,8 @@ COMMENT= Search hidden procs/rootkits from cron with low false positive rate
LICENSE= GPLv3
+BROKEN_FreeBSD_12= fails to compile: revealrk.c: 'struct xtcpcb' has no member named 'xt_socket'
+
PLIST_FILES= bin/revealrk man/man1/revealrk.1.gz
USES= scons tar:tgz
diff --git a/security/titus/Makefile b/security/titus/Makefile
index 235841dfdfd9..35e9ed8300b7 100644
--- a/security/titus/Makefile
+++ b/security/titus/Makefile
@@ -11,6 +11,8 @@ COMMENT= TLS/SSL proxy server
LICENSE= MIT
+BROKEN_powerpc64= fails to compile: child.cpp: undefined reference to std::__cxx11::basic_string
+
USES= compiler:c++11-lang ssl
USE_RC_SUBR= titus