aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-03-10 17:01:36 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-03-10 17:01:36 +0000
commit8a7c77fbbd57ecbfd89783ebd805b59f8f2387a8 (patch)
tree6d9bf2c42239eb7fa59e3a370ddfad85fecabb87 /security
parentae7708b169aa040d2d1177a4ca193ed6a8d60e5d (diff)
downloadports-8a7c77fbbd57ecbfd89783ebd805b59f8f2387a8.tar.gz
ports-8a7c77fbbd57ecbfd89783ebd805b59f8f2387a8.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/bsp_upektfmess/Makefile3
-rw-r--r--security/chntpw/Makefile3
-rw-r--r--security/cryptlib/Makefile2
-rw-r--r--security/cryptopp/Makefile3
-rw-r--r--security/dirbuster/Makefile2
-rw-r--r--security/httprint/Makefile2
-rw-r--r--security/iaikpkcs11wrapper/Makefile5
-rw-r--r--security/jbrofuzz/Makefile2
-rw-r--r--security/mindterm-binary/Makefile2
-rw-r--r--security/phpsecinfo/Makefile2
-rw-r--r--security/py-AccessControl/Makefile2
-rw-r--r--security/py-Products.PlonePAS/Makefile3
-rw-r--r--security/py-RestrictedPython/Makefile2
-rw-r--r--security/py-borg.localrole/Makefile2
-rw-r--r--security/py-keyring/Makefile2
-rw-r--r--security/py-plone.keyring/Makefile2
-rw-r--r--security/py-plone.openid/Makefile2
-rw-r--r--security/py-plone.protect/Makefile2
-rw-r--r--security/py-plone.session/Makefile2
-rw-r--r--security/py-zope.authentication/Makefile2
-rw-r--r--security/py-zope.login/Makefile2
-rw-r--r--security/quantis-kmod/Makefile2
-rw-r--r--security/quantis/Makefile3
-rw-r--r--security/webscarab/Makefile2
-rw-r--r--security/xml-security/Makefile2
-rw-r--r--security/xorsearch/Makefile2
-rw-r--r--security/yassl/Makefile2
27 files changed, 28 insertions, 34 deletions
diff --git a/security/bsp_upektfmess/Makefile b/security/bsp_upektfmess/Makefile
index c4eec4146690..b37933485c51 100644
--- a/security/bsp_upektfmess/Makefile
+++ b/security/bsp_upektfmess/Makefile
@@ -17,9 +17,8 @@ RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/xext.pc:${PORTSDIR}/x11/libXext
PLIST_FILES= lib/libtfmessbsp.so
-USE_ZIP= yes
USE_LDCONFIG= yes
-USES= gettext iconv
+USES= gettext iconv zip
# Maintainer note
# Both the gui and the non-gui object are linked to libX11
USE_XORG= x11 xext
diff --git a/security/chntpw/Makefile b/security/chntpw/Makefile
index ac00e05d4c4a..0d9ac1293a1e 100644
--- a/security/chntpw/Makefile
+++ b/security/chntpw/Makefile
@@ -15,9 +15,8 @@ LICENSE= GPLv2
OPTIONS_DEFINE= DOCS
-USE_ZIP= yes
USE_OPENSSL= yes
-USES= gmake
+USES= gmake zip
ONLY_FOR_ARCHS= i386 amd64
diff --git a/security/cryptlib/Makefile b/security/cryptlib/Makefile
index 2f2a2b5b0f80..23ee7cca5bf1 100644
--- a/security/cryptlib/Makefile
+++ b/security/cryptlib/Makefile
@@ -14,7 +14,7 @@ ONLY_FOR_ARCHS= i386 amd64
OPTIONS_DEFINE= DOCS
-USE_ZIP= yes
+USES= zip
EXTRACT_BEFORE_ARGS= -aq
NO_WRKSUBDIR= yes
MAKEFILE= makefile
diff --git a/security/cryptopp/Makefile b/security/cryptopp/Makefile
index 6bf3de48dd7f..556c6146b49a 100644
--- a/security/cryptopp/Makefile
+++ b/security/cryptopp/Makefile
@@ -20,9 +20,8 @@ GCC_DESC= Build with current GCC
.include <bsd.port.options.mk>
NO_WRKSUBDIR= yes
-USE_ZIP= yes
EXTRACT_BEFORE_ARGS= -aq
-USES= gmake
+USES= gmake zip
MAKEFILE= GNUmakefile
LIBVERSION= 0
diff --git a/security/dirbuster/Makefile b/security/dirbuster/Makefile
index 0c0448256c33..6c1d692f5dcd 100644
--- a/security/dirbuster/Makefile
+++ b/security/dirbuster/Makefile
@@ -10,7 +10,7 @@ DISTNAME= DirBuster-1.0-RC1
MAINTAINER= ports@FreeBSD.org
COMMENT= DirBuster allows file and directory brute forcing on web servers
-USE_ZIP= YES
+USES= zip
USE_JAVA= YES
JAVA_VERSION= 1.6+
NO_BUILD= yes
diff --git a/security/httprint/Makefile b/security/httprint/Makefile
index 068b67247d12..55a3053289f6 100644
--- a/security/httprint/Makefile
+++ b/security/httprint/Makefile
@@ -11,7 +11,7 @@ MAINTAINER= onatan@gmail.com
COMMENT= Web server fingerprinting tool
WRKSRC= ${WRKDIR}/${PORTNAME}_${PORTVERSION}/freebsd/
-USE_ZIP= yes
+USES= zip
RESTRICTED= No cost for personal, education and non-commercial use.
NO_BUILD= yes
diff --git a/security/iaikpkcs11wrapper/Makefile b/security/iaikpkcs11wrapper/Makefile
index 3664751748a6..cda85e003b46 100644
--- a/security/iaikpkcs11wrapper/Makefile
+++ b/security/iaikpkcs11wrapper/Makefile
@@ -13,12 +13,11 @@ COMMENT= PKCS\#11 Java wrapper
OPTIONS_DEFINE= DOCS EXAMPLES
-USE_ZIP= yes
+USES= dos2unix gmake zip
USE_JAVA= yes
-USE_DOS2UNIX= Makefile
+DOS2UNIX_FILES= Makefile
JAVA_VERSION= 1.6+
JAVA_OS= native
-USE_GMAKE= yes
ALL_TARGET= release
PLIST_FILES= lib/libpkcs11wrapper.so %%JAVAJARDIR%%/iaikPkcs11Wrapper.jar
diff --git a/security/jbrofuzz/Makefile b/security/jbrofuzz/Makefile
index 6f1d5e9070f6..5716d930d38a 100644
--- a/security/jbrofuzz/Makefile
+++ b/security/jbrofuzz/Makefile
@@ -10,7 +10,7 @@ DISTNAME= ${PORTNAME}-jar-21
MAINTAINER= ports@FreeBSD.org
COMMENT= JBroFuzz is a web application fuzzer
-USE_ZIP= YES
+USES= zip
USE_JAVA= YES
NO_BUILD= YES
JAVA_VERSION= 1.6+
diff --git a/security/mindterm-binary/Makefile b/security/mindterm-binary/Makefile
index b9396b2e4645..69603f754eef 100644
--- a/security/mindterm-binary/Makefile
+++ b/security/mindterm-binary/Makefile
@@ -14,7 +14,7 @@ EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= ports@FreeBSD.org
COMMENT= Full vt220 compatible Java SSH-1 client (not only for websites)
-USE_ZIP= yes
+USES= zip
NO_WRKSUBDIR= yes
NO_BUILD= yes
NO_CDROM= Do not sell for profit
diff --git a/security/phpsecinfo/Makefile b/security/phpsecinfo/Makefile
index d3003d8b1315..f8ec73eb7b7e 100644
--- a/security/phpsecinfo/Makefile
+++ b/security/phpsecinfo/Makefile
@@ -9,7 +9,7 @@ MASTER_SITES= LOCAL/chinsan
MAINTAINER= ports@FreeBSD.org
COMMENT= PHP environment security auditing tool
-USE_ZIP= yes
+USES= zip
USE_PHP= pcre
WANT_PHP_WEB= yes
NO_BUILD= yes
diff --git a/security/py-AccessControl/Makefile b/security/py-AccessControl/Makefile
index f856a23ba7c8..044cd3ded4dc 100644
--- a/security/py-AccessControl/Makefile
+++ b/security/py-AccessControl/Makefile
@@ -31,9 +31,9 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Acquisition>=0:${PORTSDIR}/devel/py-Acquisit
${PYTHON_PKGNAMEPREFIX}zope.security>=0:${PORTSDIR}/security/py-zope.security \
${PYTHON_PKGNAMEPREFIX}zope.testing>=0:${PORTSDIR}/devel/py-zope.testing
+USES= zip
USE_PYTHON= 2
USE_PYDISTUTILS= yes
PYDISTUTILS_AUTOPLIST= yes
-USE_ZIP= yes
.include <bsd.port.mk>
diff --git a/security/py-Products.PlonePAS/Makefile b/security/py-Products.PlonePAS/Makefile
index fe53249bb88c..404b2164af96 100644
--- a/security/py-Products.PlonePAS/Makefile
+++ b/security/py-Products.PlonePAS/Makefile
@@ -23,7 +23,6 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}plone.memoize>=0:${PORTSDIR}/www/py-plone.me
USE_PYTHON= 2
USE_PYDISTUTILS= yes
PYDISTUTILS_AUTOPLIST= yes
-USE_ZIP= yes
-USES= zope
+USES= zope zip
.include <bsd.port.mk>
diff --git a/security/py-RestrictedPython/Makefile b/security/py-RestrictedPython/Makefile
index a7a49062594e..a32636989507 100644
--- a/security/py-RestrictedPython/Makefile
+++ b/security/py-RestrictedPython/Makefile
@@ -13,9 +13,9 @@ COMMENT= Restricted execution environment for Python
LICENSE= ZPL21
+USES= zip
USE_PYTHON= 2
USE_PYDISTUTILS= yes
PYDISTUTILS_AUTOPLIST= yes
-USE_ZIP= yes
.include <bsd.port.mk>
diff --git a/security/py-borg.localrole/Makefile b/security/py-borg.localrole/Makefile
index 7f1ea3f31bde..379f24ef3051 100644
--- a/security/py-borg.localrole/Makefile
+++ b/security/py-borg.localrole/Makefile
@@ -24,10 +24,10 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}zope.annotation>=0:${PORTSDIR}/devel/py-zope
${PYTHON_PKGNAMEPREFIX}plone.memoize>=0:${PORTSDIR}/www/py-plone.memoize \
${PYTHON_PKGNAMEPREFIX}Acquisition>=0:${PORTSDIR}/devel/py-Acquisition
+USES= zip
USE_PYTHON= yes
USE_PYDISTUTILS= yes
PYDISTUTILS_AUTOPLIST= yes
-USE_ZIP= yes
#USE_ZOPE= yes
.include <bsd.port.mk>
diff --git a/security/py-keyring/Makefile b/security/py-keyring/Makefile
index 486b9f1bef4e..544a0dfcbfdf 100644
--- a/security/py-keyring/Makefile
+++ b/security/py-keyring/Makefile
@@ -16,7 +16,7 @@ BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest-runner>0:${PORTSDIR}/devel/py-pytes
LATEST_LINK= py-${PORTNAME}
-USE_ZIP= yes
+USES= zip
USE_PYTHON= yes
USE_PYDISTUTILS= easy_install
PYDISTUTILS_AUTOPLIST= yes
diff --git a/security/py-plone.keyring/Makefile b/security/py-plone.keyring/Makefile
index be00d413605a..edd25f7e5347 100644
--- a/security/py-plone.keyring/Makefile
+++ b/security/py-plone.keyring/Makefile
@@ -18,9 +18,9 @@ RUN_DEPENDS= zodb${PYTHON_PKGNAMESUFFIX}>=0:${PORTSDIR}/databases/zodb3 \
${PYTHON_PKGNAMEPREFIX}zope.interface>=0:${PORTSDIR}/devel/py-zope.interface \
${PYTHON_PKGNAMEPREFIX}zope.location>=0:${PORTSDIR}/devel/py-zope.location
+USES= zip
USE_PYTHON= yes
USE_PYDISTUTILS= yes
PYDISTUTILS_AUTOPLIST= yes
-USE_ZIP= yes
.include <bsd.port.mk>
diff --git a/security/py-plone.openid/Makefile b/security/py-plone.openid/Makefile
index c4a282b020cd..7b29232e8f0f 100644
--- a/security/py-plone.openid/Makefile
+++ b/security/py-plone.openid/Makefile
@@ -19,10 +19,10 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}openid>=0:${PORTSDIR}/security/py-openid \
${PYTHON_PKGNAMEPREFIX}Products.PluggableAuthService>=0:${PORTSDIR}/security/py-Products.PluggableAuthService \
zodb${PYTHON_PKGNAMESUFFIX}>=0:${PORTSDIR}/databases/zodb3
+USES= zip
USE_PYTHON= yes
USE_PYDISTUTILS= yes
PYDISTUTILS_AUTOPLIST= yes
-USE_ZIP= yes
#USES= zope
.include <bsd.port.mk>
diff --git a/security/py-plone.protect/Makefile b/security/py-plone.protect/Makefile
index f1ea4d9ab63c..1460c07d1064 100644
--- a/security/py-plone.protect/Makefile
+++ b/security/py-plone.protect/Makefile
@@ -17,10 +17,10 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}plone.keyring>1.0:${PORTSDIR}/security/py-pl
${PYTHON_PKGNAMEPREFIX}zope.component>=0:${PORTSDIR}/devel/py-zope.component \
${PYTHON_PKGNAMEPREFIX}zope.interface>=0:${PORTSDIR}/devel/py-zope.interface
+USES= zip
USE_PYTHON= yes
USE_PYDISTUTILS= yes
PYDISTUTILS_AUTOPLIST= yes
-USE_ZIP= yes
#USES= zope
.include <bsd.port.mk>
diff --git a/security/py-plone.session/Makefile b/security/py-plone.session/Makefile
index 3a8660de8c57..43d24b892038 100644
--- a/security/py-plone.session/Makefile
+++ b/security/py-plone.session/Makefile
@@ -18,10 +18,10 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}plone.protect>=0:${PORTSDIR}/security/py-plo
${PYTHON_PKGNAMEPREFIX}zope.interface>=0:${PORTSDIR}/devel/py-zope.interface \
${PYTHON_PKGNAMEPREFIX}Products.PluggableAuthService>=0:${PORTSDIR}/security/py-Products.PluggableAuthService
+USES= zip
USE_PYTHON= yes
USE_PYDISTUTILS= yes
PYDISTUTILS_AUTOPLIST= yes
-USE_ZIP= yes
#USES= zope
.include <bsd.port.mk>
diff --git a/security/py-zope.authentication/Makefile b/security/py-zope.authentication/Makefile
index 99b5f665fe97..c82d1fe7b167 100644
--- a/security/py-zope.authentication/Makefile
+++ b/security/py-zope.authentication/Makefile
@@ -20,9 +20,9 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}zope.browser>=0:${PORTSDIR}/devel/py-zope.br
${PYTHON_PKGNAMEPREFIX}zope.schema>=0:${PORTSDIR}/devel/py-zope.schema \
${PYTHON_PKGNAMEPREFIX}zope.security>=0:${PORTSDIR}/security/py-zope.security
+USES= zip
USE_PYTHON= yes
USE_PYDISTUTILS= yes
PYDISTUTILS_AUTOPLIST= yes
-USE_ZIP= yes
.include <bsd.port.mk>
diff --git a/security/py-zope.login/Makefile b/security/py-zope.login/Makefile
index 655050d63ac7..80176753d8a1 100644
--- a/security/py-zope.login/Makefile
+++ b/security/py-zope.login/Makefile
@@ -18,9 +18,9 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}zope.authentication>=0:${PORTSDIR}/security/
${PYTHON_PKGNAMEPREFIX}zope.interface>=0:${PORTSDIR}/devel/py-zope.interface \
${PYTHON_PKGNAMEPREFIX}zope.publisher>=0:${PORTSDIR}/devel/py-zope.publisher
+USES= zip
USE_PYTHON= yes
USE_PYDISTUTILS= yes
PYDISTUTILS_AUTOPLIST= yes
-USE_ZIP= yes
.include <bsd.port.mk>
diff --git a/security/quantis-kmod/Makefile b/security/quantis-kmod/Makefile
index b847735883e8..510d1b64af3f 100644
--- a/security/quantis-kmod/Makefile
+++ b/security/quantis-kmod/Makefile
@@ -17,7 +17,7 @@ LICENSE= BSD3CLAUSE GPLv2
LICENSE_COMB= dual
LICENSE_FILE= ${WRKDIR}/Quantis-${DISTVERSION}/License.txt
-USE_ZIP= yes
+USES= zip:infozip
EXTRACT_BEFORE_ARGS= -aqo
WRKSRC= ${WRKDIR}/Quantis-${DISTVERSION}/Drivers/Unix/QuantisPci
diff --git a/security/quantis/Makefile b/security/quantis/Makefile
index 77848398ff19..0ce1a1294c40 100644
--- a/security/quantis/Makefile
+++ b/security/quantis/Makefile
@@ -27,9 +27,8 @@ COMPAT_DESC= Build API v1 compatibility libraries
TOOL_DESC= Build EasyQuantis application
GUI_DESC= Build QT4 GUI for EasyQuantis application
-USE_ZIP= yes
EXTRACT_BEFORE_ARGS= -aqo
-USES= cmake
+USES= cmake zip:infozip
USE_QT4= # empty but required
USE_LDCONFIG= yes
diff --git a/security/webscarab/Makefile b/security/webscarab/Makefile
index 0cf77aa6be59..f23673168ad0 100644
--- a/security/webscarab/Makefile
+++ b/security/webscarab/Makefile
@@ -11,7 +11,7 @@ MASTER_SITE_SUBDIR= niels
MAINTAINER= ports@FreeBSD.org
COMMENT= Framework for analysing HTTP and HTTPS web application traffic
-USE_ZIP= YES
+USES= zip
USE_JAVA= YES
JAVA_VERSION= 1.6+
NO_BUILD= yes
diff --git a/security/xml-security/Makefile b/security/xml-security/Makefile
index 323cef707aa6..e0703fdbed8c 100644
--- a/security/xml-security/Makefile
+++ b/security/xml-security/Makefile
@@ -18,7 +18,7 @@ RUN_DEPENDS= ${JAVALIBDIR}/commons-logging.jar:${PORTSDIR}/java/jakarta-commons-
LICENSE= APACHE20
OPTIONS_DEFINE= DOCS EXAMPLES
-USE_ZIP= yes
+USES= zip
USE_JAVA= yes
JAVA_VERSION= 1.6+
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:S/./_/g}
diff --git a/security/xorsearch/Makefile b/security/xorsearch/Makefile
index c1edbb98bacd..2f290977a854 100644
--- a/security/xorsearch/Makefile
+++ b/security/xorsearch/Makefile
@@ -10,7 +10,7 @@ DISTNAME= XORSearch_V1_2_0
MAINTAINER= edwin@mavetju.org
COMMENT= Search for a given string in an XOR or ROL encoded binary file
-USE_ZIP= yes
+USES= zip
WRKSRC= ${WRKDIR}
PLIST_FILES= bin/xorsearch
diff --git a/security/yassl/Makefile b/security/yassl/Makefile
index 087375d8cace..ab5872354a2c 100644
--- a/security/yassl/Makefile
+++ b/security/yassl/Makefile
@@ -10,7 +10,7 @@ COMMENT= Embedded SSL C-Library
LICENSE= GPLv2
-USE_ZIP= yes
+USES= zip
USE_AUTOTOOLS= libtool
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-dependency-tracking \